Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

python-heatclient version for OpenStack X Release

Hi,

I know how we can check version for OpenStack services and python--clients. However I don't know (and I could not find) what is min required version of python-client for specific OpenStack release.

Example:

  • I had Juno release which had installed python-heatclient 0.2.10 and I had some problems with that version, some http errors similar to below occured during stack creation:

    {"explanation": "The server could not comply with the request since it is either malformed or otherwise incorrect.", "code": 400, "error": {"message": "The Parameter (test) was not provided.", "traceback": null, "type": "UserParameterMissing"}, "title": "Bad Request"}

When I updated python-heatclient to 0.2.12 the problem dissapeard. Do we have any reference where I can find min required versions of python-*clients for OpenStack releases?

Regards, ZJ

    -