Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

show ERROR state after input "nova list"

    I set up two VMs in VMWare 9.0 . I define two VMnets on this software as follows:

[VMnet3]:

Subnet IP : 192.168.0.0

Subnet mask:255.255.255.0

Use local DHCP service to distribute IP address to VMs , Start IP Address: 192.168.0.10 and End IP Address:192.168.0.254

[VMnet4]:

Subnet IP : 10.0.0.0

Subnet mask:255.255.255.0

Use local DHCP service to distribute IP address to VMs , Start IP Address: 10.0.0.10 and End IP Address:10.0.0.254

OS: RedHat 6.4, this VM have Three Network Adapter

  1st Adapter : 192.168.0.10, Assigned to VMnet3

  2nd Adapter: 10.0.0.10, Assigned to VMnet 4

  3rd Adapter: Network connection is NAT: Used to share the host's IP address, which is used for access the internet

OS: RedHat 6.4, this VM have Three Network Adapter

  1st Adapter : 192.168.0.11, Assigned to VMnet3

  2nd Adapter: 10.0.0.11, Assigned to VMnet 4

  3rd Adapter: Network connection is NAT: Used to share the host's IP address, which is used for access the internet

Now when I configured the network according to the section called "Enable Networking", I input the following command on the controller Node :

    "nova network-create vmnet --fixed-range-v4=10.0.0.0/24 --bridge-interface=br100 --multi-host=T"

I just get following result:

    ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-5bfa03e4-d1b6-4551-89f2-b63a3cef210d)

and the final result is as follows:

    $ nova boot --flavor 1 --key_name mykey --image 42865945-5523-4f79-80e1-de735f6d6cf3 --security_group default cirrOS

+--------------------------------------+--------------------------------------+

| Property | Value |

+--------------------------------------+--------------------------------------+

| OS-EXT-STS:task_state | scheduling |

| image | CirrOS 0.3.1 |

| OS-EXT-STS:vm_state | building |

| OS-EXT-SRV-ATTR:instance_name | instance-00000001 |

| OS-SRV-USG:launched_at | None |

| flavor | m1.tiny |

| id | ce2f7aef-7505-4c3a-8749-c072b0a5fc9e |

| security_groups | [{u'name': u'default'}] |

| user_id | d9c2c83ef3be46c1bae727a210783beb |

| OS-DCF:diskConfig | MANUAL |

| accessIPv4 | |

| accessIPv6 | |

| progress | 0 |

| OS-EXT-STS:power_state | 0 |

| OS-EXT-AZ:availability_zone | nova |

| config_drive | |

| status | BUILD |

| updated | 2013-11-30T16:09:04Z |

| hostId | |

| OS-EXT-SRV-ATTR:host | None |

| OS-SRV-USG:terminated_at | None |

| key_name | mykey |

| OS-EXT-SRV-ATTR:hypervisor_hostname | None |

| name | cirrOS |

| adminPass | eh8bCkSvwigN |

| tenant_id | 533624ab076a4289b4910cf9a4809bfe |

| created | 2013-11-30T16:09:03Z |

| os-extended-volumes:volumes_attached | [] |

| metadata | {} |

+--------------------------------------+--------------------------------------+

    $nova list

+--------------------------------------+--------+--------+------------+-------------+----------+

| ID | Name | Status | Task State | Power State | Networks |

+--------------------------------------+--------+--------+------------+-------------+----------+

| ce2f7aef-7505-4c3a-8749-c072b0a5fc9e | cirrOS | ERROR | None | NOSTATE | |

+--------------------------------------+--------+--------+------------+-------------+----------+

I think I maybe confused with the network configuration, What can I do to solve this problem? Please help me. Thanks for your help.