Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

authentication fails

Hi! I've installed OpenStack kilo and it works fine. Then I set emal addresses for the users demo and admin within horizon. Now I cannot login to horizon again - neither as admin user, nor as demo user - and even the CLI rejects all commands, e.g.

controller:~# openstack user list ERROR: openstack The request you have made requires authentication. (HTTP 401) (Request-ID: req-4e91b899-3659-4bca-81a8-fc39294ae2fd)

Changing the admin password doesn't work, too. When I unset OS_PASSWORD the command prompts for a password, but neither the admin password, nor the auth_token from keystone.conf are accepted and the command terminates with the same erroor message.

Is there a way to reset the passwords or to reinitialize the user database?

Thanks Willi

authentication fails

Hi! I've installed OpenStack kilo and it works fine. Then I set emal email addresses for the users demo and admin within horizon. Now I cannot login to horizon again - neither as admin user, nor as demo user - and even the CLI rejects all commands, e.g.

controller:~# openstack user list ERROR: openstack The request you have made requires authentication. (HTTP 401) (Request-ID: req-4e91b899-3659-4bca-81a8-fc39294ae2fd)

Changing the admin password doesn't work, too. When I unset OS_PASSWORD the command prompts for a password, but neither the admin password, nor the auth_token from keystone.conf are accepted and the command terminates with the same erroor error message.

Is there a way to reset the passwords or to reinitialize the user database?

Thanks Willi