Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

instance can't get IP from dhcp agent when using linux bridge plugin

Hi list,

I'm working under CentOS 6.4 + Havana.

I'm using neutron with core_plugin = neutron.plugins.linuxbridge.lb_neutron_plugin.LinuxBridgePluginV2

And, I have created a network with VLAN ID = 2002.

After an instance created, everything works fine, but the instance can't get IP from DHCP agent.

On the machine which is running dhcp agent:

    brctl show
    bridge name bridge id STP enabled interfaces
    brq5e04f269-94 8000.1239a4bc0e67 no eth4.2002
                                                            tap4647c381-05

    tcpdump -i eth4.2002
    15:47:58.339767 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from fa:16:3e:80:53:02 (oui Unknown), length 300

    tcpdump -i tap4647c381-05
    .... nothing ........

Anyone know why this happen ????

Thanks. -chen

click to hide/show revision 2
No.2 Revision

instance can't get IP from dhcp agent when using linux bridge plugin

Hi list,

I'm working under CentOS 6.4 + Havana.

I'm using neutron with core_plugin = neutron.plugins.linuxbridge.lb_neutron_plugin.LinuxBridgePluginV2

And, I have created a network with VLAN ID = 2002.

After an instance created, everything works fine, but the instance can't get IP from DHCP agent.

On the machine which is running dhcp agent:

    brctl show
    bridge name bridge id STP enabled interfaces
    brq5e04f269-94 8000.1239a4bc0e67 no eth4.2002
                                                            tap4647c381-05

    tcpdump -i eth4.2002
    15:47:58.339767 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from fa:16:3e:80:53:02 (oui Unknown), length 300

    tcpdump -i tap4647c381-05
    .... nothing ........

$ ip link 
6:  eth4: <broadcast,multicast,up,lower_up> mtu 1500 qdisc mq state UP qlen 1000 
    link/ether 90:e2:ba:42:41:c4 brd ff:ff:ff:ff:ff:ff 
93: tap4647c381-05: <broadcast,multicast,up,lower_up> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 12:39:a4:bc:0e:67 brd ff:ff:ff:ff:ff:ff
94: eth4.2002@eth4: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UP 
    link/ether 90:e2:ba:42:41:c4 brd ff:ff:ff:ff:ff:ff 
95: brq5e04f269-94: <broadcast,multicast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether 12:39:a4:bc:0e:67 brd ff:ff:ff:ff:ff:ff

Anyone know why this happen ????

Thanks. -chen