Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How do I add correct endpoint for heat in Devstack

I've installed and configured Devstack as per DevStack quickstart instructions. I've also added the heat configuration to the localrc and didn't bother with Celiometer or OS Profiler. So running the

source openrc

Command, returns an empty line.

But the

heat stack-list

returns the usual error when the service is not a registered endpoint in keystone:

publicURL endpoint for orchestration service in RegionOne region not found

So, I create the service in keystone with the openstack CLI v.1.5.0 (replacing the deprecated keystone CLI)

openstack service create --os-username admin --os-password password --name heat --description Orchestration orchestration

I get a successful service creation

+-------------+----------------------------------+ | Field | Value | +-------------+----------------------------------+ | description | Orchestration | | enabled | True | | id | dded3ea6a93d4cc09144539a0dedd60d | | name | heat | | type | orchestration | +-------------+----------------------------------+

(pardon the formatting)

So now I can (with the new ID created during service registration) create an endpoint in keystone using the openstack CLI. The problem is that I don't know what format to use during endpoint creating. I've tried a variation on the following:

openstack endpoint create --os-username admin --os-password password--publicurl http://10.0.2.15:8004/v1 --internalurl http://10.0.2.15:8004/v1 --adminurl http://10.0.2.15:8004/v1 --region RegionOne heat

[note: I've seen the %(tenant_id)s used in these commands in Keystone, but some services have them some done. The parenthesis seem to give syntactical problems.]

This creates an endpoint successfully:

+--------------+----------------------------------+ | Field | Value | +--------------+----------------------------------+ | adminurl | http://10.0.2.15:8004/v1 | | id | 10ec9bbd66374b1c9bbe494de29ad357 | | internalurl | http://10.0.2.15:8004/v1 | | publicurl | http://10.0.2.15:8004/v1 | | region | RegionOne | | service_id | dded3ea6a93d4cc09144539a0dedd60d | | service_name | heat | | service_type | orchestration | +--------------+----------------------------------+

Now, when I give the command:

heat stack-list

I only get the following:

Unable to establish connection to http://10.0.2.15:8004/v1/stacks?

So, I'm wondering if I have the correct command/parameter format. The parenthesis seem to be an issue, but other services do not have the (tenant_id)s with them, so I don't know if this is important. Examples in the updated documentation would be useful.

Cheers derek

How do I add correct endpoint for heat in Devstack

I've installed and configured Devstack as per DevStack quickstart instructions. I've also added the heat configuration to the localrc and didn't bother with Celiometer or OS Profiler. So running the

source openrc

openrc

Command, returns an empty line.

But the

heat stack-list

stack-list

returns the usual error when the service is not a registered endpoint in keystone:

publicURL endpoint for orchestration service in RegionOne region not found

found

So, I create the service in keystone with the openstack CLI v.1.5.0 (replacing the deprecated keystone CLI)

openstack service create --os-username admin --os-password password *password* --name heat --description Orchestration orchestration

orchestration

I get a successful service creation

+-------------+----------------------------------+
| Field       | Value                            |
+-------------+----------------------------------+
| description | Orchestration                    |
| enabled     | True                             |
| id          | dded3ea6a93d4cc09144539a0dedd60d |
| name        | heat                             |
| type        | orchestration                    |
+-------------+----------------------------------+

+-------------+----------------------------------+

(pardon the formatting)

So now I can (with the new ID created during service registration) create an endpoint in keystone using the openstack CLI. The problem is that I don't know what format to use during endpoint creating. I've tried a variation on the following:

openstack endpoint create --os-username admin --os-password password--publicurl *password*--publicurl http://10.0.2.15:8004/v1 --internalurl http://10.0.2.15:8004/v1 --adminurl http://10.0.2.15:8004/v1 --region RegionOne heat

heat

[note: I've seen the %(tenant_id)s used in these commands in Keystone, but some services have them some done. The parenthesis seem to give syntactical problems.]

This creates an endpoint successfully:

+--------------+----------------------------------+
| Field        | Value                            |
+--------------+----------------------------------+
| adminurl     | http://10.0.2.15:8004/v1         |
| id           | 10ec9bbd66374b1c9bbe494de29ad357 |
| internalurl  | http://10.0.2.15:8004/v1         |
| publicurl    | http://10.0.2.15:8004/v1         |
| region       | RegionOne                        |
| service_id   | dded3ea6a93d4cc09144539a0dedd60d |
| service_name | heat                             |
| service_type | orchestration                    |
+--------------+----------------------------------+

+--------------+----------------------------------+

Now, when I give the command:

heat stack-list

stack-list

I only get the following:

Unable to establish connection to http://10.0.2.15:8004/v1/stacks?

http://10.0.2.15:8004/v1/stacks?

So, I'm wondering if I have the correct command/parameter format. The parenthesis seem to be an issue, but other services do not have the (tenant_id)s with them, so I don't know if this is important. Examples in the updated documentation would be useful.

Cheers derek