Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

throughput of tenant network lower than of external network?

Hello,

I'm doing some traffic measurement on VM instances created in OpenStack Juno. I'm using a standard OpenStack configuration with 3 interfaces: Management, Data and External networks.

The Data (em1) and External (em3) interface have bandwidth of 10Gbps and 1Gbps. So intra-network VMs located in 2 different Compute nodes should have much higher data transfer throughput if they use em1 instead of em3. In other words, connecting to private tenant network IP address (east-west traffic) should be much faster than floating IP.

Weird thing is that, while throughput measured with data transfer using Floating IP (via em3) is about 550-800 Mbps (say, 60-80% of the achievable throughput), the throughput measured via Tenant network (em1) is only ~400Mbps (out of 10Gbps that the host compute node is able to reach).

Anybody could guess what configuration could make it wrong? I personally don't think that OpenStack limits the data tenant interface while maximise external network interface.

Thank you!

throughput of tenant network lower than of external network?

Hello,

I'm doing some traffic measurement on VM instances created in OpenStack Juno. I'm using a standard OpenStack configuration with 3 interfaces: Management, Data and External networks.

The Data (em1) and External (em3) interface have bandwidth of 10Gbps and 1Gbps. So intra-network VMs located in 2 different Compute nodes should have much higher data transfer throughput if they use em1 instead of em3. In other words, connecting to private tenant network IP address (east-west traffic) should be much faster than floating IP.

Weird thing is that, while throughput measured with data transfer using Floating IP (via em3) is about 550-800 Mbps (say, 60-80% of the achievable throughput), the throughput measured via Tenant network (em1) is only ~400Mbps (out of 10Gbps that the host compute node is able to reach).

Anybody could guess what configuration could make it wrong? I personally don't think that OpenStack limits the data tenant interface while maximise maximises external network interface.

Thank you!