Ask Your Question

Revision history [back]

nova-compute start: XML error: Missing CPU model name

Hello,

I am trying to install the latest version of OpenStack following the OpenStack documentation. I am using a Xen Server with a Debian with Xen as Domain-0. I created three virtual machines (Ubuntu Server 14.04 LTS) with xen-tools and I followed the OpenStack guide with the basic 3 nodes setup. In chapter 5, trying to setting up the Compute Node I cannot start the nova-compute service and trying to debug it I discovered it has this error:

/var/log/nova/nova-compute.log:

2015-06-25 14:27:39.345 8176 TRACE nova.openstack.common.threadgroup if ret is None: raise libvirtError ('virConnectBaselineCPU() failed', conn=self)

2015-06-25 14:27:39.345 8176 TRACE nova.openstack.common.threadgroup libvirtError: XML error: Missing CPU model name

I think I have did everything right.

/etc/nova/nova-compute.conf:

    [DEFAULT]
    compute_driver=libvirt.LibvirtDriver
    [libvirt]
    virt_type=qemu

/etc/nova/nova.conf:

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata
rpc_backend = rabbit
rabbit_host = controller
rabbit_password = giallorabbit
auth_strategy = keystone
my_ip = 10.0.0.31
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.0.31
novncproxy_base_url = http://controller:6080/vnc_auto.html
verbose = True


[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = nova
admin_password = giallo

[glance]
host = controller

nova-compute start: XML error: Missing CPU model name

Hello,

I am trying to install the latest version of OpenStack following the OpenStack documentation. I am using a Xen Server with a Debian with Xen as Domain-0. I created three virtual machines (Ubuntu Server 14.04 LTS) with xen-tools and I followed the OpenStack guide with the basic 3 nodes setup. In chapter 5, trying to setting up the Compute Node I cannot start the nova-compute service and trying to debug it I discovered it has this error:

/var/log/nova/nova-compute.log:

2015-06-25 14:27:39.345 8176 TRACE nova.openstack.common.threadgroup if ret is None: raise libvirtError ('virConnectBaselineCPU() failed', conn=self)

2015-06-25 14:27:39.345 8176 TRACE nova.openstack.common.threadgroup libvirtError: XML error: Missing CPU model name

I think I have did everything right.

/etc/nova/nova-compute.conf:

    [DEFAULT]
    compute_driver=libvirt.LibvirtDriver
    [libvirt]
    virt_type=qemu

/etc/nova/nova.conf:

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata
rpc_backend = rabbit
rabbit_host = controller
rabbit_password = giallorabbit
rabbit_password
auth_strategy = keystone
my_ip = 10.0.0.31
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.0.0.31
novncproxy_base_url = http://controller:6080/vnc_auto.html
verbose = True


[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = nova
admin_password = giallo
admin_password

[glance]
host = controller