Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Getting Error while opening horizon dashboard

Hi All,

I have installed Openstack on Solaris 11.2 in virualbox. Earlier i was able to access the horizon dashboard with glance user but now i am getting error on the browser. Below is the part of error. If you need complete log i can post the same.

unsupported operand type(s) for +: 'NoneType' and 'str'Request Method: GET Request URL: http://192.168.56.50/horizon/admin/ Django Version: 1.4.11 Exception Type: TypeError Exception Value: unsupported operand type(s) for +: 'NoneType' and 'str' Exception Location: /usr/lib/python2.6/vendor-packages/openstack_dashboard/wsgi/../../neutronclient/client.py in authenticate, line 231 Python Executable: /usr/bin/python Python Version: 2.6.8 Python Path: ['/usr/lib/python2.6/vendor-packages/openstack_dashboard/wsgi/../..', '/usr/lib/python26.zip', '/usr/lib/python2.6', '/usr/lib/python2.6/plat-sunos5', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/lib/python2.6/site-packages', '/usr/lib/python2.6/vendor-packages', '/usr/lib/python2.6/vendor-packages/PIL', '/usr/lib/python2.6/vendor-packages/openstack_dashboard']

Any idea what has gone wrong .

Getting Error while opening horizon dashboard

Hi All,

I have installed Openstack on Solaris 11.2 in virualbox. Earlier i was able to access the horizon dashboard with glance user but now i am getting error on the browser. Below is the part of error. If you need complete log i can post the same.

unsupported operand type(s) for +: 'NoneType' and 'str'Request Method: GET 
Request URL: http://192.168.56.50/horizon/admin/ 
Django Version: 1.4.11 
Exception Type: TypeError 
Exception Value: unsupported operand type(s) for +: 'NoneType' and 'str' 
Exception Location: /usr/lib/python2.6/vendor-packages/openstack_dashboard/wsgi/../../neutronclient/client.py in authenticate, line 231 
Python Executable: /usr/bin/python 
Python Version: 2.6.8 
Python Path: ['/usr/lib/python2.6/vendor-packages/openstack_dashboard/wsgi/../..',
 '/usr/lib/python26.zip',
 '/usr/lib/python2.6',
 '/usr/lib/python2.6/plat-sunos5',
 '/usr/lib/python2.6/lib-tk',
 '/usr/lib/python2.6/lib-old',
 '/usr/lib/python2.6/lib-dynload',
 '/usr/lib/python2.6/site-packages',
 '/usr/lib/python2.6/vendor-packages',
 '/usr/lib/python2.6/vendor-packages/PIL',
 '/usr/lib/python2.6/vendor-packages/openstack_dashboard'] 

'/usr/lib/python2.6/vendor-packages/openstack_dashboard']

Any idea what has gone wrong .