Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

disable dhcp-authoritative in dnsmasq

Hi All,

So I just recently upgraded our private cloud from Juno to Kilo and immediately we started to see bizarre problems on our network here. I have our private cloud setup as a flat provider network and was using dhcp quite happily for the openstack vms and there was no conflict with our dhcp server for the rest of the (non-openstack) network.

Immediately after upgrade I start to notice a physical hosts on the network not picking up IP addresses and when sniffing the traffic saw a lot of "wrong server-id" and "address not available" messages which I have tracked back to , I believe, dnsmasq now acting authoritatively on the network.

I cannot find where this is configured so I can turn it off on my flat networks...

Please Help!

disable dhcp-authoritative in dnsmasq

Hi All,

So I just recently upgraded our private cloud from Juno to Kilo and immediately we started to see bizarre problems on our network here. I have our private cloud setup as a flat provider network and was using dhcp quite happily for the openstack vms and there was no conflict with our dhcp server for the rest of the (non-openstack) network.

Immediately after upgrade I start to notice a physical hosts on the network not picking up IP addresses and when sniffing the traffic saw a lot of "wrong server-id" and "address not available" messages which I have tracked back to , I believe, dnsmasq now acting authoritatively on the network.

I cannot find where this is configured so I can turn it off on my flat networks...

Please Help!

EDIT: Answer my question. edit the file :/usr/lib/python2.7/site-packages/neutron/agent/linux/dhcp.py

disable dhcp-authoritative in dnsmasq

Hi All,

So I just recently upgraded our private cloud from Juno to Kilo and immediately we started to see bizarre problems on our network here. I have our private cloud setup as a flat provider network and was using dhcp quite happily for the openstack vms and there was no conflict with our dhcp server for the rest of the (non-openstack) network.

Immediately after upgrade I start to notice a physical hosts on the network not picking up IP addresses and when sniffing the traffic saw a lot of "wrong server-id" and "address not available" messages which I have tracked back to , I believe, dnsmasq now acting authoritatively on the network.

I cannot find where this is configured so I can turn it off on my flat networks...

Please Help!

EDIT: Answer my own question. edit the file :/usr/lib/python2.7/site-packages/neutron/agent/linux/dhcp.py