Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Error: could not install dependencies - tempest

Hello,

Can anyone advise if they have encountered the below error when running devstack. The devstack deployment I am trying to implement is a multi-node stack with

1 control node vm, 1 compute node vm and opendaylight running on the host

vm's are running on Ubuntu server 14.04 LTS in virtualbox

I start Opendaylight in the host before trying to stack the controller node but receive the below error

summary ____________________________________ 2015-06-11 18:37:14.820 | ERROR: venv: could not install deps [-r/opt/stack/tempest/requirements.txt, -r/opt/stack/tempest/test-requirements.txt]; v = InvocationError('/opt/stack/tempest/.tox/venv/bin/pip install -U -r/opt/stack/tempest/requirements.txt -r/opt/stack/tempest/test-requirements.txt (see /opt/stack/tempest/.tox/venv/log/venv-1.log)', 2)

Have tried, "upgrading setuptools within the virtualenv" (sudo pip install -U virtualenv), as a workaround according to bug fix - https://bugs.launchpad.net/tempest/+bug/1405579 - but I am still receiving the same error