Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

nova-compute unable to start with version instance not supported error

Hi,

In my environment, I have a hyper-v running as compute node, and linux running with devstack (latest codebase) as a controller node. I created a vhd image in glance, now trying to boot that image using “$nova boot …args” command, its Task Status remains in “Spawning” for some time then goes in ERROR state(from $nova list).

I checked the the nova-compute logs(on compute node) there is error related to “Version 1.10 of Instance is not supported” http://paste.openstack.org/show/50774/

I am running latest devstack code base on controller.

I tried running with Havana and Grizzly hyper-v nova msi as well for compute, getting the same error on both cases.

I am not able to understand what is the version mismatch here? nova or vm instance or glance version ? After this step my nova-compute is not able to come up at all, and always throws the same error.

Any pointers will be appreciated .

Thanks in advance.

-Swapnil