Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

No valid host was found

I am trying to get a simple cirrus VM up on a kilo implementation on CentOS with two nodes. One controller and one compute. I get a 'No valid host was found' in the nova-conductor.log file.

My nova service list output is: +----+------------------+-----------+----------+---------+-------+----------------------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | +----+------------------+-----------+----------+---------+-------+----------------------------+-----------------+ | 1 | nova-consoleauth | anders-38 | internal | enabled | up | 2015-06-01T12:52:53.000000 | - | | 2 | nova-conductor | anders-38 | internal | enabled | up | 2015-06-01T12:52:53.000000 | - | | 3 | nova-scheduler | anders-38 | internal | enabled | up | 2015-06-01T12:52:53.000000 | - | | 4 | nova-cert | anders-38 | internal | enabled | up | 2015-06-01T12:52:53.000000 | - | | 5 | nova-compute | anders-21 | nova | enabled | up | 2015-06-01T12:52:57.000000 | - | | 6 | nova-network | anders-21 | internal | enabled | up | 2015-06-01T12:52:57.000000 | - | +----+------------------+-----------+----------+---------+-------+----------------------------+-----------------+ [root@anders-21 ~]#

my nova hypervisor-stats output is: [root@anders-21 ~]# nova hypervisor-stats +----------------------+-------+ | Property | Value | +----------------------+-------+ | count | 1 | | current_workload | 0 | | disk_available_least | 91 | | free_disk_gb | 104 | | free_ram_mb | 14789 | | local_gb | 105 | | local_gb_used | 1 | | memory_mb | 15813 | | memory_mb_used | 1024 | | running_vms | 1 | | vcpus | 8 | | vcpus_used | 1 | +----------------------+-------+

Any ideas? Thanks! Don

No valid host was found

I am trying to get a simple cirrus VM up on a kilo implementation on CentOS with two nodes. One controller and one compute. I get a 'No valid host was found' in the nova-conductor.log file.

My nova service list output is: is:

+----+------------------+-----------+----------+---------+-------+----------------------------+-----------------+
| Id | Binary           | Host      | Zone     | Status  | State | Updated_at                 | Disabled Reason |
+----+------------------+-----------+----------+---------+-------+----------------------------+-----------------+
| 1  | nova-consoleauth | anders-38 | internal | enabled | up    | 2015-06-01T12:52:53.000000 | -               |
| 2  | nova-conductor   | anders-38 | internal | enabled | up    | 2015-06-01T12:52:53.000000 | -               |
| 3  | nova-scheduler   | anders-38 | internal | enabled | up    | 2015-06-01T12:52:53.000000 | -               |
| 4  | nova-cert        | anders-38 | internal | enabled | up    | 2015-06-01T12:52:53.000000 | -               |
| 5  | nova-compute     | anders-21 | nova     | enabled | up    | 2015-06-01T12:52:57.000000 | -               |
| 6  | nova-network     | anders-21 | internal | enabled | up    | 2015-06-01T12:52:57.000000 | -               |
+----+------------------+-----------+----------+---------+-------+----------------------------+-----------------+

[root@anders-21 ~]#

my nova hypervisor-stats output is:
[root@anders-21 ~]# nova hypervisor-stats
+----------------------+-------+
| Property             | Value |
+----------------------+-------+
| count                | 1     |
| current_workload     | 0     |
| disk_available_least | 91    |
| free_disk_gb         | 104   |
| free_ram_mb          | 14789 |
| local_gb             | 105   |
| local_gb_used        | 1     |
| memory_mb            | 15813 |
| memory_mb_used       | 1024  |
| running_vms          | 1     |
| vcpus                | 8     |
| vcpus_used           | 1     |
+----------------------+-------+

+----------------------+-------+

Any ideas? Thanks! Don