Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

RDO Kilo - No Pkg of ironic-conductor

Hello,

I'm trying to setup Kilo by RDO in three nodes(controller, compute, network). During packstack installation, following error message was output.

10.32.37.47_ironic.pp:                            [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 10.32.37.47_ironic.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list openstack-ironic-conductor' returned 1: Error: No matching Packages to list
You will find full trace in log /var/tmp/packstack/20150526-164515-bTdbtG/manifests/10.32.37.47_ironic.pp.log
Please check log file /var/tmp/packstack/20150526-164515-bTdbtG/openstack-setup.log for more information

Relevant repo of openstack-kilo of RDO and epel has been already added.

# yum repolist | awk '{print $1}'
base/7/x86_64
epel/x86_64
extras/7/x86_64
openstack-kilo
updates/7/x86_64

No openstack-ironic-* pkg

# yum search openstack-ironic
Warning: No matches found for: openstack-ironic
No matches found

Relevant bug (already fixed) https://bugzilla.redhat.com/show_bug.cgi?id=1187343

There is ironic puppet modules.

 # ll /usr/share/openstack-puppet/modules/ironic/
total 40
drwxr-xr-x 2 root root  4096 May 26 16:01 examples
-rw-r--r-- 1 root root   758 May 16 00:36 Gemfile
drwxr-xr-x 3 root root  4096 May 26 16:01 lib
-rw-r--r-- 1 root root 10143 May 16 00:36 LICENSE
drwxr-xr-x 5 root root  4096 May 26 16:01 manifests
-rw-r--r-- 1 root root  1312 May 16 00:36 metadata.json
-rw-r--r-- 1 root root   303 May 16 00:36 Rakefile
-rw-r--r-- 1 root root  1751 May 16 00:36 README.md

How fix this issue? Any ides would be helpful for me.

Thank you.