Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

neutron network dnsmasq not reachable behind bridge

Am trying to setup an Neutron network environment that would allow my client machines be able to PXE boot using neutron DHCP PXE support.

  • I setup neutron with DHCP and PXE + TFTP options in my controller node.
  • I created a neutron network and a subnet.
  • I see that neutron created the network and the DNSMASQ is running under a namespace on a TAP interface under the OVS integration bridge.
  • To test this I run a dhclient from one of my client VMs and the client machine/VM don't get an IP.

However if I manually run a dnsmasq directly on my controller's NIC outside the integration bridge my clients can get an IP. The moment I attach the interface to a bridge my client machines can no longer communicate with the dnsmasq running on the interface. Can someone point out what am I missing ?

I also tried the following --

  • Assigning the integration bridge (br-int) a static IP in the subnet range as TAP interface.
  • Adding default gateway for bridge IP.
  • Adding default gateway for interface IP.
  • Disabling IP tables fully.

None of these seem to help.

neutron network dnsmasq not reachable behind bridge

Am trying to setup an Neutron network environment that would allow my client machines be able to PXE boot using neutron DHCP PXE support.

  • I setup neutron with DHCP and PXE + TFTP options in my controller node.
  • I created a neutron network and a subnet.
  • I see that neutron created the network and the DNSMASQ is running under a namespace on a TAP interface under the OVS integration bridge.
  • To test this I run a dhclient from one of my client VMs and the client machine/VM don't get an IP.

However if I manually run a dnsmasq directly on my controller's NIC outside the integration bridge my clients can get an IP. The moment I attach the interface to a bridge my client machines can no longer communicate with the dnsmasq running on the interface. Can someone point out what am I missing ?

I also tried the following --

  • Assigning the integration bridge (br-int) a static IP in the subnet range as TAP interface.
  • Adding default gateway for bridge IP.
  • Adding default gateway for interface IP.
  • Disabling IP tables fully.

None of these seem to help.