Ask Your Question

Revision history [back]

Horizon dashboard not using local_settings

I'm very new to openstack, I've done a few test installs of icehouse, and now am trying juno on centos7.

I'm stopped at horizon setup, did what was in the doc (BTW cannot fully understand System Requirements items)

And now am at verify operation stage and it's not working.

I get "Bad Request (400)" on the browser. I have modified /etc/openstack-dashboard/local_settings file (also tried to rename file with .py) and it's not loaded, as with "ALLOWED_HOSTS = ['*']" I still get that in my log files :

[Wed May 13 13:39:20.527210 2015] [:error] [pid 3772] Invalid HTTP_HOST header: 'ctrl'. You may need to add u'ctrl' to ALLOWED_HOSTS.

I verified the fact by modifying /usr/lib/python2.7/site-packages/django/http/request.py to display allowed_hosts:

[Wed May 13 13:39:20.527090 2015] [:error] [pid 3772] allowed_hosts: ['horizon.example.com', 'localhost']

and forcing it to ['*'] in that file makes the thing work, so why is my local_settings file not loaded ?

Can someone explain what I have missed ?