Revision history [back]

click to hide/show revision 1
initial version

Juno controller random reboot or crash

Team, I am in the process of deploying a multi-node cluster with openstack juno on centos/RHEL 7.0. Finished the full deployment. Found 2 different issues. ( All the services are on controller & computes on each compute node )

  • I couldn't get the VM/instances to get internal IP assigned. Booting back on default kernel "3.10.0-123.el7" resolved the issue.

  • Once I resolve the above issue. Creating VM randomly crashes the controller node. Sometimes I can completely create a VM without any issues sometimes the first time I create it crashes the controller. Sometimes even without creating a VM it crashes the controllers.

    • After the reboot, the controller node shows the compute-services down but the compute services are up and running on the compute nodes.

Tried with 3 different hardware sets, just to eliminate any hardware related issues. Don't see much of an error in neutron or nova related logs. Did anyone notice such issue?

Thank you Chakri

Juno controller random reboot or crash

Team, I am in the process of deploying a multi-node cluster with openstack juno on centos/RHEL 7.0. Finished the full deployment. Found 2 different issues. ( All the services are on controller & computes on each compute node )

  • I couldn't get the VM/instances to get internal IP assigned. Booting back on default kernel "3.10.0-123.el7" resolved the issue.

  • Once I resolve the above issue. Creating VM randomly crashes the controller node. Sometimes I can completely create a VM without any issues sometimes the first time I create it crashes the controller. Sometimes even without creating a VM it crashes the controllers.

    • After the reboot, the controller node shows the compute-services down but the compute services are up and running on the compute nodes.

Tried with 3 different hardware sets, just to eliminate any hardware related issues. Don't see much of an error in neutron or nova related logs. Did anyone notice such issue?

Thank you Chakri