Ask Your Question

Revision history [back]

euca-run-instances naming problem

I am trying to create new instances on an OpenStack Grizzly deployment and I have found something very weird on the naming conventions.

When I run euca-run-instances ami-00000003 -t HLT_prod_4cores -n 1 I get a response of:

INSTANCE i-000f8ab8 ami-00000003 server-edd4b50f-bff2-49e4-b230-ca44be25e21f

But when I run for whatever instance -n > 1: euca-run-instances ami-00000003 -t HLT_prod_4cores -n 4 I get some hashes in the name that are repeated:

INSTANCE i-000f8aac ami-00000003 server-e94045e0-76c1-4aae-a736-ed3083e68d8b-e94045e0-76c1-4aae-a736-ed3083e68d8b

INSTANCE i-000f8aaf ami-00000003 server-e0c3939b-36ca-4a2f-8ba1-5f4fe4793e9d-e0c3939b-36ca-4a2f-8ba1-5f4fe4793e9d

INSTANCE i-000f8ab2 ami-00000003 server-488b2910-3205-4d18-9e3e-85105b1e6b49-488b2910-3205-4d18-9e3e-85105b1e6b49

INSTANCE i-000f8ab5 ami-00000003 server-f42436d7-d421-4936-b3f9-a756cc4325b2-f42436d7-d421-4936-b3f9-a756cc4325b2

Is this a bug of Grizzly's version? Is it fixed on newer versions? Or there is something more that I don't know?

P.S.: Nova version: 2013.1.2-1.el6