Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

issue regarding port mirroring

I have an openstack juno setup with one server as controller+neutron and other three servers as compute node. I am doing port mirroring on br-int of one compute node. I noticed that incoming packets from VM on other compute node where not getting captured on the mirrored port. The incoming packets from other VM on the same compute node where getting captured.

qvo5fa64d30-2e is the br-int interface which I had mirrored using the commands as below:

ip link add name snooper2 type dummy
ip link set dev snooper2 up
ovs-vsctl add-port br-int snooper2

ovs-vsctl -- set Bridge br-int mirrors=@m  -- --id=@snooper2 \
get Port snooper2  -- --id=@qvo5fa64d30-2e get Port qvo5fa64d30-2e  \
-- --id=@m create Mirror name=mymirror select-dst-port=@qvo5fa64d30-2e \
select-src-port=@qvo5fa64d30-2e output-port=@snooper2

Can someone please help me solve this issue.

issue regarding port mirroring

I have an openstack juno setup with one server as controller+neutron and other three servers as compute node. I am doing port mirroring on br-int of one compute node. I noticed that incoming packets from VM on other compute node where not getting captured on the mirrored port. The incoming packets from other VM on the same compute node where getting captured.

qvo5fa64d30-2e is the br-int interface which I had mirrored using the commands as below:

ip link add name snooper2 type dummy
ip link set dev snooper2 up
ovs-vsctl add-port br-int snooper2

When I mirror the traffic on br-tun patch-tun I notice the incoming request but no outgoing messages.

ovs-vsctl -- set Bridge br-int mirrors=@m  -- --id=@snooper2 \
get Port snooper2  -- --id=@qvo5fa64d30-2e get Port qvo5fa64d30-2e  \
-- --id=@m create Mirror name=mymirror select-dst-port=@qvo5fa64d30-2e \
select-src-port=@qvo5fa64d30-2e output-port=@snooper2

Can someone please help me solve this issue.

issue regarding port mirroring

I have an openstack juno setup with one server as controller+neutron and other three servers as compute node. I am doing port mirroring on br-int of one compute node. I noticed that incoming packets from VM on other compute node where not getting captured on the mirrored port. The incoming packets from other VM on the same compute node where getting captured.

qvo5fa64d30-2e is the br-int interface which I had mirrored using the commands as below:

ip link add name snooper2 type dummy
ip link set dev snooper2 up
ovs-vsctl add-port br-int snooper2

When I mirror the traffic on br-tun patch-tun I notice the incoming request but no outgoing messages.

 ovs-vsctl -- set Bridge br-int mirrors=@m  -- --id=@snooper2 \
get Port snooper2  -- --id=@qvo5fa64d30-2e get Port qvo5fa64d30-2e  \
-- --id=@m create Mirror name=mymirror select-dst-port=@qvo5fa64d30-2e \
select-src-port=@qvo5fa64d30-2e output-port=@snooper2

When I mirror the traffic on br-tun patch-tun I notice the incoming request but no outgoing messages. That is only outgoing packets are captured in br-int and only incoming packets are captured in br-tun.

Can someone please help me solve this issue.issue. Thanks in advance.