Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Invalid OpenStack Identity credentials

I am following the guide given in this link http://docs.openstack.org/havana/install-guide/install/apt/content/ch_keystone.html

First time when I followed the steps given in the guid, I was able to create users, tenants and all the verify steps given in the document worked for me. I went on to install glance and I faced some problems. So, I went through a couple of forums and they asked me to run this command

keystone --os-tenant-name service --os-username admin --os-password KEY_PASS --os-auth-url http://localhost:35357/v2.0 user-list

This one worked for me before. However, it was not working after I installed glance ( The problem in glance was I was getting HTTPInternalServerError (HTTP 500) error. I did unset http_proxy and that is when the issue started)

I have tried the methods given in the following links https://openstack.redhat.com/forum/discussion/351/keystone-auth-failing-unable-to-communicate-with-identity-service/p1 (I changed the port to 5000 as mentioned in the above link but it did not work)

https://ask.openstack.org/en/question/9620/how-to-resolve-keystone-error/ (I deleted the token and user, this too did not work)

The error log is present at this link http://pastebin.com/ymw8BKyV

I tried this command following the solution given in one of the forums

keystone --os-username=admin --os-password=ADMIN_PASS --os-auth-url=http://localhost:35357/v2.0 token-get

I get the error saying 'NoneType' object has no attribute 'has_service_catalog' Can someone help me resolve this issue?

Invalid OpenStack Identity credentials

I am following the guide given in this link http://docs.openstack.org/havana/install-guide/install/apt/content/ch_keystone.html

First time when I followed the steps given in the guid, I was able to create users, tenants and all the verify steps given in the document worked for me. I went on to install glance and I faced some problems. So, I went through a couple of forums and they asked me to run this command

keystone --os-tenant-name service --os-username admin --os-password KEY_PASS --os-auth-url http://localhost:35357/v2.0 user-list

This one worked for me before. However, it was not working after I installed glance ( The problem in glance was I was getting HTTPInternalServerError (HTTP 500) error. I did unset http_proxy and that is when the issue started)

I have tried the methods given in the following links https://openstack.redhat.com/forum/discussion/351/keystone-auth-failing-unable-to-communicate-with-identity-service/p1 (I changed the port to 5000 as mentioned in the above link but it did not work)

https://ask.openstack.org/en/question/9620/how-to-resolve-keystone-error/ (I deleted the token and user, this too did not work)

The error log is present at this link http://pastebin.com/ymw8BKyV

I tried this command following the solution given in one of the forums

keystone --os-username=admin --os-password=ADMIN_PASS --os-auth-url=http://localhost:35357/v2.0 token-get

I get the error saying 'NoneType' object has no attribute 'has_service_catalog' Can someone help me resolve this issue?