Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

cannot ssh to spawned vms

I have Ubuntu 12.04.3 LTS (precise), and I have devstack as of about two weeks ago. I would like to know how to enable load balancing.

Is it: 'enable_service q_lbass'.

If not, can someone point me to the correct steps?

Thanks

cannot ssh to spawned vms

The previous content was wrong.

The problem is: I had logged in as demo, and started the default cirros image instance. I added the security rule to the default group to open up the SSH connection:

nova secgroup-add-rule default tcp 22 22 172.24.4.0/24

I still cannot ssh login to the vm from the host where devstack is running. ie. ssh cirros@10.0.0.3 hangs. This used to work before after adding the security rule above without any tampering of iptables.

To debug the problem, I enabled trace on iptables, and I found that the rule:

-A nova-compute-sg-fallback -j DROP

ultimately matches, and as a result, the firewall is rejecting the SSH connection.

If I change it manually to:

-A nova-compute-sg-fallback -j ACCEPT

it works. However, if I spawn a second VM, the rule goes back to the DROP target, and as a result, I cannot connect. I have Ubuntu 12.04.3 LTS (precise), and to put the ACCEPT target back once more to get the login to work again.

My question is what am I doing wrong that what used to work before does not work now, and as a temporary fix, I have devstack as of about two weeks ago. I would like to know how to enable load balancing.

Is it: 'enable_service q_lbass'.

If not, can someone point me to the correct steps?to change the rule above.

Thanks