Ask Your Question

Revision history [back]

nova get-serial-console produces HTTP 400 error

Hi,

I am testing Openstack Juno, using a dedicated controller and two compute nodes. For this test, would like to access the console of my VM's as currently is possible using nova-get-serial-console.

I am using Cirros as a test VM.

As documented elsewhere, I started the serial proxy:

2015-02-06 09:41:02.038 15179 INFO nova.console.websocketproxy [-] WebSocket server settings:
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - Listen on 0.0.0.0:6083
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - Flash security policy server
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - No SSL/TLS support (no cert file)
2015-02-06 09:41:02.040 15179 INFO nova.console.websocketproxy [-]   - proxying from 0.0.0.0:6083 to None:None

When I issue a telnet to it on port 6083, I get a connection, so it is running.

But when I request a console, I get the following:

[node-4 ~]# nova get-serial-console test6
ERROR (BadRequest): Unavailable console type serial. (HTTP 400) (Request-ID: req-bbec8a4e-58ff-40f2-ac0e-503c0be9777b)

Does anyone have any insight what might be the problem?

Thanks in advance for your support.

nova get-serial-console produces HTTP 400 error

Hi,

I am testing Openstack Juno, using a dedicated controller and two compute nodes. For this test, would like to access the serial console port of my VM's as currently is possible using nova-get-serial-console.

I am using Cirros as a test VM.

As documented elsewhere, I started the serial proxy:

2015-02-06 09:41:02.038 15179 INFO nova.console.websocketproxy [-] WebSocket server settings:
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - Listen on 0.0.0.0:6083
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - Flash security policy server
2015-02-06 09:41:02.039 15179 INFO nova.console.websocketproxy [-]   - No SSL/TLS support (no cert file)
2015-02-06 09:41:02.040 15179 INFO nova.console.websocketproxy [-]   - proxying from 0.0.0.0:6083 to None:None

When I issue a telnet to it on port 6083, I get a connection, so it is running.

But when I request a serial console, I get the following:

[node-4 ~]# nova get-serial-console test6
ERROR (BadRequest): Unavailable console type serial. (HTTP 400) (Request-ID: req-bbec8a4e-58ff-40f2-ac0e-503c0be9777b)

Does anyone have any insight what might be the problem?

Thanks in advance for your support.