Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Openstack juno's on centOS 6.5

Hi,

Can we Install openstack Juno's on CentOS 6.5? there is a requirement to do so. When I am trying to install openstack Juno's on CentOS 6.5,

yum install openstack-selinux" is not completed successfully.

In CentOS 6.5, I am not able to completely install openstack-selinux package. This has dependency on selinux-policy-base and selinux-policy-targeted packages.

Centos 6.5 supports only 3.7 version of selinux-policy packages .( i.e the centos6.5 repo does not contain selinux-policy packages >= 3.12). But installation of openstack-selinux package requires selinux-policy packages >= 3.12

Logs below:
[root@INBAHRPC03055 ~]# yum install selinux-policy-targeted
Loaded plugins: priorities, refresh-packagekit, security
Setting up Install Process
Package selinux-policy-targeted-3.7.19-260.el6_6.2.noarch already installed and latest version
Nothing to do
[root@INBAHRPC03055 ~]# yum install openstack-selinux
Loaded plugins: priorities, refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openstack-selinux.noarch 0:0.5.19-2.el7ost will be installed
--> Processing Dependency: selinux-policy-targeted >= 3.12.1-153.el7_0.10 for package: openstack-selinux-0.5.19-2.el7ost.noarch
--> Processing Dependency: selinux-policy-base >= 3.12.1-153.el7_0.10 for package: openstack-selinux-0.5.19-2.el7ost.noarch
--> Finished Dependency Resolution
Error: Package: openstack-selinux-0.5.19-2.el7ost.noarch (openstack-juno)
           Requires: selinux-policy-targeted >= 3.12.1-153.el7_0.10
           Installed: selinux-policy-targeted-3.7.19-260.el6_6.2.noarch (@updates)
               selinux-policy-targeted = 3.7.19-260.el6_6.2
           Available: selinux-policy-targeted-3.7.19-260.el6.noarch (base)
               selinux-policy-targeted = 3.7.19-260.el6
           Available: selinux-policy-targeted-3.7.19-260.el6_6.1.noarch (updates)
               selinux-policy-targeted = 3.7.19-260.el6_6.1
Error: Package: openstack-selinux-0.5.19-2.el7ost.noarch (openstack-juno)
           Requires: selinux-policy-base >= 3.12.1-153.el7_0.10
           Installed: selinux-policy-targeted-3.7.19-260.el6_6.2.noarch (@updates)
               selinux-policy-base = 3.7.19-260.el6_6.2
           Available: selinux-policy-minimum-3.7.19-260.el6.noarch (base)
               selinux-policy-base = 3.7.19-260.el6
           Available: selinux-policy-minimum-3.7.19-260.el6_6.1.noarch (updates)
               selinux-policy-base = 3.7.19-260.el6_6.1
           Available: selinux-policy-minimum-3.7.19-260.el6_6.2.noarch (updates)
               selinux-policy-base = 3.7.19-260.el6_6.2
           Available: selinux-policy-mls-3.7.19-260.el6.noarch (base)
               selinux-policy-base = 3.7.19-260.el6
           Available: selinux-policy-mls-3.7.19-260.el6_6.1.noarch (updates)
               selinux-policy-base = 3.7.19-260.el6_6.1
           Available: selinux-policy-mls-3.7.19-260.el6_6.2.noarch (updates)
               selinux-policy-base = 3.7.19-260.el6_6.2
           Available: selinux-policy-targeted-3.7.19-260.el6.noarch (base)
               selinux-policy-base = 3.7.19-260.el6
           Available: selinux-policy-targeted-3.7.19-260.el6_6.1.noarch (updates)
               selinux-policy-base = 3.7.19-260.el6_6.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



[root@INBAHRPC03055 ~]# rpm -ivh openstack-selinux-0.5.19-2.el7ost.noarch.rpm
warning: openstack-selinux-0.5.19-2.el7ost.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID df6674e3: NOKEY
error: Failed dependencies:
    selinux-policy-base >= 3.12.1-153.el7_0.10 is needed by openstack-selinux-0.5.19-2.el7ost.noarch
    selinux-policy-targeted >= 3.12.1-153.el7_0.10 is needed by openstack-selinux-0.5.19-2.el7ost.noarch
[root@INBAHRPC03055 ~]# yum install selinux-policy-targeted
Loaded plugins: priorities, refresh-packagekit, security
Setting up Install Process
Package selinux-policy-targeted-3.7.19-260.el6_6.2.noarch already installed and latest version
Nothing to do