Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Network help in development

We are trying to create a small, development environment for OpenStack.

I am implementing Grizzly/Quantum/Nova

For us. we are trying to do this on a laptop with ONE NIC. I have tried a multitude of config's of the network with no success. I would ideally like to just access mt instances from the dashboard, and have them see in and out of our small corporate net, eventually onto the Internet. We have just one router/one local net at 192.168.1.0/24 in house Not what you would call complicated.....

I have tried the following: Using an image that the image is hard coded: Tested the image under VirtualBox, gets everywhere, including to the net Loaded this image under glance (both CLI and dashboard) to Openstack Created a network called Dev1, admin state, and shared (it comes up and says active) Subnet Dev_local, netaddress 192.168.1.0/24, no gateway IP (router is .1), DHCP on and address pool picked in a non-used area (10 addresses) When I create the instance, I get an IP address (according to Dashboard) the first address in my DHCP range, I get a router port with the second. Then, my server gets bridged to nowhere, so I need to kill everything piece by piece.

Tried with DHCP off, dashboard/nova report assignment of 192.168.1.2, but I can't see the VM, and eth0 comes up active with no IP address, if I try assigning it to an address, we can't see in, and it can't see out onto the main network...

BUT, of I create a second instance, assign it an address (192.168.1.3), it can see the other instance and vice versa, but you still cannot see in/out.

I know I've gotta be something really simple in error, but don't know what.. Anybody out there spot something? I'm going even crazier than normal just trying to spot this.

Sorry for the length, but I thought it would save a few questions..

Network help in developmentsmall environment

We are trying to create a small, development environment for OpenStack.

I am implementing Grizzly/Quantum/Nova

For us. we are trying to do this on a laptop with ONE NIC. I have tried a multitude of config's of the network with no success. I would ideally like to just access mt instances from the dashboard, and have them see in and out of our small corporate net, eventually onto the Internet. We have just one router/one local net at 192.168.1.0/24 in house Not what you would call complicated.....

I have tried the following: Using an image that the image is hard coded: Tested the image under VirtualBox, gets everywhere, including to the net Loaded this image under glance (both CLI and dashboard) to Openstack Created a network called Dev1, admin state, and shared (it comes up and says active) Subnet Dev_local, netaddress 192.168.1.0/24, no gateway IP (router is .1), DHCP on and address pool picked in a non-used area (10 addresses) When I create the instance, I get an IP address (according to Dashboard) the first address in my DHCP range, I get a router port with the second. Then, my server gets bridged to nowhere, so I need to kill everything piece by piece.

Tried with DHCP off, dashboard/nova report assignment of 192.168.1.2, but I can't see the VM, and eth0 comes up active with no IP address, if I try assigning it to an address, we can't see in, and it can't see out onto the main network...

BUT, of I create a second instance, assign it an address (192.168.1.3), it can see the other instance and vice versa, but you still cannot see in/out.

I know I've gotta be something really simple in error, but don't know what.. Anybody out there spot something? I'm going even crazier than normal just trying to spot this.

Sorry for the length, but I thought it would save a few questions..