Ask Your Question

Revision history [back]

Ubuntu 14.10 install horizon openstack-dashboard multiple versions of python

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard. I also tried sudo apt-get install openstack-dashboard but looks to be some kind of circular reference.

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon
bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic
bob@bob-NE722:~/devstack$ python --version
Python 2.7.8

Ubuntu 14.10 install horizon openstack-dashboard multiple versions of python

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard. I also tried sudo apt-get install openstack-dashboard but looks to be some kind of circular reference.

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon
bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic
bob@bob-NE722:~/devstack$ python --version
Python 2.7.8
bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77


Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

Ubuntu 14.10 install horizon openstack-dashboard multiple versions of pythonImportError: Could not import settings 'openstack_dashboard.settings'

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard. I also tried sudo apt-get install openstack-dashboard but looks to be some kind of circular reference.

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon
bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic
bob@bob-NE722:~/devstack$ python --version
Python 2.7.8
bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77


Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard. I also tried sudo apt-get install openstack-dashboard but looks to be some kind of circular reference.

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon
 bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic
 bob@bob-NE722:~/devstack$ python --version
Python 2.7.8
 bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides:
Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard. I also tried sudo apt-get install openstack-dashboard but looks to be some kind of circular reference.

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.1.0

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard. I also tried sudo apt-get install openstack-dashboard but looks to be some kind of circular reference.

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.1.0
2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard. ?

Tried:

What I also tried have tried:

  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard but looks
  • updating git from the git repo ( so from 2.1.0 to be some kind of circular reference.2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here
  • a2enmod wsgi

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here
  • a2enmod wsgi
  • sudo pip install -U pbr As seen: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • tried: - http://docs.openstack.org/developer/horizon/quickstart.html - installing horizon from git repo
  • repo - sudo apt-get install openstack-dashboard
  • - updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • 2.2.0) - dropping openstack-dashboard django folders in every place that I could think of
  • of - making sure that pip install xstatic
  • - which python and the above steps as well
  • well - still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here
  • - a2enmod wsgi
  • - sudo pip install -U pbr As seen: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried: - tried:

  • http://docs.openstack.org/developer/horizon/quickstart.html -
  • installing horizon from git repo - repo
  • sudo apt-get install openstack-dashboard -
  • updating git from the git repo ( so from 2.1.0 to 2.2.0) - 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of - of
  • making sure that pip install xstatic -
  • which python and the above steps as well - well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here -
  • a2enmod wsgi -
  • sudo pip install -U pbr As seen: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed.installed, and more specifically it might be an issue with how I am trying to use pbr?

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • http://docs.openstack.org/developer/horizon/quickstart.html
  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here
  • a2enmod wsgi
  • sudo pip install -U pbr As seen: here

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'

I am able to see that django is available when I navigate to http://192.168.0.201/ However, django throws an error.

I am assuming because horizon wasn't properly installed, and more specifically it might be an issue with how I am trying to use pbr?

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?

Tried:

What I have tried:

  • http://docs.openstack.org/developer/horizon/quickstart.html
  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here
  • a2enmod wsgi
  • sudo pip install -U pbr As seen: here
  • Installing pbr from git repo.
  • Searching launchpad for any reference to the error: "Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?"
  • https://bugs.launchpad.net/pbr/+bug/1369179
  • https://bugs.launchpad.net/pbr/+bug/1374677
  • https://bugs.launchpad.net/pbr/+bug/1232868
  • https://bugs.launchpad.net/pbr/+bug/1379579

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Ubuntu 14.10 ImportError: Could not import settings 'openstack_dashboard.settings'PBR : Exception "Versioning for this project requires either an sdist tarball, or access to an upstream git repository.

I am able Trying to see install openstack on Ubuntu 14.10

My initial thought was that django is available when I navigate openstack-dashboard wasn't installed properly, which led me to http://192.168.0.201/ However, django throws an error.

I am assuming because belive that horizon wasn't properly installed, and more specifically it might be an issue with how I am trying which led me to use pbr?

Question:

So my question is there a development branch that is being tested with the newer releases? And/Or is there a suggested method in which I should install horizon or openstack-dashboard?.

Tried:

What I have tried:

  • http://docs.openstack.org/developer/horizon/quickstart.html
  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here
  • a2enmod wsgi
  • sudo pip install -U pbr As seen: here
  • Installing pbr from git repo.
  • Searching launchpad for any reference to the error: "Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?"
  • https://bugs.launchpad.net/pbr/+bug/1369179
  • https://bugs.launchpad.net/pbr/+bug/1374677
  • https://bugs.launchpad.net/pbr/+bug/1232868
  • https://bugs.launchpad.net/pbr/+bug/1379579

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

Possibly related: https // bugs[dot]launchpad[dot]net/openstack-manuals/+bug/1374273

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Within horizon-master a pip freeze:

bob@bob-NE722:~/Downloads/horizon-master$ pip freeze
alembic==0.7.3
amqp==1.4.6
anyjson==0.3.3
apt-xapian-index==0.46
astroid==1.1.1
Babel==1.3
BeautifulSoup==3.2.1
boto==2.34.0
characteristic==0.1.0
chardet==2.2.1
Cheetah==2.4.4
CherryPy==3.5.0
-e git://git.openstack.org/openstack/cinder.git@11070eae55641af24ef0efb93e170b5c94c962c0#egg=cinder-master
cliff==1.9.0
cliff-tablib==1.1
cmd2==0.6.8
colorama==0.3.1
command-not-found==0.3
constants==0.6.0
coverage==3.7.1
debtagshw==0.1
decorator==3.4.0
defer==1.0.6
dirspec==13.10
Django==1.6.9
django-appconf==0.6
django-compressor==1.4
django-openstack-auth==1.1.7
django-pyscss==1.0.6
docutils==0.12
dogpile.cache==0.5.4
dogpile.core==0.4.1
ecdsa==0.11
euca2ools==3.0.1
eventlet==0.16.0
extras==0.0.3
feedparser==5.1.3
fixtures==1.0.0
FormEncode==1.2.6
futures==2.2.0
-e git://git.openstack.org/openstack/glance.git@31e194055ef37ed5d4ca866180eb0c8871f910a0#egg=glance-master
glance-store==0.1.10
greenlet==0.4.2
-e git://git.openstack.org/openstack/heat.git@15043074b1cc92e720a570936b761706dcd86c58#egg=heat-master
-e git://git.openstack.org/openstack/horizon.git@4f1b28fb9ac9f0c425a5fc8840132cd7aec3aa11#egg=horizon-master
html5lib==0.999
httplib2==0.9
idna==0.9
ipaddr==2.1.11
iso8601==0.1.10
Jinja2==2.7.3
jsonpatch==1.9
jsonpointer==1.7
jsonschema==2.4.0
-e git://git.openstack.org/openstack/keystone.git@e47bd02a662d478d43c502f4c2f19dd7cf06a530#egg=keystone-master
keystonemiddleware==1.3.1
kombu==3.0.24
libvirt-python==1.2.8
lockfile==0.8
logilab-common==0.61.0
lxml==3.3.6
M2Crypto==0.21.1
Mako==1.0.0
MarkupSafe==0.23
mock==1.0.1
mox==0.5.3
msgpack-python==0.4.2
mysql-connector-python==1.2.2
MySQL-python==1.2.3
netaddr==0.7.13
netifaces==0.10.4
networkx==1.9.1
nose==1.3.4
-e git://git.openstack.org/openstack/nova.git@7403d5da7d199bfe4d9c0e444d967c70d32475dd#egg=nova-master
numpy==1.8.2
oauthlib==0.6.1
oneconf==0.3.7
ordereddict==1.1
oslo.concurrency==0.3.0
oslo.config==1.6.0
oslo.context==0.1.0
oslo.db==1.3.0
oslo.i18n==1.3.0
oslo.messaging==1.5.1
oslo.middleware==0.3.0
oslo.rootwrap==1.4.0
oslo.serialization==1.2.0
oslo.utils==1.2.1
oslo.vmware==0.8.0
osprofiler==0.3.0
PAM==0.4.2
paramiko==1.15.1
passlib==1.6.2
Paste==1.7.5.1
PasteDeploy==1.5.2
PasteScript==1.7.5
pbr==0.10.7
pdftools==0.37
pexpect==3.2
Pillow==2.6.1
Pint==0.6
piston-mini-client==0.7.5
posix-ipc==0.9.9
prettytable==0.7.2
py==1.4.26
pyasn1==0.1.7
pyasn1-modules==0.0.5
pycadf==0.6.0
PyChart==1.39
pycrypto==2.6.1
pycups==1.9.67
pydns==2.3.6
pydot==1.0.32
Pygments==1.6
pygobject==3.14.0
pyinotify==0.9.4
pylint==1.2.1
pyOpenSSL==0.13.1
pyparsing==2.0.3
pyScss==1.2.1
pyserial==2.6
pysqlite==2.6.3
python-apt===0.9.3.10ubuntu1
python-barbicanclient==3.0.1
python-ceilometerclient==1.0.12
python-cinderclient==1.1.1
python-dateutil==1.5
python-debian==0.1.22
python-glanceclient==0.15.0
python-heatclient==0.2.12
python-keystoneclient==1.0.0
python-ldap==2.4.10
python-memcached==1.53
python-mimeparse==0.1.4
python-neutronclient==2.3.10
python-novaclient==2.20.0
python-openid==2.2.5
python-openstackclient==1.0.1
python-saharaclient==0.7.6
python-stdnum==0.9
python-swiftclient==2.3.1
python-troveclient==1.0.8
pytz==2014.10
PyWebDAV==0.9.8
pyxdg==0.25
PyYAML==3.11
qpid-python==0.26.1
reportlab==3.1.8
repoze.lru==0.6
requestbuilder==0.1.0
requests==2.3.0
retrying==1.3.3
rfc3986==0.2.0
roman==2.0.0
Routes==1.13
rtslib-fb==2.1.51
scgi==1.13
service-identity==1.0.0
sessioninstaller==0.0.0
simplegeneric==0.8.1
simplejson==3.5.3
six==1.7.3
software-center-aptd-plugins==0.0.0
SQLAlchemy==0.9.7
sqlalchemy-migrate==0.9.1
ssh-import-id==3.21
stevedore==1.2.0
suds==0.4.1
tablib==0.10.0
taskflow==0.6.1
Tempita==0.5.2
testtools==1.5.0
tox==1.8.1
Twisted-Core==14.0.2
Twisted-Web==14.0.2
unittest2==0.8.0
urllib3==1.8.3
vatnumber==1.2
vboxapi==1.0
virtualenv==12.0.4
vobject==0.8.1rc0
warlock==1.1.0
WebOb==1.4
websockify==0.6.0
Werkzeug==0.9.6
wheel==0.24.0
WSME==0.6.4
xattr==0.6.4
xlwt==0.7.5
XStatic==1.0.1
XStatic-Angular==1.3.7.0
XStatic-Angular-Bootstrap==0.11.0.2
XStatic-Bootstrap-Datepicker==1.3.1.0
XStatic-Bootstrap-SCSS==3.2.0.0
XStatic-D3==3.1.6.2
XStatic-Font-Awesome==4.2.0.0
XStatic-Hogan==2.0.0.2
XStatic-Jasmine==2.1.2.0
XStatic-jQuery==1.10.2.1
XStatic-JQuery-Migrate==1.2.1.1
XStatic-jquery-ui==1.11.0.1
XStatic-JQuery.quicksearch==2.0.3.1
XStatic-JQuery.TableSorter==2.14.5.1
XStatic-JSEncrypt==2.0.0.2
XStatic-QUnit==1.14.0.2
XStatic-Rickshaw==1.5.0.0
XStatic-smart-table==1.4.5.3
XStatic-Spin==1.2.5.2
zope.interface==4.1.1
ZSI==2.1a1

PBR : Exception "Versioning for this project requires either an sdist tarball, or access to an upstream git repository.

Trying to install openstack on Ubuntu 14.10

My initial thought was that openstack-dashboard wasn't installed properly, which led me to belive that horizon wasn't properly installed, which led me to pbr.

The only related question that I could find: https://ask.openstack.org/en/question/47118/issue-with-nova-installation-in-devstack/

Tried:

What I have tried:

  • http://docs.openstack.org/developer/horizon/quickstart.html
  • installing horizon from git repo
  • sudo apt-get install openstack-dashboard
  • updating git from the git repo ( so from 2.1.0 to 2.2.0)
  • dropping openstack-dashboard django folders in every place that I could think of
  • making sure that pip install xstatic
  • which python and the above steps as well
  • still working on DJANGO_SETTINGS_MODULE to see where it gets set? See: here
  • a2enmod wsgi
  • sudo pip install -U pbr As seen: here
  • Installing pbr from git repo.
  • Searching launchpad for any reference to the error: "Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?"
  • https://bugs.launchpad.net/pbr/+bug/1369179
  • https://bugs.launchpad.net/pbr/+bug/1374677
  • https://bugs.launchpad.net/pbr/+bug/1232868
  • https://bugs.launchpad.net/pbr/+bug/1379579

Troubleshooting:

After running FORCE=yes ./stack.sh I receive the following traceback:

Traceback (most recent call last):
  File "manage.py", line 25, in <module>
    execute_from_command_line(sys.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
    utility.execute()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 261, in fetch_command
    commands = get_commands()
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 107, in get_commands
    apps = settings.INSTALLED_APPS
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 54, in __getattr__
    self._setup(name)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 49, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/local/lib/python2.7/dist-packages/django/conf/__init__.py", line 132, in __init__
    % (self.SETTINGS_MODULE, e)
ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.main
dpkg: error processing package openstack-dashboard (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 openstack-dashboard
E: Sub-process /usr/bin/dpkg returned an error code (1)

Also my version info:

bob@bob-NE722:~/devstack$ pip show horizon
---
Name: horizon
Version: 2015.1.dev95
Location: /opt/stack/horizon

bob@bob-NE722:~/devstack$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:    14.10
Codename:   utopic

bob@bob-NE722:~/devstack$ python --version
Python 2.7.8


bob@bob-NE722:~/devstack$ apt-cache showpkg openstack-dashboard
Package: openstack-dashboard
Versions: 
1:2014.2.1-0ubuntu2 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic-updates_main_binary-amd64_Packages) (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77

1:2014.2-0ubuntu1 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_binary-amd64_Packages
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77
 Description Language: en
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_utopic_main_i18n_Translation-en
                  MD5: a54f5b92f84ab1d5b6c3fa553f99ef77    
Reverse Depends: 
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2.1-0ubuntu2
  openstack-dashboard-ubuntu-theme,openstack-dashboard 1:2014.2-0ubuntu1
Dependencies: 
1:2014.2.1-0ubuntu2 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2.1-0ubuntu2) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
1:2014.2-0ubuntu1 - adduser (0 (null)) apache2 (16 (null)) httpd (0 (null)) libapache2-mod-wsgi (2 2.3) python-django-horizon (5 1:2014.2-0ubuntu1) python:any (2 2.6.6-7~) dpkg (2 1.15.7.2) openstack-dashboard-ubuntu-theme (0 (null)) 
Provides: 
1:2014.2.1-0ubuntu2 - 
1:2014.2-0ubuntu1 - 
Reverse Provides: 


pip show xstatic
---
Name: XStatic
Version: 1.0.1
Location: /usr/local/lib/python2.7/dist-packages
Requires:

I have also tried downloading the horizon git repo and the traceback:

bob@bob-NE722:~/Downloads/horizon-master$ python setup.py install
ERROR:root:Error parsing
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pbr/core.py", line 104, in pbr
    attrs = util.cfg_to_args(path)
  File "/usr/local/lib/python2.7/dist-packages/pbr/util.py", line 238, in cfg_to_args
    pbr.hooks.setup_hook(config)
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/__init__.py", line 27, in setup_hook
    metadata_config.run()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/base.py", line 29, in run
    self.hook()
  File "/usr/local/lib/python2.7/dist-packages/pbr/hooks/metadata.py", line 28, in hook
    self.config['name'], self.config.get('version', None))
  File "/usr/local/lib/python2.7/dist-packages/pbr/packaging.py", line 554, in get_version
    raise Exception("Versioning for this project requires either an sdist"
Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?
error in setup command: Error parsing /home/bob/Downloads/horizon-master/setup.cfg: Exception: Versioning for this project requires either an sdist tarball, or access to an upstream git repository. Are you sure that git is installed?

I think so yes:

bob@bob-NE722:~/Downloads/horizon-master$ git --version
git version 2.2.0.GIT

Within horizon-master a pip freeze:

bob@bob-NE722:~/Downloads/horizon-master$ pip freeze
alembic==0.7.3
amqp==1.4.6
anyjson==0.3.3
apt-xapian-index==0.46
astroid==1.1.1
Babel==1.3
BeautifulSoup==3.2.1
boto==2.34.0
characteristic==0.1.0
chardet==2.2.1
Cheetah==2.4.4
CherryPy==3.5.0
-e git://git.openstack.org/openstack/cinder.git@11070eae55641af24ef0efb93e170b5c94c962c0#egg=cinder-master
cliff==1.9.0
cliff-tablib==1.1
cmd2==0.6.8
colorama==0.3.1
command-not-found==0.3
constants==0.6.0
coverage==3.7.1
debtagshw==0.1
decorator==3.4.0
defer==1.0.6
dirspec==13.10
Django==1.6.9
django-appconf==0.6
django-compressor==1.4
django-openstack-auth==1.1.7
django-pyscss==1.0.6
docutils==0.12
dogpile.cache==0.5.4
dogpile.core==0.4.1
ecdsa==0.11
euca2ools==3.0.1
eventlet==0.16.0
extras==0.0.3
feedparser==5.1.3
fixtures==1.0.0
FormEncode==1.2.6
futures==2.2.0
-e git://git.openstack.org/openstack/glance.git@31e194055ef37ed5d4ca866180eb0c8871f910a0#egg=glance-master
glance-store==0.1.10
greenlet==0.4.2
-e git://git.openstack.org/openstack/heat.git@15043074b1cc92e720a570936b761706dcd86c58#egg=heat-master
-e git://git.openstack.org/openstack/horizon.git@4f1b28fb9ac9f0c425a5fc8840132cd7aec3aa11#egg=horizon-master
html5lib==0.999
httplib2==0.9
idna==0.9
ipaddr==2.1.11
iso8601==0.1.10
Jinja2==2.7.3
jsonpatch==1.9
jsonpointer==1.7
jsonschema==2.4.0
-e git://git.openstack.org/openstack/keystone.git@e47bd02a662d478d43c502f4c2f19dd7cf06a530#egg=keystone-master
keystonemiddleware==1.3.1
kombu==3.0.24
libvirt-python==1.2.8
lockfile==0.8
logilab-common==0.61.0
lxml==3.3.6
M2Crypto==0.21.1
Mako==1.0.0
MarkupSafe==0.23
mock==1.0.1
mox==0.5.3
msgpack-python==0.4.2
mysql-connector-python==1.2.2
MySQL-python==1.2.3
netaddr==0.7.13
netifaces==0.10.4
networkx==1.9.1
nose==1.3.4
-e git://git.openstack.org/openstack/nova.git@7403d5da7d199bfe4d9c0e444d967c70d32475dd#egg=nova-master
numpy==1.8.2
oauthlib==0.6.1
oneconf==0.3.7
ordereddict==1.1
oslo.concurrency==0.3.0
oslo.config==1.6.0
oslo.context==0.1.0
oslo.db==1.3.0
oslo.i18n==1.3.0
oslo.messaging==1.5.1
oslo.middleware==0.3.0
oslo.rootwrap==1.4.0
oslo.serialization==1.2.0
oslo.utils==1.2.1
oslo.vmware==0.8.0
osprofiler==0.3.0
PAM==0.4.2
paramiko==1.15.1
passlib==1.6.2
Paste==1.7.5.1
PasteDeploy==1.5.2
PasteScript==1.7.5
pbr==0.10.7
pdftools==0.37
pexpect==3.2
Pillow==2.6.1
Pint==0.6
piston-mini-client==0.7.5
posix-ipc==0.9.9
prettytable==0.7.2
py==1.4.26
pyasn1==0.1.7
pyasn1-modules==0.0.5
pycadf==0.6.0
PyChart==1.39
pycrypto==2.6.1
pycups==1.9.67
pydns==2.3.6
pydot==1.0.32
Pygments==1.6
pygobject==3.14.0
pyinotify==0.9.4
pylint==1.2.1
pyOpenSSL==0.13.1
pyparsing==2.0.3
pyScss==1.2.1
pyserial==2.6
pysqlite==2.6.3
python-apt===0.9.3.10ubuntu1
python-barbicanclient==3.0.1
python-ceilometerclient==1.0.12
python-cinderclient==1.1.1
python-dateutil==1.5
python-debian==0.1.22
python-glanceclient==0.15.0
python-heatclient==0.2.12
python-keystoneclient==1.0.0
python-ldap==2.4.10
python-memcached==1.53
python-mimeparse==0.1.4
python-neutronclient==2.3.10
python-novaclient==2.20.0
python-openid==2.2.5
python-openstackclient==1.0.1
python-saharaclient==0.7.6
python-stdnum==0.9
python-swiftclient==2.3.1
python-troveclient==1.0.8
pytz==2014.10
PyWebDAV==0.9.8
pyxdg==0.25
PyYAML==3.11
qpid-python==0.26.1
reportlab==3.1.8
repoze.lru==0.6
requestbuilder==0.1.0
requests==2.3.0
retrying==1.3.3
rfc3986==0.2.0
roman==2.0.0
Routes==1.13
rtslib-fb==2.1.51
scgi==1.13
service-identity==1.0.0
sessioninstaller==0.0.0
simplegeneric==0.8.1
simplejson==3.5.3
six==1.7.3
software-center-aptd-plugins==0.0.0
SQLAlchemy==0.9.7
sqlalchemy-migrate==0.9.1
ssh-import-id==3.21
stevedore==1.2.0
suds==0.4.1
tablib==0.10.0
taskflow==0.6.1
Tempita==0.5.2
testtools==1.5.0
tox==1.8.1
Twisted-Core==14.0.2
Twisted-Web==14.0.2
unittest2==0.8.0
urllib3==1.8.3
vatnumber==1.2
vboxapi==1.0
virtualenv==12.0.4
vobject==0.8.1rc0
warlock==1.1.0
WebOb==1.4
websockify==0.6.0
Werkzeug==0.9.6
wheel==0.24.0
WSME==0.6.4
xattr==0.6.4
xlwt==0.7.5
XStatic==1.0.1
XStatic-Angular==1.3.7.0
XStatic-Angular-Bootstrap==0.11.0.2
XStatic-Bootstrap-Datepicker==1.3.1.0
XStatic-Bootstrap-SCSS==3.2.0.0
XStatic-D3==3.1.6.2
XStatic-Font-Awesome==4.2.0.0
XStatic-Hogan==2.0.0.2
XStatic-Jasmine==2.1.2.0
XStatic-jQuery==1.10.2.1
XStatic-JQuery-Migrate==1.2.1.1
XStatic-jquery-ui==1.11.0.1
XStatic-JQuery.quicksearch==2.0.3.1
XStatic-JQuery.TableSorter==2.14.5.1
XStatic-JSEncrypt==2.0.0.2
XStatic-QUnit==1.14.0.2
XStatic-Rickshaw==1.5.0.0
XStatic-smart-table==1.4.5.3
XStatic-Spin==1.2.5.2
zope.interface==4.1.1
ZSI==2.1a1