Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rdo packstack allinone installation with proxy fail in _provision_glance.pp

Trying to install openstack icehouse on a single rhel 6.6 server (allinone mode for lab testing).

As my server is behind a proxy, the following files were set /etc/yum.conf : proxy=http://<proxy-ip>:<proxy-port> /etc/environment: http_proxy=http://<proxy-ip>:<proxy-port> export no_proxy=localhost,localhost.localdomain,127.0.0.1,<local-ip>

Tried packstack installation with all default options:

packstack --allinone

And got an error during _provision_glance.pp execution. Error: Execution of '/usr/bin/glance -T services -I glance -K 32e99b59fc574c48 -N http://<local-ip>:35357/v2.0/ image-create --name=cirros --is-public=Yes --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img' returned 1: Request returned failure status.

glance.pp.log tells "400 Bad Request The HTTP URL is invalid."

Indeed, I get the same result if trying to play the "glance -T services ..." myself, although wget is ok for both URLs http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img and http://<local-ip>:35357/v2.0/

I restarted the whole process, but get stuck there again.

The dashboard is available using keystonerc_xxx credentials, but maybe some configuration steps (no only loading the demo cirros image) are missing?

Note: the exact same symptoms were already show in question 'https://ask.openstack.org/en/question/53735/glance-image-create-error/' , but proxy variables are set in my environment, and this doesn't seem enough. Maybe did I miss something else? I have some background on using libvirt/kvm, but am a newbie on openstack.

rdo packstack allinone installation with proxy fail in _provision_glance.pp

Trying to install openstack icehouse on a single rhel 6.6 server (allinone mode for lab testing).

As my server is behind a proxy, the following files were set

/etc/yum.conf : proxy=http://<proxy-ip>:<proxy-port>
/etc/environment: 
   http_proxy=http://<proxy-ip>:<proxy-port>
   export no_proxy=localhost,localhost.localdomain,127.0.0.1,<local-ip>

no_proxy=localhost,localhost.localdomain,127.0.0.1,<local-ip>

Tried packstack installation with all default options:

packstack --allinone

And got an error during _provision_glance.pp execution.

Error: Execution of '/usr/bin/glance -T services -I glance -K 32e99b59fc574c48 -N http://<local-ip>:35357/v2.0/ image-create --name=cirros --is-public=Yes --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img' returned 1: Request returned failure status.

status.

glance.pp.log tells "400 Bad Request The HTTP URL is invalid."

Indeed, I get the same result if trying to play the "glance -T services ..." myself, although wget is ok for both URLs http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img and http://<local-ip>:35357/v2.0/

I restarted the whole process, but get stuck there again.

The dashboard is available using keystonerc_xxx credentials, but maybe some configuration steps (no only loading the demo cirros image) are missing?

Note: the exact same symptoms were already show in question 'https://ask.openstack.org/en/question/53735/glance-image-create-error/' , but proxy variables are set in my environment, and this doesn't seem enough. Maybe did I miss something else? I have some background on using libvirt/kvm, but am a newbie on openstack.

rdo packstack allinone installation with proxy fail in _provision_glance.pp

Trying to install openstack icehouse on a single rhel 6.6 server (allinone mode for lab testing).

As my server is behind a proxy, the following files were set

/etc/yum.conf : proxy=http://<proxy-ip>:<proxy-port>
/etc/environment: 
   http_proxy=http://<proxy-ip>:<proxy-port>
   export no_proxy=localhost,localhost.localdomain,127.0.0.1,<local-ip>

Tried packstack installation with all default options:

# packstack --allinone

--allinone

And got an error during _provision_glance.pp execution.

Error: Execution of '/usr/bin/glance -T services -I glance -K 32e99b59fc574c48 -N http://<local-ip>:35357/v2.0/ image-create --name=cirros --is-public=Yes --container-format=bare --disk-format=qcow2 --copy-from=http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img' returned 1: Request returned failure status.

glance.pp.log tells "400 Bad Request The HTTP URL is invalid."

Indeed, I get the same result if trying to play the "glance -T services ..." myself, although wget is ok for both URLs http://download.cirros-cloud.net/0.3.1/cirros-0.3.1-x86_64-disk.img and http://<local-ip>:35357/v2.0/

I restarted the whole process, but get stuck there again.

The dashboard is available using keystonerc_xxx credentials, but maybe some configuration steps (no only loading the demo cirros image) are missing?

Note: the exact same symptoms were already show in question 'https://ask.openstack.org/en/question/53735/glance-image-create-error/' , but proxy variables are set in my environment, and this doesn't seem enough. Maybe did I miss something else? I have some background on using libvirt/kvm, but am a newbie on openstack.