Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

why my openstackclient doesn't work with keystone?

I installed keystone and It now works good with keystoneclient CLI. But I want to try v3 API and found my openstackclient doesn't work with keystone.

here is my command: openstack --os-auth-url http://202.112.113.213:5000/v3 \ --os-identity-api-version 3 \ --os-auth-type v3password \ --os-project-name demo \ --os-project-domain-id default \ --os-username darren \ --os-user-domain-id default \ --os-password keystone@ruc_iser

here is the traceback: 2015-01-03 20:09:46.725 8411 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270 2015-01-03 20:09:46.728 8411 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191 2015-01-03 20:09:46.859 8411 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "POST /v3/auth/tokens HTTP/1.1" 201 4318 0.134202 2015-01-03 20:09:46.863 8409 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191 2015-01-03 20:09:46.864 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET / HTTP/1.1" 300 934 0.001486 2015-01-03 20:09:46.867 8409 INFO eventlet.wsgi.server [-] 202.112.113.213 - - [03/Jan/2015 20:09:46] "GET /v3/users HTTP/1.1" 404 252 0.000999 ERROR: openstack The resource could not be found. (HTTP 404)

"user list" is just an example and I can't do anything with v3 API. The trick is I can do everything with keystoneclient using v2 API, if you need more configuration details, just let me know.

why my openstackclient doesn't work with keystone?

I installed keystone and It now works good with keystoneclient CLI. But I want to try v3 API and found my openstackclient doesn't work with keystone.

here is my command: openstack --os-auth-url http://202.112.113.213:5000/v3 \ \

--os-identity-api-version 3 \ \

--os-auth-type v3password \ \

--os-project-name demo \ \

--os-project-domain-id default \ \

--os-username darren \ \

--os-user-domain-id default \ \

--os-password keystone@ruc_iser

here is the traceback: 2015-01-03 20:09:46.725 8411 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270 /usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270

2015-01-03 20:09:46.728 8411 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191 /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.859 8411 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "POST /v3/auth/tokens HTTP/1.1" 201 4318 0.134202 0.134202

2015-01-03 20:09:46.863 8409 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191 /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.864 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET / HTTP/1.1" 300 934 0.001486 0.001486

2015-01-03 20:09:46.867 8409 INFO eventlet.wsgi.server [-] 202.112.113.213 - - [03/Jan/2015 20:09:46] "GET /v3/users HTTP/1.1" 404 252 0.000999 0.000999

ERROR: openstack The resource could not be found. (HTTP 404)

"user list" is just an example and I can't do anything with v3 API. The trick is I can do everything with keystoneclient using v2 API, if you need more configuration details, just let me know.

why my openstackclient doesn't work with keystone?

I installed keystone and It now works good with keystoneclient CLI. But I want to try v3 API and found my openstackclient doesn't work with keystone.

here is my command: openstack --os-auth-url http://202.112.113.213:5000/v3 http://localhost:5000/v3 \

--os-identity-api-version 3 \

--os-auth-type v3password \

--os-project-name demo \

--os-project-domain-id default \

--os-username darren \

--os-user-domain-id default \

--os-password keystone@ruc_iser

here is the traceback: 2015-01-03 20:09:46.725 8411 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270

2015-01-03 20:09:46.728 8411 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.859 8411 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "POST /v3/auth/tokens HTTP/1.1" 201 4318 0.134202

2015-01-03 20:09:46.863 8409 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.864 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET / HTTP/1.1" 300 934 0.001486

2015-01-03 20:09:46.867 8409 INFO eventlet.wsgi.server [-] 202.112.113.213 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET /v3/users HTTP/1.1" 404 252 0.000999

ERROR: openstack The resource could not be found. (HTTP 404)

"user list" is just an example and I can't do anything with v3 API. The trick is I can do everything with keystoneclient using v2 API, if you need more configuration details, just let me know.

why my openstackclient doesn't work with keystone?

I installed keystone and It now works good with keystoneclient CLI. But I want to try v3 API and found my openstackclient doesn't work with keystone.

here is my command: openstack --os-auth-url http://localhost:5000/v3 \

--os-identity-api-version 3 \

--os-auth-type v3password \

--os-project-name demo \

--os-project-domain-id default \

--os-username darren \

--os-user-domain-id default \

--os-password keystone@ruc_iserkeystonepass

here is the traceback: 2015-01-03 20:09:46.725 8411 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270

2015-01-03 20:09:46.728 8411 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.859 8411 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "POST /v3/auth/tokens HTTP/1.1" 201 4318 0.134202

2015-01-03 20:09:46.863 8409 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.864 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET / HTTP/1.1" 300 934 0.001486

2015-01-03 20:09:46.867 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET /v3/users HTTP/1.1" 404 252 0.000999

ERROR: openstack The resource could not be found. (HTTP 404)

"user list" is just an example and I can't do anything with v3 API. The trick is I can do everything with keystoneclient using v2 API, if you need more configuration details, just let me know.

click to hide/show revision 5
No.5 Revision

why my openstackclient doesn't work with keystone?

I installed keystone and It now works good with keystoneclient CLI. But I want to try v3 API and found my openstackclient doesn't work with keystone.

here is my command:

openstack --os-auth-url http://localhost:5000/v3 \

\ --os-identity-api-version 3 \

\ --os-auth-type v3password \

\ --os-project-name demo \

\ --os-project-domain-id default \

\ --os-username darren \

\ --os-user-domain-id default \

\ --os-password keystonepass

keystonepass

here is the traceback:

2015-01-03 20:09:46.725 8411 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270

/usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270 2015-01-03 20:09:46.728 8411 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

/usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191 2015-01-03 20:09:46.859 8411 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "POST /v3/auth/tokens HTTP/1.1" 201 4318 0.134202

0.134202 2015-01-03 20:09:46.863 8409 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

/usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191 2015-01-03 20:09:46.864 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET / HTTP/1.1" 300 934 0.001486

0.001486 2015-01-03 20:09:46.867 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET /v3/users HTTP/1.1" 404 252 0.000999

0.000999 ERROR: openstack The resource could not be found. (HTTP 404)

404)

"user list" is just an example and I can't do anything with v3 API. The trick is I can do everything with keystoneclient using v2 API, if you need more configuration details, just let me know.

why my openstackclient doesn't work with keystone?keystone v3 API?

I installed keystone and It now works good with keystoneclient CLI. But I want to try v3 API and found my openstackclient doesn't work with keystone.

here is my command:

openstack --os-auth-url http://localhost:5000/v3 \

--os-identity-api-version 3 \

--os-auth-type v3password \

--os-project-name demo \

--os-project-domain-id default \

--os-username darren \

--os-user-domain-id default \

--os-password keystonepass

here is the traceback:

2015-01-03 20:09:46.725 8411 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/dist-packages/keystone/middleware/core.py:270

2015-01-03 20:09:46.728 8411 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.859 8411 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "POST /v3/auth/tokens HTTP/1.1" 201 4318 0.134202

2015-01-03 20:09:46.863 8409 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/dist-packages/keystone/common/wsgi.py:191

2015-01-03 20:09:46.864 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET / HTTP/1.1" 300 934 0.001486

2015-01-03 20:09:46.867 8409 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [03/Jan/2015 20:09:46] "GET /v3/users HTTP/1.1" 404 252 0.000999

ERROR: openstack The resource could not be found. (HTTP 404)

"user list" is just an example and I can't do anything with v3 API. The trick is I can do everything with keystoneclient using v2 API, if you need more configuration details, just let me know.