Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

DevStack with Neutron: Cannot ping twice

I encounter some very strange behaviour in a test setup using DevStack inside a VM. My VM is Ubuntu 12.04.3 and I have been using these guides:

  • http://devstack.org/guides/single-vm.html
  • https://wiki.openstack.org/wiki/NeutronDevstack

My goal is to launch an instance, associate a floating IP to it and be able to access that instance.

So I have created my internal network, router, set the public network as the gateway for the router, launched my instance (connected to the internal network), associated a floating IP, all fine so far.

I end with a floating IP of 172.24.4.229 in my example.

So I try to ping my instance using the floating IP:

devstack@devstack-VirtualBox:~$ ping 172.24.4.229
64 bytes from 172.24.4.229: icmp_req=932 ttl=64 time=0.168 ms
64 bytes from 172.24.4.229: icmp_req=933 ttl=64 time=0.153 ms
64 bytes from 172.24.4.229: icmp_req=934 ttl=64 time=0.166 ms
64 bytes from 172.24.4.229: icmp_req=935 ttl=64 time=0.135 ms
64 bytes from 172.24.4.229: icmp_req=936 ttl=64 time=0.153 ms

I can let that ping go on forever; I have tried 10+ minutes, keeps answering.

Now comes the fun part. I press <ctrl><c> and try again:

devstack@devstack-VirtualBox:~$ ping 172.24.4.229
PING 172.24.4.229 (172.24.4.229) 56(84) bytes of data.
^C
--- 172.24.4.229 ping statistics ---
445 packets transmitted, 0 received, 100% packet loss, time 445536ms

In other words, as soon as I interrupt the ping, I cannot start over again unless I disassociate the floating IP and associate it again.

I also tried to start a second ping in a new window while the first ping was ongoing: No luck.

So I wanted to know if this is only about ping, so I looked at SSH, starting out without the floating IP:

ssh: connect to host 172.24.4.229 port 22: No route to host

Agree. Now let's associate the floating IP and try again:

devstack@devstack-VirtualBox:~$ ssh 172.24.4.229
ssh: connect to host 172.24.4.229 port 22: Connection refused

I am wondering a bit about the "Connection refused" as my instance should have SSH enabled, but never mind. Just immediately try again:

devstack@devstack-VirtualBox:~$ ssh 172.24.4.229
ssh: connect to host 172.24.4.229 port 22: Connection timed out

Any thoughts about that strange kind of behavior?

Anything to try?