Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

asked 2014-12-25 07:01:07 -0500

RHK gravatar image

HypervisorUnavailable: Connection to the hypervisor is broken on host: compute01

Hello,

I deployed a openstack multinode with juno release, when i launch VM status is getting error.

Here is the error logs i found in nova,

root@compute01:/var/log/nova# tail -f nova-compute.log
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 3299, in _get_host_capabilities
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     xmlstr = self._conn.getCapabilities()
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 775, in _get_connection
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     wrapped_conn = self._get_new_connection()
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 728, in _get_new_connection
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     wrapped_conn = self._connect(self.uri(), self.read_only)
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 848, in _connect
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     raise exception.HypervisorUnavailable(host=CONF.host)
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup HypervisorUnavailable: Connection to the hypervisor is broken on host: compute01
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup

and when i restart libvirt service getting unknown job,

root@compute01:~# service libvirt-bin restart
stop: Unknown job: libvirt-bin
start: Unknown job: libvirt-bin

I verified from hypervisor side it looks ok.

root@compute01:~# kvm-ok
INFO: /dev/kvm exists
KVM acceleration can be used

here is my qemu.conf

cgroup_device_acl = [
"/dev/null", "/dev/full", "/dev/zero",
"/dev/random", "/dev/urandom",
"/dev/ptmx", "/dev/kvm", "/dev/kqemu",
"/dev/rtc", "/dev/hpet","/dev/net/tun"
]

nova-compute.conf

root@compute01:~# vim /etc/nova/nova-compute.conf
[DEFAULT]
compute_driver=libvirt.LibvirtDriver
[libvirt]
virt_type=kvm

any one let me know what i am missing from hypervisor side.

Regards,
RHK

HypervisorUnavailable: Connection to the hypervisor is broken on host: compute01

Hello,

I deployed a openstack multinode with juno release, when i launch VM status is getting error.

Here is the error logs i found in nova,

root@compute01:/var/log/nova# tail -f nova-compute.log
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 3299, in _get_host_capabilities
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     xmlstr = self._conn.getCapabilities()
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 775, in _get_connection
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     wrapped_conn = self._get_new_connection()
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 728, in _get_new_connection
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     wrapped_conn = self._connect(self.uri(), self.read_only)
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 848, in _connect
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup     raise exception.HypervisorUnavailable(host=CONF.host)
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup HypervisorUnavailable: Connection to the hypervisor is broken on host: compute01
2014-12-25 02:17:57.947 7882 TRACE nova.openstack.common.threadgroup

and when i restart libvirt service getting unknown job,

root@compute01:~# service libvirt-bin restart
stop: Unknown job: libvirt-bin
start: Unknown job: libvirt-bin

I verified from hypervisor side it looks ok.

root@compute01:~# kvm-ok
INFO: /dev/kvm exists
KVM acceleration can be used

here is my qemu.conf

cgroup_device_acl = [
"/dev/null", "/dev/full", "/dev/zero",
"/dev/random", "/dev/urandom",
"/dev/ptmx", "/dev/kvm", "/dev/kqemu",
"/dev/rtc", "/dev/hpet","/dev/net/tun"
]

nova-compute.conf

root@compute01:~# vim /etc/nova/nova-compute.conf
[DEFAULT]
compute_driver=libvirt.LibvirtDriver
[libvirt]
virt_type=kvm

any one let me know what i am missing from hypervisor side.

Regards,
RHK