Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't start nova compute

Hello,

I'm having some trouble with nova-compute. I'm installing openstack multi node with four servers and I can't get nova-compute listed in nova services,

Controller node

root@nimbo1:~# nova-manage service list

Binary Host Zone Status State Updated_At

nova-scheduler nimbo1 internal enabled :-) 2013-10-04 00:17:37

nova-conductor nimbo1 internal enabled :-) 2013-10-04 00:17:41

nova-cert nimbo1 internal enabled :-) 2013-10-04 00:17:41

nova-consoleauth nimbo1 internal enabled :-) 2013-10-04 00:17:37

As u see, there is not nova-compute of the compute nodes. When I try to start manuall, nova-compute, there is an error that appears in both compute nodes,

Compute Node

root@nimbo3:~# nova-compute

2013-10-04 02:19:13.460 28996 INFO nova.manager [-] Skipping periodic task _periodic_update_dns because its interval is negative 2013-10-04 02:19:13.522 28996 INFO nova.virt.driver [-] Loading compute driver 'libvirt.LibvirtDriver' 2013-10-04 02:19:13.612 INFO nova.openstack.common.rpc.common [req-a10f7a48-f478-424a-a967-781f4c92facb None None] Connected to AMQP server on 192.168.82.11:5672 2013-10-04 02:19:13.650 28996 AUDIT nova.service [-] Starting compute node (version 2013.1.3) Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/eventlet/hubs/poll.py", line 97, in wait readers.get(fileno, noop).cb(fileno) File "/usr/lib/python2.7/dist-packages/eventlet/greenthread.py", line 194, in main result = function(args, *kwargs) File "/usr/lib/python2.7/dist-packages/nova/service.py", line 147, in run_server server.start() File "/usr/lib/python2.7/dist-packages/nova/service.py", line 429, in start self.manager.init_host() File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 604, in init_host self.host) File "/usr/lib/python2.7/dist-packages/nova/conductor/api.py", line 409, in instance_get_all_by_host context, host, columns_to_join=columns_to_join) File "/usr/lib/python2.7/dist-packages/nova/conductor/rpcapi.py", line 316, in instance_get_all_by_host return self.call(context, msg, version='1.47') File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/proxy.py", line 80, in call return rpc.call(context, self._get_topic(topic), msg, timeout) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/__init__.py", line 140, in call return _get_impl().call(CONF, context, topic, msg, timeout) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/impl_kombu.py", line 798, in call rpc_amqp.get_connection_pool(conf, Connection)) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 612, in call rv = list(rv) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 561, in __iter__ raise result RemoteError: Remote error: UnsupportedRpcVersion Specified RPC version, 1.47, not supported by this endpoint. [u'Traceback (most recent call last):\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/amqp.py", line 430, in _process_data\n rval = self.proxy.dispatch(ctxt, version, method, *args)\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/dispatcher.py", line 138, in dispatch\n raise rpc_common.UnsupportedRpcVersion(version=version)\n', u'UnsupportedRpcVersion: Specified RPC version, 1.47, not supported by this endpoint.\n']. Removing descriptor: 5 2013-10-04 02:19:13.696 28996 CRITICAL nova [-] Remote error: UnsupportedRpcVersion Specified RPC version, 1.47, not supported by this endpoint. [u'Traceback (most recent call last):\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/amqp.py", line 430, in _process_data\n rval = self.proxy.dispatch(ctxt, version, method, *args)\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/dispatcher.py", line 138, in dispatch\n raise rpc_common.UnsupportedRpcVersion(version=version)\n', u'UnsupportedRpcVersion: Specified RPC version, 1.47, not supported by this endpoint.\n']. 2013-10-04 02:19:13.696 28996 TRACE nova Traceback (most recent call last): 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/bin/nova-compute", line 85, in <module> 2013-10-04 02:19:13.696 28996 TRACE nova service.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 689, in wait 2013-10-04 02:19:13.696 28996 TRACE nova _launcher.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 209, in wait 2013-10-04 02:19:13.696 28996 TRACE nova super(ServiceLauncher, self).wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 179, in wait 2013-10-04 02:19:13.696 28996 TRACE nova service.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/greenthread.py", line 168, in wait 2013-10-04 02:19:13.696 28996 TRACE nova return self._exit_event.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/event.py", line 116, in wait 2013-10-04 02:19:13.696 28996 TRACE nova return hubs.get_hub().switch() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/hubs/hub.py", line 187, in switch 2013-10-04 02:19:13.696 28996 TRACE nova return self.greenlet.switch() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/greenthread.py", line 194, in main 2013-10-04 02:19:13.696 28996 TRACE nova result = function(args, *kwargs) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 147, in run_server 2013-10-04 02:19:13.696 28996 TRACE nova server.start() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 429, in start 2013-10-04 02:19:13.696 28996 TRACE nova self.manager.init_host() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 604, in init_host 2013-10-04 02:19:13.696 28996 TRACE nova self.host) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/conductor/api.py", line 409, in instance_get_all_by_host 2013-10-04 02:19:13.696 28996 TRACE nova context, host, columns_to_join=columns_to_join) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/conductor/rpcapi.py", line 316, in instance_get_all_by_host 2013-10-04 02:19:13.696 28996 TRACE nova return self.call(context, msg, version='1.47') 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/proxy.py", line 80, in call 2013-10-04 02:19:13.696 28996 TRACE nova return rpc.call(context, self._get_topic(topic), msg, timeout) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/__init__.py", line 140, in call 2013-10-04 02:19:13.696 28996 TRACE nova return _get_impl().call(CONF, context, topic, msg, timeout) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/impl_kombu.py", line 798, in call 2013-10-04 02:19:13.696 28996 TRACE nova rpc_amqp.get_connection_pool(conf, Connection)) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 612, in call 2013-10-04 02:19:13.696 28996 TRACE nova rv = list(rv) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 561, in __iter__ 2013-10-04 02:19:13.696 28996 TRACE nova raise result 2013-10-04 02:19:13.696 28996 TRACE nova RemoteError: Remote error: UnsupportedRpcVersion Specified RPC version, 1.47, not supported by this endpoint. 2013-10-04 02:19:13.696 28996 TRACE nova [u'Traceback (most recent call last):\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/amqp.py", line 430, in _process_data\n rval = self.proxy.dispatch(ctxt, version, method, **args)\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/dispatcher.py", line 138, in dispatch\n raise rpc_common.UnsupportedRpcVersion(version=version)\n', u'UnsupportedRpcVersion: Specified RPC version, 1.47, not supported by this endpoint.\n']. 2013-10-04 02:19:13.696 28996 TRACE nova

I have already tried to upgrade and update all the node but the error still appears. Hope u can help me. Thanks!

Can't start nova compute

Hello,

I'm having some trouble with nova-compute. I'm installing openstack multi node with four servers and I can't get nova-compute listed in nova services,

Controller node

root@nimbo1:~# nova-manage service list

list Binary Host Zone Status State Updated_At

Updated_At nova-scheduler nimbo1 internal enabled :-) 2013-10-04 00:17:37

nova-conductor nimbo1 internal enabled :-) 2013-10-04 00:17:41

nova-cert nimbo1 internal enabled :-) 2013-10-04 00:17:41

nova-consoleauth nimbo1 internal enabled :-) 2013-10-04 00:17:37

00:17:37

As u see, there is not nova-compute of the compute nodes. When I try to start manuall, nova-compute, there is an error that appears in both compute nodes,

Compute Node

root@nimbo3:~# nova-compute

nova-compute 2013-10-04 02:19:13.460 28996 INFO nova.manager [-] Skipping periodic task _periodic_update_dns because its interval is negative 2013-10-04 02:19:13.522 28996 INFO nova.virt.driver [-] Loading compute driver 'libvirt.LibvirtDriver' 2013-10-04 02:19:13.612 INFO nova.openstack.common.rpc.common [req-a10f7a48-f478-424a-a967-781f4c92facb None None] Connected to AMQP server on 192.168.82.11:5672 2013-10-04 02:19:13.650 28996 AUDIT nova.service [-] Starting compute node (version 2013.1.3) Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/eventlet/hubs/poll.py", line 97, in wait readers.get(fileno, noop).cb(fileno) File "/usr/lib/python2.7/dist-packages/eventlet/greenthread.py", line 194, in main result = function(args, *kwargs) function(*args, **kwargs) File "/usr/lib/python2.7/dist-packages/nova/service.py", line 147, in run_server server.start() File "/usr/lib/python2.7/dist-packages/nova/service.py", line 429, in start self.manager.init_host() File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 604, in init_host self.host) File "/usr/lib/python2.7/dist-packages/nova/conductor/api.py", line 409, in instance_get_all_by_host context, host, columns_to_join=columns_to_join) File "/usr/lib/python2.7/dist-packages/nova/conductor/rpcapi.py", line 316, in instance_get_all_by_host return self.call(context, msg, version='1.47') File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/proxy.py", line 80, in call return rpc.call(context, self._get_topic(topic), msg, timeout) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/__init__.py", line 140, in call return _get_impl().call(CONF, context, topic, msg, timeout) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/impl_kombu.py", line 798, in call rpc_amqp.get_connection_pool(conf, Connection)) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 612, in call rv = list(rv) File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 561, in __iter__ raise result RemoteError: Remote error: UnsupportedRpcVersion Specified RPC version, 1.47, not supported by this endpoint. [u'Traceback (most recent call last):\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/amqp.py", line 430, in _process_data\n rval = self.proxy.dispatch(ctxt, version, method, *args)\n', **args)\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/dispatcher.py", line 138, in dispatch\n raise rpc_common.UnsupportedRpcVersion(version=version)\n', u'UnsupportedRpcVersion: Specified RPC version, 1.47, not supported by this endpoint.\n']. Removing descriptor: 5 2013-10-04 02:19:13.696 28996 CRITICAL nova [-] Remote error: UnsupportedRpcVersion Specified RPC version, 1.47, not supported by this endpoint. [u'Traceback (most recent call last):\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/amqp.py", line 430, in _process_data\n rval = self.proxy.dispatch(ctxt, version, method, *args)\n', **args)\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/dispatcher.py", line 138, in dispatch\n raise rpc_common.UnsupportedRpcVersion(version=version)\n', u'UnsupportedRpcVersion: Specified RPC version, 1.47, not supported by this endpoint.\n']. 2013-10-04 02:19:13.696 28996 TRACE nova Traceback (most recent call last): 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/bin/nova-compute", line 85, in <module> 2013-10-04 02:19:13.696 28996 TRACE nova service.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 689, in wait 2013-10-04 02:19:13.696 28996 TRACE nova _launcher.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 209, in wait 2013-10-04 02:19:13.696 28996 TRACE nova super(ServiceLauncher, self).wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 179, in wait 2013-10-04 02:19:13.696 28996 TRACE nova service.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/greenthread.py", line 168, in wait 2013-10-04 02:19:13.696 28996 TRACE nova return self._exit_event.wait() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/event.py", line 116, in wait 2013-10-04 02:19:13.696 28996 TRACE nova return hubs.get_hub().switch() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/hubs/hub.py", line 187, in switch 2013-10-04 02:19:13.696 28996 TRACE nova return self.greenlet.switch() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/eventlet/greenthread.py", line 194, in main 2013-10-04 02:19:13.696 28996 TRACE nova result = function(args, *kwargs) function(*args, **kwargs) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 147, in run_server 2013-10-04 02:19:13.696 28996 TRACE nova server.start() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/service.py", line 429, in start 2013-10-04 02:19:13.696 28996 TRACE nova self.manager.init_host() 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 604, in init_host 2013-10-04 02:19:13.696 28996 TRACE nova self.host) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/conductor/api.py", line 409, in instance_get_all_by_host 2013-10-04 02:19:13.696 28996 TRACE nova context, host, columns_to_join=columns_to_join) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/conductor/rpcapi.py", line 316, in instance_get_all_by_host 2013-10-04 02:19:13.696 28996 TRACE nova return self.call(context, msg, version='1.47') 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/proxy.py", line 80, in call 2013-10-04 02:19:13.696 28996 TRACE nova return rpc.call(context, self._get_topic(topic), msg, timeout) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/__init__.py", line 140, in call 2013-10-04 02:19:13.696 28996 TRACE nova return _get_impl().call(CONF, context, topic, msg, timeout) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/impl_kombu.py", line 798, in call 2013-10-04 02:19:13.696 28996 TRACE nova rpc_amqp.get_connection_pool(conf, Connection)) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 612, in call 2013-10-04 02:19:13.696 28996 TRACE nova rv = list(rv) 2013-10-04 02:19:13.696 28996 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 561, in __iter__ 2013-10-04 02:19:13.696 28996 TRACE nova raise result 2013-10-04 02:19:13.696 28996 TRACE nova RemoteError: Remote error: UnsupportedRpcVersion Specified RPC version, 1.47, not supported by this endpoint. 2013-10-04 02:19:13.696 28996 TRACE nova [u'Traceback (most recent call last):\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/amqp.py", line 430, in _process_data\n rval = self.proxy.dispatch(ctxt, version, method, **args)\n', u' File "/opt/stack/nova/nova/openstack/common/rpc/dispatcher.py", line 138, in dispatch\n raise rpc_common.UnsupportedRpcVersion(version=version)\n', u'UnsupportedRpcVersion: Specified RPC version, 1.47, not supported by this endpoint.\n']. 2013-10-04 02:19:13.696 28996 TRACE nova

nova

I have already tried to upgrade and update all the node but the error still appears. Hope u can help me. Thanks!