Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

asked 2014-12-18 22:43:44 -0500

teju gravatar image

How to install Ironic in Ubuntu 14.04?

I've installed openstack Juno packages in Ubuntu 14.04.

I am trying to install Ironic by following the instructions in the below link:

http://docs.openstack.org/developer/ironic/deploy/install-guide.html

The below command throws an error

apt-get install ironic-api ironic-conductor python-ironicclient

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ironic-api : Depends: ironic-common (= 2014.1~rc1-0ubuntu1) but it is not going to be installed ironic-conductor : Depends: ironic-common (= 2014.1~rc1-0ubuntu1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

How to fix this?

NOTE : My Ubuntu version

lsb_release -a

No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty

How to install Ironic in Ubuntu 14.04?

I've installed openstack Juno packages in Ubuntu 14.04.14.04 by following standard openstack docs.

I am trying to install Ironic by following the instructions in the below link:

http://docs.openstack.org/developer/ironic/deploy/install-guide.html

The below command throws an error

apt-get install ironic-api ironic-conductor python-ironicclient

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ironic-api : Depends: ironic-common (= 2014.1~rc1-0ubuntu1) but it is not going to be installed ironic-conductor : Depends: ironic-common (= 2014.1~rc1-0ubuntu1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

How to fix this?

NOTE : My Ubuntu version

lsb_release -a

No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.1 LTS Release: 14.04 Codename: trusty