Ask Your Question

Revision history [back]

dhcp issue RDO AIO juno

Hi, I correctly installed Juno release with RDO on CentOS7 machine.

Now I am facing a problem when starting VMs, seems dhcp is not working fine; here some debug commands:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ll
total 20
-rw-r--r--. 1 neutron neutron 156 Dec  9 10:42 addn_hosts
-rw-r--r--. 1 neutron neutron 168 Dec  9 10:42 host
-rw-r--r--. 1 neutron neutron  14 Dec  9 10:42 interface
-rw-r--r--. 1 neutron neutron  67 Dec  9 10:42 opts
-rw-r--r--. 1 root    root      6 Dec  9 10:42 pid
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat addn_hosts
10.0.0.2        host-10-0-0-2.openstacklocal host-10-0-0-2
10.0.0.9        host-10-0-0-9.openstacklocal host-10-0-0-9
10.0.0.1        host-10-0-0-1.openstacklocal host-10-0-0-1
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat host
fa:16:3e:17:69:78,host-10-0-0-2.openstacklocal,10.0.0.2
fa:16:3e:2b:ea:63,host-10-0-0-9.openstacklocal,10.0.0.9
fa:16:3e:8a:3e:fc,host-10-0-0-1.openstacklocal,10.0.0.1
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat interface
tap3c06f7ab-47[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat opts
tag:tag0,option:router,10.0.0.1
tag:tag0,option:dns-server,10.0.0.2[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat pid
11846
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   11846     1  0 10:42 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
root     13774  3865  0 10:54 pts/0    00:00:00 grep --color=auto dnsmasq
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
9: tap3c06f7ab-47: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:17:69:78 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global tap3c06f7ab-47
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe17:6978/64 scope link
       valid_lft forever preferred_lft forever

I also followed tips fron dbaxps in this answer but it doesn't help.

No tcpdump capturing line when performing:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c tcpdump -ln -i tap3c06f7ab-47
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on tap3c06f7ab-47, link-type EN10MB (Ethernet), capture size 65535 bytes

Is it correct that 'dnsmasq' process is owned by 'nobody' user? I also tried running the command with root user with no luck:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   11846     1  0 10:42 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
root     15734  3865  0 11:06 pts/0    00:00:00 grep --color=auto dnsmasq
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# kill 11846
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   15813     1  0 11:06 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal

Thanks in advance for any suggestion...

dhcp issue RDO AIO juno

Hi, I correctly installed Juno release with RDO on CentOS7 machine.machine. Here some reference on used versions:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# rpm -qa | grep neutron
python-neutron-2014.2-11.el7.centos.noarch
openstack-neutron-2014.2-11.el7.centos.noarch
openstack-neutron-openvswitch-2014.2-11.el7.centos.noarch
python-neutronclient-2.3.9-1.el7.centos.noarch
openstack-neutron-metering-agent-2014.2-11.el7.centos.noarch
openstack-neutron-ml2-2014.2-11.el7.centos.noarch

Now I am facing a problem when starting VMs, seems dhcp is not working fine; here some debug commands:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ll
total 20
-rw-r--r--. 1 neutron neutron 156 Dec  9 10:42 addn_hosts
-rw-r--r--. 1 neutron neutron 168 Dec  9 10:42 host
-rw-r--r--. 1 neutron neutron  14 Dec  9 10:42 interface
-rw-r--r--. 1 neutron neutron  67 Dec  9 10:42 opts
-rw-r--r--. 1 root    root      6 Dec  9 10:42 pid
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat addn_hosts
10.0.0.2        host-10-0-0-2.openstacklocal host-10-0-0-2
10.0.0.9        host-10-0-0-9.openstacklocal host-10-0-0-9
10.0.0.1        host-10-0-0-1.openstacklocal host-10-0-0-1
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat host
fa:16:3e:17:69:78,host-10-0-0-2.openstacklocal,10.0.0.2
fa:16:3e:2b:ea:63,host-10-0-0-9.openstacklocal,10.0.0.9
fa:16:3e:8a:3e:fc,host-10-0-0-1.openstacklocal,10.0.0.1
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat interface
tap3c06f7ab-47[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat opts
tag:tag0,option:router,10.0.0.1
tag:tag0,option:dns-server,10.0.0.2[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat pid
11846
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   11846     1  0 10:42 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
root     13774  3865  0 10:54 pts/0    00:00:00 grep --color=auto dnsmasq
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
9: tap3c06f7ab-47: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:17:69:78 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global tap3c06f7ab-47
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe17:6978/64 scope link
       valid_lft forever preferred_lft forever

I also followed tips fron from dbaxps in this answer but it doesn't help.

No tcpdump capturing line when performing:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c tcpdump -ln -i tap3c06f7ab-47
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on tap3c06f7ab-47, link-type EN10MB (Ethernet), capture size 65535 bytes

Is it correct that 'dnsmasq' process is owned by 'nobody' user? I also tried running the command with root user with no luck:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   11846     1  0 10:42 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
root     15734  3865  0 11:06 pts/0    00:00:00 grep --color=auto dnsmasq
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# kill 11846
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   15813     1  0 11:06 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal

Thanks in advance for any suggestion...

dhcp issue RDO AIO juno

Hi, I correctly installed Juno release with RDO on CentOS7 machine. Here some reference on used versions:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# rpm -qa | grep neutron
python-neutron-2014.2-11.el7.centos.noarch
openstack-neutron-2014.2-11.el7.centos.noarch
openstack-neutron-openvswitch-2014.2-11.el7.centos.noarch
python-neutronclient-2.3.9-1.el7.centos.noarch
openstack-neutron-metering-agent-2014.2-11.el7.centos.noarch
openstack-neutron-ml2-2014.2-11.el7.centos.noarch

Now I am facing a problem when starting VMs, seems dhcp is not working fine; here some debug commands:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ll
total 20
-rw-r--r--. 1 neutron neutron 156 Dec  9 10:42 addn_hosts
-rw-r--r--. 1 neutron neutron 168 Dec  9 10:42 host
-rw-r--r--. 1 neutron neutron  14 Dec  9 10:42 interface
-rw-r--r--. 1 neutron neutron  67 Dec  9 10:42 opts
-rw-r--r--. 1 root    root      6 Dec  9 10:42 pid
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat addn_hosts
10.0.0.2        host-10-0-0-2.openstacklocal host-10-0-0-2
10.0.0.9        host-10-0-0-9.openstacklocal host-10-0-0-9
10.0.0.1        host-10-0-0-1.openstacklocal host-10-0-0-1
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat host
fa:16:3e:17:69:78,host-10-0-0-2.openstacklocal,10.0.0.2
fa:16:3e:2b:ea:63,host-10-0-0-9.openstacklocal,10.0.0.9
fa:16:3e:8a:3e:fc,host-10-0-0-1.openstacklocal,10.0.0.1
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat interface
tap3c06f7ab-47[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat opts
tag:tag0,option:router,10.0.0.1
tag:tag0,option:dns-server,10.0.0.2[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# cat pid
11846
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   11846     1  0 10:42 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
root     13774  3865  0 10:54 pts/0    00:00:00 grep --color=auto dnsmasq
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
9: tap3c06f7ab-47: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN
    link/ether fa:16:3e:17:69:78 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global tap3c06f7ab-47
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe17:6978/64 scope link
       valid_lft forever preferred_lft forever

I also followed tips from dbaxps in this answer but it doesn't help.

No tcpdump capturing line when performing:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c tcpdump -ln -i tap3c06f7ab-47
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on tap3c06f7ab-47, link-type EN10MB (Ethernet), capture size 65535 bytes

Is it correct that 'dnsmasq' process is owned by 'nobody' user? I also tried running the command with root user with no luck:perceivable change:

[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   11846 16047     1  0 10:42 11:08 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
root     15734 17181  3865  0 11:06 11:15 pts/0    00:00:00 grep --color=auto dnsmasq
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# kill 11846
16047
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ip netns exec qdhcp-6137f6d8-ee0b-451c-ac69-7178b6964f9c sudo dnsmasq **--user=root** --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal
[root@juno61-60-controller 6137f6d8-ee0b-451c-ac69-7178b6964f9c]# ps -ef | grep dnsmasq
nobody   15813 root     17303     1  0 11:06 11:16 ?        00:00:00 dnsmasq --user=root --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tap3c06f7ab-47 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/host --addn-hosts=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/6137f6d8-ee0b-451c-ac69-7178b6964f9c/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file=/etc/neutron/dnsmasq-neutron.conf --domain=openstacklocal

Thanks in advance for any suggestion...