Revision history [back]

click to hide/show revision 1
initial version

nova service state all down

i was following juno on ubuntu step by step. but some issues had to make me stop and look back when i was installing and configuring on compute-node. it turns out that all my nova service state is not up. root@controller:~# nova service-list +----+------------------+------------+----------+---------+-------+------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | +----+------------------+------------+----------+---------+-------+------------+-----------------+ | 1 | nova-cert | controller | internal | enabled | down | - | - | | 2 | nova-consoleauth | controller | internal | enabled | down | - | - | | 3 | nova-scheduler | controller | internal | enabled | down | - | - | | 4 | nova-conductor | controller | internal | enabled | down | - | - | +----+------------------+------------+----------+---------+-------+------------+-----------------+

what's more, controller couldn't detect nova-compute from compute node.
here is some log from compute node

2014-12-05 15:36:07.534 7958 INFO oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] Delaying reconnect for 1.0 seconds... 2014-12-05 15:36:08.536 7958 INFO oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] Connecting to AMQP server on controller:5672 2014-12-05 15:36:11.556 7958 ERROR oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed

telnet to controller 5672 port is ok. root@compute:/home# telnet controller 5672 Trying 10.139.37.245... Connected to controller. Escape character is '^]'. Connection closed by foreign host.

here is part of setting on /etc/nova/nova.conf, im pretty sure that network connection among controller, compute and network is good. and i checked the rabbit_password is matched.

my_ip = 10.139.37.246 rabbit_host = controller rabbit_password=12345 auth_strategy = keystone my_ip = 10.139.37.246 vnc_enabled = True vncserver_listen = 0.0.0.0 vncserver_proxyclient_address = 10.139.37.246 novncproxy_base_url = http://controller:6080/vnc_auto.html

[keystone_authtoken] auth_uri = http://controller:5000/v2.0 identity_uri = http://controller:35357 admin_tenant_name = service admin_user = nova admin_password = 12345

[glance] host = controller

the following is nova.conf on controller

rpc_backend = rabbit rabbit_host = controller rabbit_password=12345 auth_strategy = keystone my_ip = 10.139.37.245 vncserver_listen = 10.139.37.245 vncserver_proxyclient_address = 10.139.37.245 verbose = True

i have no idea where goes wrong.

nova service state all down

i was following juno on ubuntu step by step. but some issues had to make me stop and look back when i was installing and configuring on compute-node. it turns out that all my nova service state is not up. up.

root@controller:~# nova service-list
+----+------------------+------------+----------+---------+-------+------------+-----------------+
| Id | Binary           | Host       | Zone     | Status  | State | Updated_at | Disabled Reason |
+----+------------------+------------+----------+---------+-------+------------+-----------------+
| 1  | nova-cert        | controller | internal | enabled | down  | -          | -               |
| 2  | nova-consoleauth | controller | internal | enabled | down  | -          | -               |
| 3  | nova-scheduler   | controller | internal | enabled | down  | -          | -               |
| 4  | nova-conductor   | controller | internal | enabled | down  | -          | -               |
+----+------------------+------------+----------+---------+-------+------------+-----------------+

+----+------------------+------------+----------+---------+-------+------------+-----------------+

what's more, controller couldn't detect nova-compute from compute node.
here is some log from compute node

2014-12-05 15:36:07.534 7958 INFO oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] Delaying reconnect for 1.0 seconds...
2014-12-05 15:36:08.536 7958 INFO oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] Connecting to AMQP server on controller:5672
2014-12-05 15:36:11.556 7958 ERROR oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed

closed

telnet to controller 5672 port is ok. root@compute:/home# telnet controller 5672 Trying 10.139.37.245... Connected to controller. Escape character is '^]'. Connection closed by foreign host.

here is part of setting on /etc/nova/nova.conf, im pretty sure that network connection among controller, compute and network is good. and i checked the rabbit_password is matched.

my_ip = 10.139.37.246
rabbit_host = controller
rabbit_password=12345
auth_strategy = keystone
my_ip = 10.139.37.246
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.139.37.246
novncproxy_base_url = http://controller:6080/vnc_auto.html

http://controller:6080/vnc_auto.html [keystone_authtoken] auth_uri = http://controller:5000/v2.0 identity_uri = http://controller:35357 admin_tenant_name = service admin_user = nova admin_password = 12345

12345 [glance] host = controller

controller

the following is nova.conf on controller

rpc_backend = rabbit
rabbit_host = controller
rabbit_password=12345
auth_strategy = keystone
my_ip = 10.139.37.245
vncserver_listen = 10.139.37.245
vncserver_proxyclient_address = 10.139.37.245
verbose = True

True

i have no idea where goes wrong.