Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

devstack multi-node lab compute node fails

I am trying to setup the mutil-node devstack setup http://docs.openstack.org/developer/devstack/guides/multinode-lab.html. I can install devstack on the controller node just fine. But while adding a compute node, devstack fails with

2014-12-04 10:43:31.826 | + cinder type-create lvmdriver-1
2014-12-04 10:43:32.127 | ERROR: Unable to establish connection to http://127.0.0.1:5000/v2.0/tokens
2014-12-04 10:43:32.148 | ++ err_trap
2014-12-04 10:43:32.148 | ++ local r=1
2014-12-04 10:43:32.148 | stack.sh failed: full log in /opt/stack/logs/stack.sh.log.2014-12-04-161234
2014-12-04 10:43:32.148 | Error on exit

I have made sure that the endpoints in the controller have routable IPs, but for some reason the keystone client on the compute node thinks the auth uri is the loopback ip. How can change it to have the routable ip?

I have been reproducing this error multiple times with different approaches. I tried having the two nodes in a private network of vagrant boxes, tried with two physical machines running Ubuntu. But I'm not able to solve this issue. Any inputs are greatly appreciated.

devstack multi-node lab compute node fails

I am trying to setup the mutil-node devstack setup http://docs.openstack.org/developer/devstack/guides/multinode-lab.html. I can install devstack on the controller node just fine. But while adding a compute node, devstack fails with

2014-12-04 10:43:31.826 | + cinder type-create lvmdriver-1
2014-12-04 10:43:32.127 | ERROR: Unable to establish connection to http://127.0.0.1:5000/v2.0/tokens
2014-12-04 10:43:32.148 | ++ err_trap
2014-12-04 10:43:32.148 | ++ local r=1
2014-12-04 10:43:32.148 | stack.sh failed: full log in /opt/stack/logs/stack.sh.log.2014-12-04-161234
2014-12-04 10:43:32.148 | Error on exit

I have made sure that the endpoints in the controller have routable IPs, but for some reason the keystone client on the compute node thinks the auth uri is the loopback ip. How can change it to have the routable ip?

I have been reproducing this error multiple times with different approaches. I tried having the two nodes in a private network of vagrant boxes, tried with two physical machines running Ubuntu. But I'm not able to solve this issue. Any inputs are greatly appreciated.

Controller local.conf

[[local|localrc]]
HOST_IP=10.4.1.255
FLAT_INTERFACE=eth0
FIXED_RANGE=192.168.0.0/20
FIXED_NETWORK_SIZE=4096
FLOATING_RANGE=10.4.2.0/28
# Credentials
DATABASE_PASSWORD=secrete
ADMIN_PASSWORD=secrete
SERVICE_PASSWORD=secrete
SERVICE_TOKEN=secrete
RABBIT_PASSWORD=secrete
MULTI_HOST=1

# Enable Logging
LOGFILE=/opt/stack/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=True
SCREEN_LOGDIR=/opt/stack/logs
RECLONE=yes

Compute local.conf

[[local|localrc]]
HOST_IP=10.4.1.208
FLAT_INTERFACE=eth0
FIXED_RANGE=192.168.0.0/20
FIXED_NETWORK_SIZE=4096
FLOATING_RANGE=10.4.2.0/28
MULTI_HOST=1
LOGFILE=/opt/stack/logs/stack.sh.log
ADMIN_PASSWORD=secrete
MYSQL_PASSWORD=secrete
RABBIT_PASSWORD=secrete
SERVICE_PASSWORD=secrete
SERVICE_TOKEN=secrete
DATABASE_TYPE=mysql
SERVICE_HOST=
MYSQL_HOST=10.4.1.255
RABBIT_HOST=10.4.1.255
GLANCE_HOSTPORT=10.4.1.255:9292
ENABLED_SERVICES=n-cpu,n-net,n-api,c-sch,c-api,c-vol
NOVA_VNC_ENABLED=True
NOVNCPROXY_URL="http://10.4.1.255:6080/vnc_auto.html"
VNCSERVER_LISTEN=$HOST_IP
VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN

devstack multi-node lab compute node fails

I am trying to setup the mutil-node devstack setup http://docs.openstack.org/developer/devstack/guides/multinode-lab.html. I can install devstack on the controller node just fine. But while adding a compute node, devstack fails with

2014-12-04 10:43:31.826 | + cinder type-create lvmdriver-1
2014-12-04 10:43:32.127 | ERROR: Unable to establish connection to http://127.0.0.1:5000/v2.0/tokens
2014-12-04 10:43:32.148 | ++ err_trap
2014-12-04 10:43:32.148 | ++ local r=1
2014-12-04 10:43:32.148 | stack.sh failed: full log in /opt/stack/logs/stack.sh.log.2014-12-04-161234
2014-12-04 10:43:32.148 | Error on exit

I have made sure that the endpoints in the controller have routable IPs, but for some reason the keystone client on the compute node thinks the auth uri is the loopback ip. How can change it to have the routable ip?

I have been reproducing this error multiple times with different approaches. I tried having the two nodes in a private network of vagrant boxes, tried with two physical machines running Ubuntu. But I'm not able to solve this issue. Any inputs are greatly appreciated.

Controller local.conf

[[local|localrc]]
HOST_IP=10.4.1.255
FLAT_INTERFACE=eth0
FIXED_RANGE=192.168.0.0/20
FIXED_NETWORK_SIZE=4096
FLOATING_RANGE=10.4.2.0/28
# Credentials
DATABASE_PASSWORD=secrete
ADMIN_PASSWORD=secrete
SERVICE_PASSWORD=secrete
SERVICE_TOKEN=secrete
RABBIT_PASSWORD=secrete
MULTI_HOST=1

# Enable Logging
LOGFILE=/opt/stack/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=True
SCREEN_LOGDIR=/opt/stack/logs
RECLONE=yes

Compute local.conf

[[local|localrc]]
HOST_IP=10.4.1.208
FLAT_INTERFACE=eth0
FIXED_RANGE=192.168.0.0/20
FIXED_NETWORK_SIZE=4096
FLOATING_RANGE=10.4.2.0/28
MULTI_HOST=1
LOGFILE=/opt/stack/logs/stack.sh.log
ADMIN_PASSWORD=secrete
MYSQL_PASSWORD=secrete
RABBIT_PASSWORD=secrete
SERVICE_PASSWORD=secrete
SERVICE_TOKEN=secrete
DATABASE_TYPE=mysql
SERVICE_HOST=
SERVICE_HOST=10.4.1.255
MYSQL_HOST=10.4.1.255
RABBIT_HOST=10.4.1.255
GLANCE_HOSTPORT=10.4.1.255:9292
ENABLED_SERVICES=n-cpu,n-net,n-api,c-sch,c-api,c-vol
NOVA_VNC_ENABLED=True
NOVNCPROXY_URL="http://10.4.1.255:6080/vnc_auto.html"
VNCSERVER_LISTEN=$HOST_IP
VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN