Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

juno 3 node configuration external network not working

Hi, I have installed an ubuntu juno version with three separate node configuration, controller, network, compute1 Everything is working but the external network. everything seems ok, i can add the floating ip to the server (Cirros) and from inside the server I can ping the floating ip assigned. I cannot ping any external ip from the server and I cannot ping of course the ip of the server from outside. It looks like a routing problem, From the definition I have assigned a router to the subnet (gw 10.60.1.1 from 10.60.85.100 to 10.60.85.110 mask 10.60.0.0/16) but looking from the dashboard I see that the network:router_gateway is assigned to the first ip of the range of the floating ips.

I have tried to redefine several times with different configuration but nothing seems to work I have reviews also all the settings.

From the network node I can see:

root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip addr show 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN group default link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 16: qr-8c36733f-27: <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN group default link/ether fa:16:3e:02:e7:85 brd ff:ff:ff:ff:ff:ff inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-8c36733f-27 valid_lft forever preferred_lft forever inet6 fe80::f816:3eff:fe02:e785/64 scope link valid_lft forever preferred_lft forever 21: qg-02d1751e-37: <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN group default link/ether fa:16:3e:2b:90:87 brd ff:ff:ff:ff:ff:ff inet 10.60.85.100/16 brd 10.60.255.255 scope global qg-02d1751e-37 valid_lft forever preferred_lft forever inet 10.60.85.101/32 brd 10.60.85.101 scope global qg-02d1751e-37 valid_lft forever preferred_lft forever inet6 fe80::f816:3eff:fe2b:9087/64 scope link valid_lft forever preferred_lft forever root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip route default via 10.60.1.1 dev qg-02d1751e-37 10.60.0.0/16 dev qg-02d1751e-37 proto kernel scope link src 10.60.85.100 192.168.1.0/24 dev qr-8c36733f-27 proto kernel scope link src 192.168.1.1 root@network:~#

in this moment I have one floating ip assigned by me: 10.65.85.101 The other one was automatically assigned to the network:router_gateway that I can see from the dashboard

Thanks for your help

juno 3 node configuration external network not working

Hi, I have installed an ubuntu juno version with three separate node configuration, controller, network, compute1 Everything is working but the external network. everything seems ok, i can add the floating ip to the server (Cirros) and from inside the server I can ping the floating ip assigned. I cannot ping any external ip from the server and I cannot ping of course the ip of the server from outside. It looks like a routing problem, problem,

From the definition I have assigned a router to the subnet (gw 10.60.1.1 from 10.60.85.100 to 10.60.85.110 mask 10.60.0.0/16) but looking from the dashboard I see that the network:router_gateway is assigned to the first ip of the range of the floating ips.

ips.

I have tried to redefine several times with different configuration but nothing seems to work I have reviews also all the settings.

From the network node I can see:

root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip addr show
1: lo: <loopback,up,lower_up> <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
16: qr-8c36733f-27: <broadcast,up,lower_up> <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether fa:16:3e:02:e7:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-8c36733f-27
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe02:e785/64 scope link
       valid_lft forever preferred_lft forever
21: qg-02d1751e-37: <broadcast,up,lower_up> <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether fa:16:3e:2b:90:87 brd ff:ff:ff:ff:ff:ff
    inet 10.60.85.100/16 brd 10.60.255.255 scope global qg-02d1751e-37
       valid_lft forever preferred_lft forever
    inet 10.60.85.101/32 brd 10.60.85.101 scope global qg-02d1751e-37
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe2b:9087/64 scope link
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip route
default via 10.60.1.1 dev qg-02d1751e-37
10.60.0.0/16 dev qg-02d1751e-37  proto kernel  scope link  src 10.60.85.100
192.168.1.0/24 dev qr-8c36733f-27  proto kernel  scope link  src 192.168.1.1
root@network:~#

root@network:~#

in this moment I have one floating ip assigned by me: 10.65.85.101 The other one was automatically assigned to the network:router_gateway that I can see from the dashboard

Thanks for your help

juno 3 node configuration external network not working

Hi, I have installed an ubuntu juno version with three separate node configuration, controller, network, compute1 Everything is working but the external network. everything seems ok, i can add the floating ip to the server (Cirros) and from inside the server I can ping the floating ip assigned. I cannot ping any external ip from the server and I cannot ping of course the ip of the server from outside. It looks like a routing problem,

problem,
From the definition I have assigned a router to the subnet (gw 10.60.1.1 from 10.60.85.100 to 10.60.85.110 mask 10.60.0.0/16) but looking from the dashboard I see that the network:router_gateway is assigned to the first ip of the range of the floating ips.
ips.

I have tried to redefine several times with different configuration but nothing seems to work I have reviews also all the settings.

From the network node I can see:

root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip addr show 1: lo: <LOOPBACK,UP,LOWER_UP> <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN group default link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 16: qr-8c36733f-27: <BROADCAST,UP,LOWER_UP> <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN group default link/ether fa:16:3e:02:e7:85 brd ff:ff:ff:ff:ff:ff inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-8c36733f-27 valid_lft forever preferred_lft forever inet6 fe80::f816:3eff:fe02:e785/64 scope link valid_lft forever preferred_lft forever 21: qg-02d1751e-37: <BROADCAST,UP,LOWER_UP> <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN group default link/ether fa:16:3e:2b:90:87 brd ff:ff:ff:ff:ff:ff inet 10.60.85.100/16 brd 10.60.255.255 scope global qg-02d1751e-37 valid_lft forever preferred_lft forever inet 10.60.85.101/32 brd 10.60.85.101 scope global qg-02d1751e-37 valid_lft forever preferred_lft forever inet6 fe80::f816:3eff:fe2b:9087/64 scope link valid_lft forever preferred_lft forever root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip route default via 10.60.1.1 dev qg-02d1751e-37 10.60.0.0/16 dev qg-02d1751e-37 proto kernel scope link src 10.60.85.100 192.168.1.0/24 dev qr-8c36733f-27 proto kernel scope link src 192.168.1.1 root@network:~#

root@network:~#

root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd iptables -t nat -L Chain PREROUTING (policy ACCEPT) target prot opt source destination neutron-l3-agent-PREROUTING all -- anywhere anywhere

Chain INPUT (policy ACCEPT) target prot opt source destination

Chain OUTPUT (policy ACCEPT) target prot opt source destination neutron-l3-agent-OUTPUT all -- anywhere anywhere

Chain POSTROUTING (policy ACCEPT) target prot opt source destination neutron-l3-agent-POSTROUTING all -- anywhere anywhere neutron-postrouting-bottom all -- anywhere anywhere

Chain neutron-l3-agent-OUTPUT (1 references) target prot opt source destination DNAT all -- anywhere 10.60.85.101 to:192.168.1.5

Chain neutron-l3-agent-POSTROUTING (1 references) target prot opt source destination ACCEPT all -- anywhere anywhere ! ctstate DNAT

Chain neutron-l3-agent-PREROUTING (1 references) target prot opt source destination REDIRECT tcp -- anywhere 169.254.169.254 tcp dpt:http redir ports 9697 DNAT all -- anywhere 10.60.85.101 to:192.168.1.5

Chain neutron-l3-agent-float-snat (1 references) target prot opt source destination SNAT all -- 192.168.1.5 anywhere to:10.60.85.101

Chain neutron-l3-agent-snat (1 references) target prot opt source destination neutron-l3-agent-float-snat all -- anywhere anywhere SNAT all -- 192.168.1.0/24 anywhere to:10.60.85.100

Chain neutron-postrouting-bottom (1 references) target prot opt source destination neutron-l3-agent-snat all -- anywhere anywhere

in this moment I have one floating ip assigned by me: 10.65.85.101 10.65.85.101, the cirros server has 192.168.1.5 assigned from dhcp The other one was automatically assigned to the network:router_gateway that I can see from the dashboard

Thanks for your help

juno 3 node configuration external network not working

Hi, I have installed an ubuntu juno version with three separate node configuration, controller, network, compute1 Everything is working but the external network. everything seems ok, i can add the floating ip to the server (Cirros) and from inside the server I can ping the floating ip assigned. I cannot ping any external ip from the server and I cannot ping of course the ip of the server from outside. It looks like a routing problem, problem,

From the definition I have assigned a router to the subnet (gw 10.60.1.1 from 10.60.85.100 to 10.60.85.110 mask 10.60.0.0/16) but looking from the dashboard I see that the network:router_gateway is assigned to the first ip of the range of the floating ips.

ips.

I have tried to redefine several times with different configuration but nothing seems to work I have reviews also all the settings.

From the network node I can see:

root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip addr show
1: lo: <loopback,up,lower_up> <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
16: qr-8c36733f-27: <broadcast,up,lower_up> <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether fa:16:3e:02:e7:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-8c36733f-27
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe02:e785/64 scope link
       valid_lft forever preferred_lft forever
21: qg-02d1751e-37: <broadcast,up,lower_up> <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether fa:16:3e:2b:90:87 brd ff:ff:ff:ff:ff:ff
    inet 10.60.85.100/16 brd 10.60.255.255 scope global qg-02d1751e-37
       valid_lft forever preferred_lft forever
    inet 10.60.85.101/32 brd 10.60.85.101 scope global qg-02d1751e-37
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe2b:9087/64 scope link
       valid_lft forever preferred_lft forever
root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd ip route
default via 10.60.1.1 dev qg-02d1751e-37
10.60.0.0/16 dev qg-02d1751e-37  proto kernel  scope link  src 10.60.85.100
192.168.1.0/24 dev qr-8c36733f-27  proto kernel  scope link  src 192.168.1.1
root@network:~#

root@network:~# root@network:~# ip netns exec qrouter-c301e1b2-f985-43fd-a6a8-0fbf7c221ecd iptables -t nat -L Chain PREROUTING (policy ACCEPT) target prot opt source destination neutron-l3-agent-PREROUTING all -- anywhere anywhere

anywhere Chain INPUT (policy ACCEPT) target prot opt source destination

destination Chain OUTPUT (policy ACCEPT) target prot opt source destination neutron-l3-agent-OUTPUT all -- anywhere anywhere

anywhere Chain POSTROUTING (policy ACCEPT) target prot opt source destination neutron-l3-agent-POSTROUTING all -- anywhere anywhere neutron-postrouting-bottom all -- anywhere anywhere

anywhere Chain neutron-l3-agent-OUTPUT (1 references) target prot opt source destination DNAT all -- anywhere 10.60.85.101 to:192.168.1.5

to:192.168.1.5 Chain neutron-l3-agent-POSTROUTING (1 references) target prot opt source destination ACCEPT all -- anywhere anywhere ! ctstate DNAT

DNAT Chain neutron-l3-agent-PREROUTING (1 references) target prot opt source destination REDIRECT tcp -- anywhere 169.254.169.254 tcp dpt:http redir ports 9697 DNAT all -- anywhere 10.60.85.101 to:192.168.1.5

to:192.168.1.5 Chain neutron-l3-agent-float-snat (1 references) target prot opt source destination SNAT all -- 192.168.1.5 anywhere to:10.60.85.101

to:10.60.85.101 Chain neutron-l3-agent-snat (1 references) target prot opt source destination neutron-l3-agent-float-snat all -- anywhere anywhere SNAT all -- 192.168.1.0/24 anywhere to:10.60.85.100

to:10.60.85.100 Chain neutron-postrouting-bottom (1 references) target prot opt source destination neutron-l3-agent-snat all -- anywhere anywhere

anywhere

in this moment I have one floating ip assigned by me: 10.65.85.101, the cirros server has 192.168.1.5 assigned from dhcp The other one was automatically assigned to the network:router_gateway that I can see from the dashboard

Thanks for your help