Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Neutron: Router port connected to external network is showing status Down

I have a external network 192.168.182.0/24 and I have unlinked the router to this external network using router-gateway-set command. However I see that router port (Type External Gateway) connected to this external network is showing down.

I even started a instance and associated the floating IP from this external pool to that VMs private IP address hoping that ,this may actually bring the port UP but still the problem persists. I am relatively new user of Openstack not played around all the neutron options. Am I missing any other configuration or is there something wrong with my installation ?

I have a multi-node setup of control,compute and network nodes.

root@controller:/home/regress# neutron router-port-list router1 -c status -c id +--------+--------------------------------------+ | status | id | +--------+--------------------------------------+ | ACTIVE | 5745b8d9-8187-4330-8fbe-c308252509ba | | DOWN | bb767dcf-d337-4ea5-8b68-b8a6a0496c90 | +--------+--------------------------------------+ root@controller:/home/regress# root@controller:/home/regress# root@controller:/home/regress# root@controller:/home/regress# root@controller:/home/regress# root@controller:/home/regress# root@controller:/home/regress# neutron port-show bb767dcf-d337-4ea5-8b68-b8a6a0496c90 +-----------------------+--------------------------------------------------------------------------------------+ | Field | Value | +-----------------------+--------------------------------------------------------------------------------------+ | admin_state_up | True | | allowed_address_pairs | | | binding:host_id | network | | binding:profile | {} | | binding:vif_details | {"port_filter": true, "ovs_hybrid_plug": true} | | binding:vif_type | ovs | | binding:vnic_type | normal | | device_id | 15273fc6-5519-4a34-b207-d28ea7794143 | | device_owner | network:router_gateway | | extra_dhcp_opts | | | fixed_ips | {"subnet_id": "b497969c-d1e1-482a-b678-0b5eecbad2ba", "ip_address": "192.168.182.2"} | | id | bb767dcf-d337-4ea5-8b68-b8a6a0496c90 | | mac_address | fa:16:3e:a1:47:c3 | | name | | | network_id | 18ee9a02-ef46-4c23-a46d-6a5514e8c891 | | security_groups | | | status | DOWN | | tenant_id | | +-----------------------+--------------------------------------------------------------------------------------+ root@controller:/home/regress#

Neutron: Router port connected to external network is showing status Down

I have a external network 192.168.182.0/24 and I have unlinked the router to this external network using router-gateway-set command. However I see that router port (Type External Gateway) connected to this external network is showing down.

I even started a instance and associated the floating IP from this external pool to that VMs private IP address hoping that ,this may actually bring the port UP but still the problem persists. I am relatively new user of Openstack not played around all the neutron options. Am I missing any other configuration or is there something wrong with my installation ?

I have a multi-node setup of control,compute and network nodes.

 root@controller:/home/regress# neutron router-port-list router1 -c status -c id                                                               +--------+--------------------------------------+
 | status | id                                   |
 +--------+--------------------------------------+
 | ACTIVE | 5745b8d9-8187-4330-8fbe-c308252509ba |
 | DOWN   | bb767dcf-d337-4ea5-8b68-b8a6a0496c90 |
 +--------+--------------------------------------+
 root@controller:/home/regress# 
 root@controller:/home/regress# 
 root@controller:/home/regress# 
 root@controller:/home/regress# 
 root@controller:/home/regress# 
 root@controller:/home/regress# 
 root@controller:/home/regress# neutron port-show bb767dcf-d337-4ea5-8b68-b8a6a0496c90                                                         +-----------------------+--------------------------------------------------------------------------------------+
 | Field                 | Value                                                                                |
 +-----------------------+--------------------------------------------------------------------------------------+
 | admin_state_up        | True                                                                                 |
 | allowed_address_pairs |                                                                                      |
 | binding:host_id       | network                                                                              |
 | binding:profile       | {}                                                                                   |
 | binding:vif_details   | {"port_filter": true, "ovs_hybrid_plug": true}                                       |
 | binding:vif_type      | ovs                                                                                  |
 | binding:vnic_type     | normal                                                                               |
 | device_id             | 15273fc6-5519-4a34-b207-d28ea7794143                                                 |
 | device_owner          | network:router_gateway                                                               |
 | extra_dhcp_opts       |                                                                                      |
 | fixed_ips             | {"subnet_id": "b497969c-d1e1-482a-b678-0b5eecbad2ba", "ip_address": "192.168.182.2"} |
 | id                    | bb767dcf-d337-4ea5-8b68-b8a6a0496c90                                                 |
 | mac_address           | fa:16:3e:a1:47:c3                                                                    |
 | name                  |                                                                                      |
 | network_id            | 18ee9a02-ef46-4c23-a46d-6a5514e8c891                                                 |
 | security_groups       |                                                                                      |
 | status                | DOWN                                                                                 |
 | tenant_id             |                                                                                      |
 +-----------------------+--------------------------------------------------------------------------------------+
root@controller:/home/regress# 

root@controller:/home/regress#