Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

'service openstack-nova-compute start' command doesn't works

Hi all,

I am trying to install icehouse which includes 3 nodes (controller, compute and block) and runs centos 6.6. I have installed identity and image service. Also, I have installed compute service on controller node. Than, I installed openstack-nova-compute service (not start yet) and edited nova.conf file on compute node. Than I tried to start nova-compute service using following command and response was 'Starting openstack-nova-compute: [ OK ]';

service openstack-nova-compute start

But service wasn't started and also there aren't any log file in /var/log/nova. I checked the nova-compute service with /etc/init.d/openstack-nova-compute status. The response was openstack-nova-compute dead but pid file exists. And checked openstack-status; The response was;

== Nova services ==
openstack-nova-api:                     inactive  (disabled on boot)
openstack-nova-compute:                 dead
openstack-nova-network:                 dead
openstack-nova-scheduler:               dead      (disabled on boot)
== Support services ==
mysqld:                                 dead      (disabled on boot)
libvirtd:                               active
messagebus:                             active

Than, I tried to start nova-compute service with followig command /usr/bin/nova-compute --debug and the service was started. And I check log file ,which in /var/log/nova/ folder, everthing was fine and also there isn't any error massege or like that.

I don't understand why the service wasn't started with neitherservice openstack-nova-compute start nor /etc/init.d/openstack-nova-compute start command . Howewer, İt worked with that command /usr/bin/nova-compute --debug.

PS: also compute-network service is in similar situation.

Did anybody experience such a case before?

Thanks to all.