Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

cannot ping the router on the tenant interface

i created a subnet in the ext-net using the following command:

neutron subnet-create ext-net --name ext-subnet \ --allocation-pool start=10.129.2.108,end=10.129.2.150 \ --disable-dhcp --gateway 10.129.1.250 10.129.0.0/16

I created a router using

neutron router-create demo-router

added a interface using

neutron router-interface-add demo-router demo-subnet

attached it to external network using command

neutron router-gateway-set demo-router ext-net

All these steps worked fine as per the guide i am following:

http://docs.openstack.org/icehouse/install-guide/install/apt/content/

But I cannot ping to this router external IP i.e. 10.129.2.108

neutron router-list shows:

+--------------------------------------+-------------+-----------------------------------------------------------------------------+ | id | name | external_gateway_info | +--------------------------------------+-------------+-----------------------------------------------------------------------------+ | aa004dfa-c882-4187-8242-8b8c2f961660 | demo-router | {"network_id": "0b4ceee5-7108-4b64-93fb-0f7c81ad3a01", "enable_snat": true} | +--------------------------------------+-------------+-----------------------------------------------------------------------------+

sudo ip netns exec qrouter-aa004dfa-c882-4187-8242-8b8c2f961660 ifconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:13 errors:0 dropped:0 overruns:0 frame:0 TX packets:13 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1176 (1.1 KB) TX bytes:1176 (1.1 KB)

qg-7c3ed541-23 Link encap:Ethernet HWaddr fa:16:3e:55:c7:97
inet addr:10.129.2.108 Bcast:10.129.255.255 Mask:255.255.0.0 inet6 addr: fe80::f816:3eff:fe55:c797/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:864 (864.0 B)

qr-5fbc0cd7-96 Link encap:Ethernet HWaddr fa:16:3e:49:64:76
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::f816:3eff:fe49:6476/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:2 errors:0 dropped:0 overruns:0 frame:0 TX packets:9 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:140 (140.0 B) TX bytes:738 (738.0 B)

As per the guide the br-ex had to be connected to the external network interface which i assumed is the one which does not have an IP assigned (the third interface on the network node). So, how can the external network connect to this router through this interface?

cannot ping the router on the tenant interface

i created a subnet in the ext-net using the following command:

neutron subnet-create ext-net --name ext-subnet \
--allocation-pool start=10.129.2.108,end=10.129.2.150 \
--disable-dhcp --gateway 10.129.1.250 10.129.0.0/16

10.129.0.0/16

I created a router using

neutron router-create demo-router 

added a interface using

neutron router-interface-add demo-router demo-subnet

demo-subnet attached it to external network using command

command neutron router-gateway-set demo-router ext-net

ext-net

All these steps worked fine as per the guide i am following:

http://docs.openstack.org/icehouse/install-guide/install/apt/content/

But I cannot ping to this router external IP i.e. 10.129.2.108

neutron router-list shows:

+--------------------------------------+-------------+-----------------------------------------------------------------------------+
| id                                   | name        | external_gateway_info                                                       |
+--------------------------------------+-------------+-----------------------------------------------------------------------------+
| aa004dfa-c882-4187-8242-8b8c2f961660 | demo-router | {"network_id": "0b4ceee5-7108-4b64-93fb-0f7c81ad3a01", "enable_snat": true} |
+--------------------------------------+-------------+-----------------------------------------------------------------------------+

+--------------------------------------+-------------+-----------------------------------------------------------------------------+ sudo ip netns exec qrouter-aa004dfa-c882-4187-8242-8b8c2f961660 ifconfig

ifconfig lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:13 errors:0 dropped:0 overruns:0 frame:0 TX packets:13 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1176 (1.1 KB) TX bytes:1176 (1.1 KB)

KB) qg-7c3ed541-23 Link encap:Ethernet HWaddr fa:16:3e:55:c7:97
inet addr:10.129.2.108 Bcast:10.129.255.255 Mask:255.255.0.0 inet6 addr: fe80::f816:3eff:fe55:c797/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:864 (864.0 B)

B) qr-5fbc0cd7-96 Link encap:Ethernet HWaddr fa:16:3e:49:64:76
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::f816:3eff:fe49:6476/64 Scope:Link UP BROADCAST RUNNING MTU:1500 Metric:1 RX packets:2 errors:0 dropped:0 overruns:0 frame:0 TX packets:9 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:140 (140.0 B) TX bytes:738 (738.0 B)

B)

As per the guide the br-ex had to be connected to the external network interface which i assumed is the one which does not have an IP assigned (the third interface on the network node). So, how can the external network connect to this router through this interface?