Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

lbaas configuration in havana multi-node setup

Steps followed by me to configure lbaas in havana multi-node (12.04 LTS)

  1. apt-get install neutron-lbaas-agent 2.vi /etc/neutron/neutron.conf service_provider = LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default 3.vi /etc/neutron/neutron.conf service_plugins = lbaas 4.vi /etc/neutron/lbaas_agent.ini device_driver = neutron.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver 5.vi /etc/neutron/lbaas_agent.ini interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver 6.restarting the neutron-server and neutron-lbaas-agent services. Enable load balancing in the Project section of the dashboard. on Ubuntu 7.vi /etc/openstack-dashboard/local_settings.py
    OPENSTACK_NEUTRON_NETWORK = { 'enable_lb': True, ... }

BUT provider is not showing in dashboard. I have attached scrrenshot please go through it.Screenshot from 2014-11-25 09:25:48.png

click to hide/show revision 2
No.2 Revision

lbaas configuration in havana multi-node setup

Steps followed by me to configure lbaas in havana multi-node (12.04 LTS)

  1.  1. apt-get install neutron-lbaas-agent
     2.vi /etc/neutron/neutron.conf  
    service_provider = LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default
     3.vi /etc/neutron/neutron.conf 
     service_plugins = lbaas
    lbaas 
    
    
    4.vi /etc/neutron/lbaas_agent.ini 
     device_driver = neutron.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver
     5.vi /etc/neutron/lbaas_agent.ini 
     interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
     6.restarting the neutron-server and neutron-lbaas-agent services.
     Enable load balancing in the Project section of the dashboard.
     on Ubuntu 
     7.vi /etc/openstack-dashboard/local_settings.py 
    OPENSTACK_NEUTRON_NETWORK = { 'enable_lb': True, ... }
  2. }

BUT provider is not showing in dashboard. I have attached scrrenshot please go through it.Screenshot it.[Screenshot from 2014-11-25 09:25:48.png

09:25:48.png](/upfiles/14168888472680341.png)