Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Not able to use OS::Heat::MultipartMime resource type in Heat.

I have this template which uses OS::MultipartMime to combine the CloudConfig and SoftwareConfig resource types. But when I try to run this or any template with heat I run into errors and the stack fails. Here is the the full trace of the error that I see in heat engine. I have tried multiple MultipartMime examples but all of them fail like this. Has anyone seen this before, found a workaround, or just have any clue how I can get around this for now?

2014-11-24 15:49:49.562 INFO heat.engine.stack [-] Stack CREATE FAILED (simple): Resource CREATE failed: TypeError: object of type 'NoneType' has no len()
Traceback (most recent call last):

  File "/usr/local/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 134, in _dispatch_and_reply
    incoming.message))

  File "/usr/local/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 177, in _dispatch
    return self._do_dispatch(endpoint, method, ctxt, args)

  File "/usr/local/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 123, in _do_dispatch
    result = getattr(endpoint, method)(ctxt, **new_args)

  File "/usr/local/lib/python2.7/dist-packages/osprofiler/profiler.py", line 105, in wrapper
    return f(*args, **kwargs)

  File "/opt/stack/heat/heat/engine/service.py", line 72, in wrapped
    return func(self, ctx, *args, **kwargs)

  File "/opt/stack/heat/heat/engine/service.py", line 1409, in show_software_config
    sc = db_api.software_config_get(cnxt, config_id)

  File "/opt/stack/heat/heat/db/api.py", line 258, in software_config_get
    return IMPL.software_config_get(context, config_id)

  File "/opt/stack/heat/heat/db/sqlalchemy/api.py", line 706, in software_config_get
    result = model_query(context, models.SoftwareConfig).get(config_id)

  File "/usr/lib/python2.7/dist-packages/sqlalchemy/orm/query.py", line 799, in get
    if len(ident) != len(mapper.primary_key):

TypeError: object of type 'NoneType' has no len()