Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

VMs not getting IP through DHCP

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can launch VM but What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

VMs not getting IP through DHCP

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can launch VM but What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

VMs not getting IP through DHCP

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can launch VM but What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

VMs not getting IP through DHCP

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can launch VM but What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

dnsmasq log on /var/log/neutron/dnsmasq.log

[hcuser@localhost ~]$ sudo tail -n50 /var/log/neutron/dnsmasq.log
Nov 20 12:21:53 dnsmasq[3982]: started, version 2.68 cachesize 150
Nov 20 12:21:53 dnsmasq[3982]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth
Nov 20 12:21:53 dnsmasq[3982]: warning: no upstream servers configured
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, static leases only on 10.0.0.0, lease time 1d
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, sockets bound exclusively to interface ns-0b36c82a-61
Nov 20 12:21:53 dnsmasq[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts - 3 addresses
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts

VMs not getting IP through DHCPDHCP private 10.x network unreachable

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I cano see the router and the dhcp namespace in ip netns But I can not ping 10.0.0.1 or 10.0.0.2. I can launch VM but But VM's are not getting IP from DHCP. What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

dnsmasq log on /var/log/neutron/dnsmasq.log

[hcuser@localhost ~]$ sudo tail -n50 /var/log/neutron/dnsmasq.log
Nov 20 12:21:53 dnsmasq[3982]: started, version 2.68 cachesize 150
Nov 20 12:21:53 dnsmasq[3982]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth
Nov 20 12:21:53 dnsmasq[3982]: warning: no upstream servers configured
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, static leases only on 10.0.0.0, lease time 1d
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, sockets bound exclusively to interface ns-0b36c82a-61
Nov 20 12:21:53 dnsmasq[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts - 3 addresses
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts

VMs not getting IP through DHCP private 10.x network unreachable

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I cano can see the router and the dhcp namespace in ip netns But I can not not ping 10.0.0.1 or 10.0.0.2. I can launch VM but But VM's are not getting IP from DHCP. What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

dnsmasq log on /var/log/neutron/dnsmasq.log

[hcuser@localhost ~]$ sudo tail -n50 /var/log/neutron/dnsmasq.log
Nov 20 12:21:53 dnsmasq[3982]: started, version 2.68 cachesize 150
Nov 20 12:21:53 dnsmasq[3982]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth
Nov 20 12:21:53 dnsmasq[3982]: warning: no upstream servers configured
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, static leases only on 10.0.0.0, lease time 1d
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, sockets bound exclusively to interface ns-0b36c82a-61
Nov 20 12:21:53 dnsmasq[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts - 3 addresses
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts

VMs not getting IP through DHCP private 10.x network unreachable

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can see the router and the dhcp namespace in ip netns But I can not ping 10.0.0.1 or 10.0.0.2. I can launch VM but But VM's are not getting IP from DHCP. What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

dnsmasq log on /var/log/neutron/dnsmasq.log

[hcuser@localhost ~]$ sudo tail -n50 /var/log/neutron/dnsmasq.log
Nov 20 12:21:53 dnsmasq[3982]: started, version 2.68 cachesize 150
Nov 20 12:21:53 dnsmasq[3982]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth
Nov 20 12:21:53 dnsmasq[3982]: warning: no upstream servers configured
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, static leases only on 10.0.0.0, lease time 1d
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, sockets bound exclusively to interface ns-0b36c82a-61
Nov 20 12:21:53 dnsmasq[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts - 3 addresses
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts

Also I cannot ping 10.0.0.1 from 10.0.0.2 and vice verse.

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
From 10.0.0.2 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
64 bytes from 10.0.0.2: icmp_seq=1 ttl=64 time=0.028 ms

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
From 10.0.0.1 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.027 ms

P.S. qrouter-xxxx having in interface with IP 10.0.0.1 and qdhcp-xxxx is having an interface with 10.0.0.2 and none can ping the outside network

VMs not getting IP through DHCP private 10.x network unreachable

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can see the router and the dhcp namespace in ip netns But I can not ping 10.0.0.1 or 10.0.0.2. I can launch VM but But VM's are not getting IP from DHCP. (The question is long with too many outputs attached please check more) What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

dnsmasq log on /var/log/neutron/dnsmasq.log

[hcuser@localhost ~]$ sudo tail -n50 /var/log/neutron/dnsmasq.log
Nov 20 12:21:53 dnsmasq[3982]: started, version 2.68 cachesize 150
Nov 20 12:21:53 dnsmasq[3982]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth
Nov 20 12:21:53 dnsmasq[3982]: warning: no upstream servers configured
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, static leases only on 10.0.0.0, lease time 1d
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, sockets bound exclusively to interface ns-0b36c82a-61
Nov 20 12:21:53 dnsmasq[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts - 3 addresses
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts

Also I cannot ping 10.0.0.1 from 10.0.0.2 and vice verse.

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
From 10.0.0.2 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
64 bytes from 10.0.0.2: icmp_seq=1 ttl=64 time=0.028 ms

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
From 10.0.0.1 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.027 ms

P.S. qrouter-xxxx having in interface with IP 10.0.0.1 and qdhcp-xxxx is having an interface with 10.0.0.2 and none can ping the outside network

as admin I can see L3 and dhcp agents up

[hcuser@localhost ~(keystone_admin)]$ neutron agent-list | less -S
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+
| id                                   | agent_type         | host                  | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+
| 291815be-b2fe-459c-8e77-0260f0aeafb1 | DHCP agent         | localhost.localdomain | :-)   | True           | neutron-dhcp-agent        |
| a703de55-f2e4-4b3f-b2f4-4433b1d8d1e9 | L3 agent           | localhost.localdomain | :-)   | True           | neutron-l3-agent          |
| c251aca1-c741-47d0-882a-fb8b94676da2 | Open vSwitch agent | localhost.localdomain | :-)   | True           | neutron-openvswitch-agent |
| edeafc76-3253-4970-862f-5b8cb6ce0353 | Metadata agent     | localhost.localdomain | :-)   | True           | neutron-metadata-agent    |
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+

But as demo user I see no service at all

[root@localhost ~(keystone_demo)]# neutron agent-list

[root@localhost ~(keystone_demo)]#

VMs not getting IP through DHCP private 10.x network unreachable

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can see the router and the dhcp namespace in ip netns But I can not ping 10.0.0.1 or 10.0.0.2. I can launch VM but But VM's are not getting IP from DHCP. (The question is long with too many outputs attached please check more) What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

dnsmasq log on /var/log/neutron/dnsmasq.log

[hcuser@localhost ~]$ sudo tail -n50 /var/log/neutron/dnsmasq.log
Nov 20 12:21:53 dnsmasq[3982]: started, version 2.68 cachesize 150
Nov 20 12:21:53 dnsmasq[3982]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth
Nov 20 12:21:53 dnsmasq[3982]: warning: no upstream servers configured
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, static leases only on 10.0.0.0, lease time 1d
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, sockets bound exclusively to interface ns-0b36c82a-61
Nov 20 12:21:53 dnsmasq[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts - 3 addresses
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts

Also I cannot ping 10.0.0.1 from 10.0.0.2 and vice verse.

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
From 10.0.0.2 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
64 bytes from 10.0.0.2: icmp_seq=1 ttl=64 time=0.028 ms

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
From 10.0.0.1 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.027 ms

P.S. qrouter-xxxx having in interface with IP 10.0.0.1 and qdhcp-xxxx is having an interface with 10.0.0.2 and none can ping the outside network

as admin I can see L3 and dhcp agents up

[hcuser@localhost ~(keystone_admin)]$ neutron agent-list | less -S
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+
| id                                   | agent_type         | host                  | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+
| 291815be-b2fe-459c-8e77-0260f0aeafb1 | DHCP agent         | localhost.localdomain | :-)   | True           | neutron-dhcp-agent        |
| a703de55-f2e4-4b3f-b2f4-4433b1d8d1e9 | L3 agent           | localhost.localdomain | :-)   | True           | neutron-l3-agent          |
| c251aca1-c741-47d0-882a-fb8b94676da2 | Open vSwitch agent | localhost.localdomain | :-)   | True           | neutron-openvswitch-agent |
| edeafc76-3253-4970-862f-5b8cb6ce0353 | Metadata agent     | localhost.localdomain | :-)   | True           | neutron-metadata-agent    |
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+

But as demo user I see no service at all

[root@localhost ~(keystone_demo)]# neutron agent-list

[root@localhost ~(keystone_demo)]#

ovs-vsctl show output:

[hcuser@localhost ~]$ sudo ovs-vsctl show
[sudo] password for hcuser: 
62c30134-97e2-4723-b42c-9474eb333885
    Bridge br-int
        fail_mode: secure
        Port "tap231aae57-ee"
            tag: 1
            Interface "tap231aae57-ee"
        Port "tap0b36c82a-61"
            tag: 4095
            Interface "tap0b36c82a-61"
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qvo7c65b9a6-a7"
            tag: 1
            Interface "qvo7c65b9a6-a7"
        Port br-int
            Interface br-int
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "tap5021e689-3f"
            Interface "tap5021e689-3f"
    ovs_version: "2.3.0"

VMs not getting IP through DHCP private 10.x network unreachable

I am logging in to dashboard through demo user that is having a private network of 10.0.0.0/24. I can see the router and the dhcp namespace in ip netns But I can not ping 10.0.0.1 or 10.0.0.2. I can launch VM but But VM's are not getting IP from DHCP. (The DHCP.

The question is long with too many many outputs attached please check more) click (more) at the bottom for full question

What I see in the console/log is

Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 180.96

VMs are having an eth0 iface that doesn't have an IPv4.

systemctl status neutron-dhcp-agent.service says active(running) but bridge interfaces are DOWN

$ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:22:4d:b1:3b:4f brd ff:ff:ff:ff:ff:ff
    inet 172.16.21.11/23 brd 172.16.21.255 scope global em1
       valid_lft forever preferred_lft forever
    inet6 fe80::222:4dff:feb1:3b4f/64 scope link 
       valid_lft forever preferred_lft forever
3: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether ea:fc:1c:48:e2:57 brd ff:ff:ff:ff:ff:ff
4: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 02:09:3f:7c:5b:49 brd ff:ff:ff:ff:ff:ff
5: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether 9e:7c:0d:20:16:46 brd ff:ff:ff:ff:ff:ff
7: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether b6:da:2f:93:dc:85 brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
8: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default 
    link/ether aa:94:26:b3:f0:46 brd ff:ff:ff:ff:ff:ff
9: qbr7c65b9a6-a7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::f0c7:e3ff:fea4:17bb/64 scope link 
       valid_lft forever preferred_lft forever
10: qvo7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 12:a2:36:0e:9d:5c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::10a2:36ff:fe0e:9d5c/64 scope link 
       valid_lft forever preferred_lft forever
11: qvb7c65b9a6-a7: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master qbr7c65b9a6-a7 state UP group default qlen 1000
    link/ether 06:73:bb:99:aa:a7 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::473:bbff:fe99:aaa7/64 scope link 
       valid_lft forever preferred_lft forever
12: tap0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether aa:fd:de:ff:59:61 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a8fd:deff:feff:5961/64 scope link 
       valid_lft forever preferred_lft forever
13: tap231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 4e:bb:8b:15:53:51 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4cbb:8bff:fe15:5351/64 scope link 
       valid_lft forever preferred_lft forever
14: tap5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether fe:08:af:58:d4:1e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::fc08:afff:fe58:d41e/64 scope link 
       valid_lft forever preferred_lft forever

-- EDIT --

ps -ef | grep dnsmasq:

[hcuser@localhost ~]$  ps -ef | grep dnsmasq
nobody    2651     1  0 11:29 ?        00:00:00 /sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf
nobody    4034     1  0 11:30 ?        00:00:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=ns-0b36c82a-61 --except-interface=lo --pid-file=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/pid --dhcp-hostsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host --addn-hosts=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts --dhcp-optsfile=/var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts --leasefile-ro --dhcp-range=set:tag0,10.0.0.0,static,86400s --dhcp-lease-max=256 --conf-file= --domain=openstacklocal

namespaces

[hcuser@localhost ~]$ ip netns 
qrouter-168fe615-95ea-4c72-824d-03a1b44921df
qdhcp-852f04cb-b478-4b08-ba25-77991a118497

interfaces in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: ns-0b36c82a-61: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:eb:b0:ad brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/16 brd 169.254.255.255 scope global ns-0b36c82a-61
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feeb:b0ad/64 scope link 
       valid_lft forever preferred_lft forever

nmap in dhcp namespace

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 nmap -sU -sT 10.0.0.2

Starting Nmap 6.45 ( http://nmap.org ) at 2014-11-20 11:42 IST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 10.0.0.2
Host is up (0.00017s latency).
Not shown: 1998 closed ports
PORT   STATE SERVICE
53/tcp open  domain
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds

tcpdump shows no traffic at all

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 tcpdump -ln -i ns-0b36c82a-61
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ns-0b36c82a-61, link-type EN10MB (Ethernet), capture size 65535 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

interfaces in router namespace

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ip addr list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: qr-231aae57-ee: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:ac:8a:da brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.1/24 brd 10.0.0.255 scope global qr-231aae57-ee
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:feac:8ada/64 scope link 
       valid_lft forever preferred_lft forever
3: qg-5021e689-3f: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:7c:ca:c2 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.226/28 brd 172.24.4.239 scope global qg-5021e689-3f
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe7c:cac2/64 scope link 
       valid_lft forever preferred_lft forever

dnsmasq log on /var/log/neutron/dnsmasq.log

[hcuser@localhost ~]$ sudo tail -n50 /var/log/neutron/dnsmasq.log
Nov 20 12:21:53 dnsmasq[3982]: started, version 2.68 cachesize 150
Nov 20 12:21:53 dnsmasq[3982]: compile time options: IPv6 GNU-getopt DBus no-i18n IDN DHCP DHCPv6 no-Lua TFTP no-conntrack ipset auth
Nov 20 12:21:53 dnsmasq[3982]: warning: no upstream servers configured
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, static leases only on 10.0.0.0, lease time 1d
Nov 20 12:21:53 dnsmasq-dhcp[3982]: DHCP, sockets bound exclusively to interface ns-0b36c82a-61
Nov 20 12:21:53 dnsmasq[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/addn_hosts - 3 addresses
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/host
Nov 20 12:21:53 dnsmasq-dhcp[3982]: read /var/lib/neutron/dhcp/852f04cb-b478-4b08-ba25-77991a118497/opts

Also I cannot ping 10.0.0.1 from 10.0.0.2 and vice verse.

[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
From 10.0.0.2 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qdhcp-852f04cb-b478-4b08-ba25-77991a118497 ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
64 bytes from 10.0.0.2: icmp_seq=1 ttl=64 time=0.028 ms

[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.2
PING 10.0.0.2 (10.0.0.2) 56(84) bytes of data.
From 10.0.0.1 icmp_seq=1 Destination Host Unreachable
[hcuser@localhost ~]$ sudo ip netns exec qrouter-168fe615-95ea-4c72-824d-03a1b44921df ping 10.0.0.1
PING 10.0.0.1 (10.0.0.1) 56(84) bytes of data.
64 bytes from 10.0.0.1: icmp_seq=1 ttl=64 time=0.027 ms

P.S. qrouter-xxxx having in interface with IP 10.0.0.1 and qdhcp-xxxx is having an interface with 10.0.0.2 and none can ping the outside network

as admin I can see L3 and dhcp agents up

[hcuser@localhost ~(keystone_admin)]$ neutron agent-list | less -S
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+
| id                                   | agent_type         | host                  | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+
| 291815be-b2fe-459c-8e77-0260f0aeafb1 | DHCP agent         | localhost.localdomain | :-)   | True           | neutron-dhcp-agent        |
| a703de55-f2e4-4b3f-b2f4-4433b1d8d1e9 | L3 agent           | localhost.localdomain | :-)   | True           | neutron-l3-agent          |
| c251aca1-c741-47d0-882a-fb8b94676da2 | Open vSwitch agent | localhost.localdomain | :-)   | True           | neutron-openvswitch-agent |
| edeafc76-3253-4970-862f-5b8cb6ce0353 | Metadata agent     | localhost.localdomain | :-)   | True           | neutron-metadata-agent    |
+--------------------------------------+--------------------+-----------------------+-------+----------------+---------------------------+

But as demo user I see no service at all

[root@localhost ~(keystone_demo)]# neutron agent-list

[root@localhost ~(keystone_demo)]#

ovs-vsctl show output:

[hcuser@localhost ~]$ sudo ovs-vsctl show
[sudo] password for hcuser: 
62c30134-97e2-4723-b42c-9474eb333885
    Bridge br-int
        fail_mode: secure
        Port "tap231aae57-ee"
            tag: 1
            Interface "tap231aae57-ee"
        Port "tap0b36c82a-61"
            tag: 4095
            Interface "tap0b36c82a-61"
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qvo7c65b9a6-a7"
            tag: 1
            Interface "qvo7c65b9a6-a7"
        Port br-int
            Interface br-int
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "tap5021e689-3f"
            Interface "tap5021e689-3f"
    ovs_version: "2.3.0"