Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rsync not working

Hi

I tried to follow the OpenStack installation guide to install Object Storage. After I configured the /etc/rsyncd.conf and change disable=yes to disable=no (/etc/xinetd.d/rsync) and restart xinetd, I could not get rsync working

I installed on CentOS 6.3 not Ubuntu (For ubuntu, I got a 7 nodes Swift cluster working like a charm)

The command I ran

rsync rsync://pub@localhost/

The error message I got in /var/log/rsyncd.log

2013/09/19 13:53:44 [7283] rsync: getpeername on fd0 failed: Transport endpoint
is not connected (107)

2013/09/19 13:53:44 [7283] rsync error: error in socket IO (code 10) at clientnaa me.c(171) [receiver=3.0.6]

2013/09/19 13:53:44 [7284] rsync: getpeername on fd0 failed: Transport endpoint
is not connected (107)

2013/09/19 13:53:44 [7284] rsync error: error in socket IO (code 10) at clientnaa me.c(171) [receiver=3.0.6]

The command line output from the above command is:

[root@snode01c node]# rsync rsync://pub@localhost/ rsync: read error: Connection reset by peer (104) rsync error: error in rsync protocol data stream (code 12) at io.c(759) [receiver=3.0.6]

Can any one help with the instruction about how to set up rsync for swift on CentOS?

rsync not workinghow to set up rsync for swift on CentOS?

Hi

I tried to follow the OpenStack installation guide to install Object Storage. After I configured the /etc/rsyncd.conf and change disable=yes to disable=no (/etc/xinetd.d/rsync) and restart xinetd, I could not get rsync working

I installed on CentOS 6.3 not Ubuntu (For ubuntu, I got a 7 nodes Swift cluster working like a charm)

The command I ran

rsync rsync://pub@localhost/

The error message I got in /var/log/rsyncd.log

2013/09/19 13:53:44 [7283] rsync: getpeername on fd0 failed: Transport endpoint
is not connected (107)

(107) 2013/09/19 13:53:44 [7283] rsync error: error in socket IO (code 10) at clientnaa me.c(171) [receiver=3.0.6]

[receiver=3.0.6] 2013/09/19 13:53:44 [7284] rsync: getpeername on fd0 failed: Transport endpoint
is not connected (107)

(107) 2013/09/19 13:53:44 [7284] rsync error: error in socket IO (code 10) at clientnaa me.c(171) [receiver=3.0.6]

The command line output from the above command is:

[root@snode01c node]# rsync rsync://pub@localhost/ rsync: read error: Connection reset by peer (104) rsync error: error in rsync protocol data stream (code 12) at io.c(759) [receiver=3.0.6]

Can any one help with the instruction about how to set up rsync for swift on CentOS?

how to set up rsync for swift on CentOS?

I tried to follow the OpenStack installation guide to install Object Storage. After I configured the /etc/rsyncd.conf and change disable=yes to disable=no (/etc/xinetd.d/rsync) and restart xinetd, I could not get rsync working

I installed on CentOS 6.3 not Ubuntu (For ubuntu, I got a 7 nodes Swift cluster working like a charm)

The command I ran

rsync rsync://pub@localhost/

The error message I got in /var/log/rsyncd.log

2013/09/19 13:53:44 [7283] rsync: getpeername on fd0 failed: Transport endpoint 
is not connected (107) 2013/09/19 13:53:44 [7283] rsync error: error in socket IO (code 10) at clientnaa me.c(171) clientnaame.c(171) [receiver=3.0.6] 2013/09/19 13:53:44 [7284] rsync: getpeername on fd0 failed: Transport endpoint
is not connected (107) 2013/09/19 13:53:44 [7284] rsync error: error in socket IO (code 10) at clientnaa me.c(171) [receiver=3.0.6]

clientnaame.c(171) [receiver=3.0.6]

The command line output from the above command is:

[root@snode01c node]# rsync rsync://pub@localhost/
 rsync: read error: Connection reset by peer (104)
 rsync error: error in rsync protocol data stream (code 12) at io.c(759) [receiver=3.0.6]

[receiver=3.0.6]

Can any one help with the instruction about how to set up rsync for swift on CentOS?