Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

asked 2014-10-25 17:48:18 -0600

job gravatar image

"Gateway is not valid on subnet" when enabling Neutron in Devstack

Devstack stable/juno

Local.conf:

SERVICE_TOKEN=azertytoken ADMIN_PASSWORD=nomoresecrete MYSQL_PASSWORD=stackdb RABBIT_PASSWORD=stackqueue SERVICE_PASSWORD=$ADMIN_PASSWORD FLOATING_RANGE=172.16.49.32/27 FIXED_RANGE=10.0.0.0/24 FIXED_NETWORK_SIZE=256 FLAT_INTERFACE=eth0 LOGFILE=$DEST/logs/stack.sh.log SCREEN_LOGDIR=$DEST/logs/screen LOGDAYS=2 SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5 SWIFT_REPLICAS=1 SWIFT_DATA_DIR=$DEST/data IMAGE_URLS+=",http://cloud.fedoraproject.org/fedora-20.x86_64.qcow2"

With this basic config, everyting seemed OK. After that I tried enabling Neutron but when I do ./stack the error appears. I just added to local.conf.

disable_service n-net enable_service q-svc enable_service q-agt enable_service q-dhcp enable_service q-l3 enable_service q-meta enable_service tempest

The gateway and devstack are out of the FLOATING_RANGE subnet by design. It worked with nova-network but, with neutron, It just doesn't. I even tried setting FLOATING_RANGE as the whole subtnet (172.16.49.0/24) but VM didn't get connectivity at all.

One more issue: when I enable neutron, public network is only present in admin project and private network is only present in demo project.

Any piece of advice would be appreciated.

Thanks

"Gateway is not valid on subnet" when enabling Neutron in Devstack

Devstack stable/juno

Local.conf:

SERVICE_TOKEN=azertytoken
ADMIN_PASSWORD=nomoresecrete
MYSQL_PASSWORD=stackdb
RABBIT_PASSWORD=stackqueue
SERVICE_PASSWORD=$ADMIN_PASSWORD
FLOATING_RANGE=172.16.49.32/27
FIXED_RANGE=10.0.0.0/24
FIXED_NETWORK_SIZE=256
FLAT_INTERFACE=eth0
LOGFILE=$DEST/logs/stack.sh.log
SCREEN_LOGDIR=$DEST/logs/screen
LOGDAYS=2
SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5
SWIFT_REPLICAS=1
SWIFT_DATA_DIR=$DEST/data
IMAGE_URLS+=",http://cloud.fedoraproject.org/fedora-20.x86_64.qcow2"

IMAGE_URLS+=",http://cloud.fedoraproject.org/fedora-20.x86_64.qcow2"

With this basic config, everyting seemed OK. After that I tried enabling Neutron but when I do ./stack the error appears. I just added to local.conf.

disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service tempest

tempest

The gateway and devstack are out of the FLOATING_RANGE subnet by design. It worked with nova-network but, with neutron, It just doesn't. I even tried setting FLOATING_RANGE as the whole subtnet (172.16.49.0/24) but VM didn't get connectivity at all.

One more issue: when I enable neutron, public network is only present in admin project and private network is only present in demo project.

Any piece of advice would be appreciated.

Thanks