Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Grizzly sandbox: VM does not get DHCP IP

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox - I checked the network adapters Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 68 on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.

Grizzly sandbox: VM does not get DHCP IP

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I run a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox - I checked the network adapters Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 68 on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.

Grizzly sandbox: VM does not get DHCP IP

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I run a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox to host the setup - I checked the network adapters node's Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 6868' on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.

Grizzly sandbox: VM does not get DHCP IP

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I run a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox to host the setup - I checked the network node's Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 68' on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.

Grizzly sandbox: VM does not get DHCP IP

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I run a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox to host the setup - I checked the network node's Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 68' on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.

Grizzly sandbox: VM does not get DHCP IP

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I run a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox to host the setup - I checked the network node's Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 68' on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.

Grizzly sandbox: VM does not get DHCP IP

Hi everyone,

I am trying to do a sandbox installation of Openstack as mentioned in multi node Grizzly sandbox guide which does an intial Virtualbox networking setup and then moves on to the actual Grizzly setup guide

I could go upto the last part of booting up a VM from the horizon UI. However, once the VM boots up it does not get the IP. After bootup, if I do a

nova list

on the controller - I do get an output:

| 665fe9ca-1474-43aa-9202-ae822f1db3da | linux_inst_1 | ACTIVE | net_proj_one=50.50.1.3 |

And even on the network node - the corresponding network's host file as present in:

/var/lib/quantum/dhcp/02f517d6-7913-46eb-95e6-a6899052ce65/host

is updated with an entry:

fa:16:3e:c4:61:dd,50-50-1-3.openstacklocal,50.50.1.3

However - the VM (I had used a TinyCore qemu linux appliance from - here does not get the IP. When I run a dhclient from within the tinycore linux guest - it just kept on sending Discover packets without any IP's assigned.

To confirm - I ran tcpdump -i any -nvv 'port 67 or port 68' on the Compute node and saw that DHCP request packets were coming in. But the same request packets were not being sent to the network node because the tcpdump command on network node was not producing any output.

As I was running VirtualBox to host the setup - I checked the network node's Promiscuous mode setting and they were correct. I verified this by running tcpdump -i any -nvv 'port 67 or port 68' on the network node and doing dhclient from a separated VM - the DHCP packet was received at network. However within the openstack setup - the tinycore linux guest sends request to the compute but it is not sent to the network node.

Can anyone please help me out on this?

Thanks.