Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

neutron-server.service won't start at OS boot time

Hi, have a question related to the deployment about the neutron-server.service inside a Openstack's Controller node

The main issue is that the neutron-server.service do not start at OS boot time.

[root@controller ~]# systemctl list-unit-files -t service | grep neutron-server neutron-server.service enabled

[root@controller ~]# systemctl status neutron-server.service neutron-server.service - OpenStack Neutron Server Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled) Active: failed (Result: timeout) since Sun 2014-10-05 14:28:05 CEST; 3min 12s ago Main PID: 1065 CGroup: /system.slice/neutron-server.service

Oct 05 14:28:00 controller systemd[1]: neutron-server.service operation timed out. Terminating. Oct 05 14:28:05 controller systemd[1]: Failed to start OpenStack Neutron Server. Oct 05 14:28:05 controller systemd[1]: Unit neutron-server.service entered failed state.

However when the OS start up if i start the service manually then neutron-server.service start up sucessfull.

[root@controller ~]# systemctl start neutron-server.service [root@controller ~]# systemctl status neutron-server.service neutron-server.service - OpenStack Neutron Server Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled) Active: active (running) since Sun 2014-10-05 14:32:19 CEST; 4s ago Main PID: 3456 (neutron-server) CGroup: /system.slice/neutron-server.service └─3456 /usr/bin/python /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /e...

At boot time the debug log /var/log/neutron/server.log INFO neutron.common.config [-] Logging enabled! INFO neutron.common.config [-] Config paste file: /usr/share/neutron/api-paste.ini INFO neutron.manager [-] Loading core plugin: neutron.plugins.ml2.plugin.Ml2Plugin INFO neutron.plugins.ml2.managers [-] Configured type driver names: ['gre'] INFO neutron.plugins.ml2.managers [-] Loaded type driver names: ['gre'] INFO neutron.plugins.ml2.managers [-] Registered types: ['gre'] INFO neutron.plugins.ml2.managers [-] Tenant network_types: ['gre'] INFO neutron.plugins.ml2.managers [-] Configured mechanism driver names: ['openvswitch'] INFO neutron.plugins.ml2.managers [-] Loaded mechanism driver names: ['openvswitch'] INFO neutron.plugins.ml2.managers [-] Registered mechanism drivers: ['openvswitch']

Warnings... neutron.openstack.common.db.sqlalchemy.session [-] 1) This application has not enabled MySQL traditional mode, which means silent data corruption may occur. Please encourage the application developers to enable this mode. 2) SQL connection failed. 10 attempts left. 3) SQL connection failed. 9 attempts left. .. n) SQL connection failed. 1 attempts left.

"This application has not enabled. MySQL traditional mode, which means silent data corruption may occur. Please encourage the application developers to enable this mode."

To avoid the warning issue related to the SQL_MODE i have configured the MariaDB service to include the TRADITIONAL sql mode.

[root@controller ~]# head -n 10 /etc/my.cnf [mysqld]

OpenStack MySQL Customization

bind-address = 192.168.100.10 default-storage-engine = innodb innodb_file_per_table collation-server = utf8_general_ci init-connect = 'SET NAMES utf8' character-set-server = utf8 sql_mode = TRADITIONAL

mysql -u root -popenstack -e 'select @@GLOBAL.sql_mode;'

@@GLOBAL.sql_mode STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

I think that the issue is not related to the mariadb sql_mode; the proposed solution to avoid the warning do not works.... :(

But... anyone knows why the neutron-server.service no not start at boot time

Many thanks in advance Simon

neutron-server.service won't start at OS boot time

Hi, have a question related to the deployment about the neutron-server.service inside a Openstack's Controller node

The main issue is that the neutron-server.service do not start at OS boot time.

[root@controller ~]# systemctl list-unit-files -t service | grep neutron-server
neutron-server.service                        enabled

enabled [root@controller ~]# systemctl status neutron-server.service neutron-server.service - OpenStack Neutron Server Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled) Active: failed **failed** (Result: timeout) since Sun 2014-10-05 14:28:05 CEST; 3min 12s ago Main PID: 1065 CGroup: /system.slice/neutron-server.service

/system.slice/neutron-server.service Oct 05 14:28:00 controller systemd[1]: neutron-server.service operation timed out. Terminating. Oct 05 14:28:05 controller systemd[1]: Failed to start OpenStack Neutron Server. Oct 05 14:28:05 controller systemd[1]: Unit neutron-server.service entered failed state.

state.

However when the OS start up if i start the service manually then neutron-server.service start up sucessfull.

[root@controller ~]# systemctl start neutron-server.service
[root@controller ~]# systemctl status neutron-server.service
neutron-server.service - OpenStack Neutron Server
   Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled)
   Active: active **active** (running) since Sun 2014-10-05 14:32:19 CEST; 4s ago
 Main PID: 3456 (neutron-server)
   CGroup: /system.slice/neutron-server.service
           └─3456 /usr/bin/python /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /e...

/e...

At boot time the debug log /var/log/neutron/server.log /var/log/neutron/server.log

INFO neutron.common.config [-] Logging enabled!
INFO neutron.common.config [-] Config paste file: /usr/share/neutron/api-paste.ini
INFO neutron.manager [-] Loading core plugin: neutron.plugins.ml2.plugin.Ml2Plugin
INFO neutron.plugins.ml2.managers [-] Configured type driver names: ['gre']
INFO neutron.plugins.ml2.managers [-] Loaded type driver names: ['gre']
INFO neutron.plugins.ml2.managers [-] Registered types: ['gre']
INFO neutron.plugins.ml2.managers [-] Tenant network_types: ['gre']
INFO neutron.plugins.ml2.managers [-] Configured mechanism driver names: ['openvswitch']
INFO neutron.plugins.ml2.managers [-] Loaded mechanism driver names: ['openvswitch']
INFO neutron.plugins.ml2.managers [-] Registered mechanism drivers: ['openvswitch']

['openvswitch'] Warnings... neutron.openstack.common.db.sqlalchemy.session [-] 1) This application has not enabled MySQL traditional mode, which means silent data corruption may occur. Please encourage the application developers to enable this mode. 2) SQL connection failed. 10 attempts left. 3) SQL connection failed. 9 attempts left. .. n) SQL connection failed. 1 attempts left.

left.

"This application has not enabled. MySQL traditional mode, which means silent data corruption may occur. Please encourage the application developers to enable this mode."

To avoid the warning issue related to the SQL_MODE i have configured the MariaDB service to include the TRADITIONAL sql mode.

[root@controller ~]# head -n 10 /etc/my.cnf
[mysqld]

[mysqld] # OpenStack MySQL Customization

Customization bind-address = 192.168.100.10 default-storage-engine = innodb innodb_file_per_table collation-server = utf8_general_ci init-connect = 'SET NAMES utf8' character-set-server = utf8 sql_mode = TRADITIONAL

TRADITIONAL # mysql -u root -popenstack -e 'select @@GLOBAL.sql_mode;'

@@GLOBAL.sql_mode;' @@GLOBAL.sql_mode STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,TRADITIONAL,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

STRICT_TRANS_TABLES,STRICT_ALL_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,**TRADITIONAL**,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION

I think that the issue is not related to the mariadb sql_mode; the proposed solution to avoid the warning do not works.... :(

But... anyone knows why the neutron-server.service no not start at boot time

Many thanks in advance Simon