Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Set up devstack with two ethernet interfaces

I'm trying to setup a devstack VM using virt-manager. The VM must have two interfaces: 1 interface to internet (eth0) and 1 interface to connect to another physical machine (eth1). I setup this at my local.conf:

[[local|localrc]]

DEST=/opt/stack

FLAT_INTERFACE=eth0

# Passwords and token
ADMIN_PASSWORD=admin
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50

# Fixed and floating subnets
FIXED_RANGE=10.100.27.0/24
#FLOATING_RANGE=192.168.200.0/24
NETWORK_GATEWAY=10.100.27.1
PUBLIC_NETWORK_GATEWAY=172.24.4.225
Q_FLOATING_ALLOCATION_POOL=start=172.24.4.226,end=172.24.4.231

# Reclone each time
RECLONE=yes

# Disable Nova Networking
disable_service n-net

# Neutron - Networking Service
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service q-metering
enable_service neutron

# Neutron - VPN as a Service
enable_service q-vpn

Q_PLUGIN=ml2
Q_ML2_PLUGIN_MECHANISM_DRIVERS=openvswitch
Q_ML2_PLUGIN_TYPE_DRIVERS=flat,vlan
ML2_VLAN_RANGES=physnet0:2000:2999,physnet1:3000:3999
ENABLE_TENANT_VLANS=True
PHYSICAL_NETWORK=physnet0
OVS_PHYSICAL_BRIDGE=br-eth0
OVS_BRIDGE_MAPPINGS=physnet0:br-eth0,physnet1:br-eth1

The devstack buildss successfuly. The instances created in openstack have internet communication. I then create a provider network that maps with physnet1:

neutron net-create provider --shared --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 3500

And create a subnet:

neutron subnet-create --name provider_subnet provider 10.100.28.0/24

I launch a VM and a router in this new network and they ping each other. Then I add eth1 to br-eth1 with:

ovs-vsctl add-br br-eth1 eth1

So that network maps in the eth1 interface. Then I connect a physical machine to eth1 with a network cable and set the the vlan ID 3500 for the interface. When I try to ping from the physical machine to the router or the VM inside devstack I don't get communication.

Is there any missing configuration in devstack local.conf?

Thank you

Set up devstack with two ethernet interfaces

I'm trying to setup a devstack VM using virt-manager. The VM must have two interfaces: 1 interface to internet (eth0) and 1 interface to connect to another physical machine (eth1). I setup this at my local.conf:

[[local|localrc]]

DEST=/opt/stack

FLAT_INTERFACE=eth0

# Passwords and token
ADMIN_PASSWORD=admin
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50

# Fixed and floating subnets
FIXED_RANGE=10.100.27.0/24
#FLOATING_RANGE=192.168.200.0/24
NETWORK_GATEWAY=10.100.27.1
PUBLIC_NETWORK_GATEWAY=172.24.4.225
Q_FLOATING_ALLOCATION_POOL=start=172.24.4.226,end=172.24.4.231

# Reclone each time
RECLONE=yes

# Disable Nova Networking
disable_service n-net

# Neutron - Networking Service
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service q-metering
enable_service neutron

# Neutron - VPN as a Service
enable_service q-vpn

Q_PLUGIN=ml2
Q_ML2_PLUGIN_MECHANISM_DRIVERS=openvswitch
Q_ML2_PLUGIN_TYPE_DRIVERS=flat,vlan
ML2_VLAN_RANGES=physnet0:2000:2999,physnet1:3000:3999
ENABLE_TENANT_VLANS=True
PHYSICAL_NETWORK=physnet0
OVS_PHYSICAL_BRIDGE=br-eth0
OVS_BRIDGE_MAPPINGS=physnet0:br-eth0,physnet1:br-eth1

The devstack buildss successfuly. The instances created in openstack have internet communication. I then create a provider network that maps with physnet1:

neutron net-create provider --shared --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 3500

And create a subnet:

neutron subnet-create --name provider_subnet provider 10.100.28.0/24

I launch a VM and a router in this new network and they ping each other. Then I add eth1 to br-eth1 with:

ovs-vsctl add-br br-eth1 eth1

So that network maps in the eth1 interface. Then I connect a physical machine to eth1 with a network cable and set the the vlan ID 3500 for the interface. When I try to ping from the physical machine to the router or the VM inside devstack I don't get communication.

Is there any missing configuration in devstack local.conf?

Thank you