Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

swift stat [Errno 111] Connection refused error

Hi All,

I am getting [Errno 111] Connection refused error, after i setup swift service. root@block1:/etc/swift# swift stat [Errno 111] Connection refused My Box settings:

root@block1:/etc/swift# ifconfig eth0 Link encap:Ethernet HWaddr 00:50:56:92:61:fc inet addr:10.100.1.156 Bcast:10.100.1.255 Mask:255.255.255.0

memcached.conf entry = -l 10.100.1.156

proxy-servr.conf : [filter:authtoken] paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

service_port = 5000

service_host = 10.100.1.150

auth_protocol = http auth_host = 10.100.1.150 auth_port = 35357

auth_uri = http://10.100.1.150:5000

admin_tenant_name = admin admin_user = admin admin_password = ADMIN_PASS delay_auth_decision = 1 cahce = swift.cache

use = egg:swift#memcache set log_name = cache memcached_servers = 10.100.1.156:11211

all the swift object, container, account, proxy services are running fine.

Kindly Help.

click to hide/show revision 2
No.2 Revision

swift stat [Errno 111] Connection refused error

Hi All,

I am getting [Errno 111] Connection refused error, after i setup swift service. service.

root@block1:/etc/swift# swift stat
[Errno 111] Connection refused

My Box settings:

root@block1:/etc/swift# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:56:92:61:fc
          inet addr:10.100.1.156  Bcast:10.100.1.255  Mask:255.255.255.0

Mask:255.255.255.0

memcached.conf entry = -l 10.100.1.156

10.100.1.156

proxy-servr.conf : [filter:authtoken] paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

service_port keystoneclient.middleware.auth_token:filter_factory #service_port = 5000

service_host 5000 #service_host = 10.100.1.150

10.100.1.150 auth_protocol = http auth_host = 10.100.1.150 auth_port = 35357

auth_uri 35357 #auth_uri = http://10.100.1.150:5000

http://10.100.1.150:5000 admin_tenant_name = admin admin_user = admin admin_password = ADMIN_PASS delay_auth_decision = 1 cahce = swift.cache

swift.cache

use = egg:swift#memcache set log_name = cache memcached_servers = 10.100.1.156:11211

10.100.1.156:11211

all the swift object, container, account, proxy services are running fine.

Kindly Help.

click to hide/show revision 3
No.3 Revision

swift stat [Errno 111] Connection refused error

Hi All,

I am getting [Errno 111] Connection refused error, after i setup swift service.

root@block1:/etc/swift# swift stat
[Errno 111] Connection refused

My Box settings:

root@block1:/etc/swift# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:56:92:61:fc
          inet addr:10.100.1.156  Bcast:10.100.1.255  Mask:255.255.255.0

memcached.conf entry = -l 10.100.1.156

proxy-servr.conf :
[filter:authtoken]
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory
#service_port = 5000
#service_host = 10.100.1.150
auth_protocol = http
auth_host = 10.100.1.150
auth_port = 35357
#auth_uri = http://10.100.1.150:5000
admin_tenant_name = admin
admin_user = admin
admin_password = ADMIN_PASS
delay_auth_decision = 1
cahce = swift.cache

use = egg:swift#memcache
set log_name = cache
memcached_servers = 10.100.1.156:11211

all the swift object, container, account, proxy services are running fine.

Update:

i have changed the bind_port to 80 and its listening :

root@block1:/etc/swift# netstat -tlnp | grep 80 
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 13379/python

keystone service runs fine.