Revision history [back]

click to hide/show revision 1
initial version

Not able to ssh VMs on compute node (instance console is also not available on horizon)

I am not able to ping or ssh my instances present on compute node as well as getting error on console on horizon for the same. VMs on controller node are accessible through controller node only but not through compute node. Vms on both hosts have same security group and ssh and ping enabled.

Machine and installation details:

I have multi node devstack installation in my system:

   MACHINE 1 (controller node): 12GB RAM (devstack installed openstack with following local.conf:

[[local|localrc]]

DEST=/opt/stack

enable_service s-proxy s-object s-container s-account

SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5

SWIFT_REPLICAS=1

SWIFT_DATA_DIR=$DEST/data/swift enable_service n-net q-svc q-agt q-dhcp q-l3 q-meta q-metering

LOGDAYS=1

LOGFILE=$DEST/logs/stack.sh.log SCREEN_LOGDIR=$DEST/logs/screen ADMIN_PASSWORD=quiet DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50 PUBLIC_INTERFACE=eth0

MACHINE 2 (Compute node): 4GB RAM (devstack installed compute with following local.conf)

[[local|localrc]]

DEST=/opt/stack LOGDAYS=1 VERBOSE=True LOGFILE=$DEST/logs/stack.sh.log SCREEN_LOGDIR=$DEST/logs/screen ADMIN_PASSWORD=quiet DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD SERVICE_TOKEN=a682f596-76f3-11e3-b3b2-e716f9080d50

PUBLIC_INTERFACE=eth0

HOST_IP=10.201.1.3 SERVICE_HOST=10.201.2.58 Q_HOST=$SERVICE_HOST

disable_all_services enable_service neutron n-cpu rabbit q-api q-agt

I have one NIC in both machines with eth0 interface