Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

cannot ssh into devstack host vm

I have a ubuntu-12.04.2-server-amd64.iso based vm hosted at 10.0.10.21 on a vSphere ESX server. I installed openstack with the devstack stack.sh on this vm. Everything went fine. I can ping out and ssh to machines on my vpn from 10.0.10.21, but I cannot ssh to it from other machines. I created users admin and kbroughton on the devstack host using the vmware console.

[laptop]$ ssh kbroughton@10.0.10.21
kbroughton@10.0.10.21's password: 
Permission denied, please try again. 
Permission denied (publickey,gssapi-with-mic,password).

I also tried stack and admin@10.0.10.21, but that doesn't have an ssh.

password didn't work, so i tried to set up passwordless

Using scp i copied my laptop id_rsa for kbroughton to /home/kbroughton/.ssh/authorized_keys

made the following changes to /etc/ssh/sshd_config

# explicitly allow users
AllowUsers kbroughton stack admin
# uncommented this
AuthorizedKeysFile %h/.ssh/authorized_keys 

sudo service ssh restart

double checked that openssh-server is installed and running. Of course they are.

What am i missing