Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

openstack juno using RDO -- stuck on error during nova install step

Ventured trying out Openstack Juno install using the info on this page : http://docs.openstack.org/trunk/install-guide/install/yum/content/basics-packages.html

Used Centos x64 v7.0 minimal server , EPEL repo installed and set in packstack answer file ( CONFIG_USE_EPEL=y ), SELinux on permissive mode and manually installing basic required packages like puppet, mariadb-galeria server and whatever it complained .. Now stuck on the nova install stage ..with an error message indicating nova-compute.service cannot start.. Any ideas ?

-- packstack error log -- 192.168.0.20_api_nova.pp: [ DONE ]
Applying 192.168.0.20_nova.pp 192.168.0.20_nova.pp: [ ERROR ]
Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.0.20_nova.pp Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.

--- tail nova-consoleauth.log -------------

2014-09-24 18:23:44.526 1662 ERROR oslo.messaging._drivers.impl_rabbit [req-17f065b9-a532-4c8e-8322-3ca776bb9238 ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

---- tail nova-cert.log ------------- 2014-09-24 18:24:52.828 1665 ERROR oslo.messaging._drivers.impl_rabbit [req-81a513b8-6501-4e08-bfc2-314a4a9ab98a ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

Other nova logs are all INFO msg..some issue with the RabbitMQ service login api credentials..not able to figure out..

openstack juno using RDO -- stuck on error during nova install step

Ventured trying out Openstack Juno install using the info on this page : http://docs.openstack.org/trunk/install-guide/install/yum/content/basics-packages.htmldocs.openstack.org/trunk/install-guide/install/yum/content/basics-packages.html

Used Centos x64 v7.0 minimal server , EPEL repo installed and set in packstack answer file ( CONFIG_USE_EPEL=y ), SELinux on permissive mode and manually installing basic required packages like puppet, mariadb-galeria server and whatever it complained .. Now stuck on the nova install stage ..with an error message indicating nova-compute.service cannot start.. Any ideas ?

-- packstack error log -- 192.168.0.20_api_nova.pp: [ DONE ]
Applying 192.168.0.20_nova.pp 192.168.0.20_nova.pp: [ ERROR ]
Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.0.20_nova.pp Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.

--- tail nova-consoleauth.log -------------

2014-09-24 18:23:44.526 1662 ERROR oslo.messaging._drivers.impl_rabbit [req-17f065b9-a532-4c8e-8322-3ca776bb9238 ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

---- tail nova-cert.log ------------- 2014-09-24 18:24:52.828 1665 ERROR oslo.messaging._drivers.impl_rabbit [req-81a513b8-6501-4e08-bfc2-314a4a9ab98a ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

Other nova logs are all INFO msg..some issue with the RabbitMQ service login api credentials..not able to figure out..

openstack juno using RDO -- stuck on error during nova install step

Ventured trying out Openstack Juno install using the info on this page : docs.openstack.org/trunk/install-guide/install/yum/content/basics-packages.html

Used Centos x64 v7.0 minimal server , EPEL repo installed and set in packstack answer file ( CONFIG_USE_EPEL=y ), SELinux on permissive mode and manually installing basic required packages like puppet, mariadb-galeria server and whatever it complained .. Now stuck on the nova install stage ..with an error message indicating nova-compute.service cannot start.. Any ideas ?

-- packstack error log -- --

192.168.0.20_api_nova.pp: [ DONE ]
Applying 192.168.0.20_nova.pp 192.168.0.20_nova.pp: [ ERROR ]
Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.0.20_nova.pp Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.

--- tail nova-consoleauth.log -------------

2014-09-24 18:23:44.526 1662 ERROR oslo.messaging._drivers.impl_rabbit [req-17f065b9-a532-4c8e-8322-3ca776bb9238 ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

---- tail nova-cert.log ------------- -------------

2014-09-24 18:24:52.828 1665 ERROR oslo.messaging._drivers.impl_rabbit [req-81a513b8-6501-4e08-bfc2-314a4a9ab98a ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

Other nova logs are all INFO msg..some issue with the RabbitMQ service login api credentials..not able to figure out..

openstack juno using RDO -- stuck on error during nova install step

Ventured trying out Openstack Juno install using the info on this page : docs.openstack.org/trunk/install-guide/install/yum/content/basics-packages.htmlhttp://docs.openstack.org/trunk/install-guide/install/yum/content/basics-packages.html

Used Centos x64 v7.0 minimal server , EPEL repo installed and set in packstack answer file ( CONFIG_USE_EPEL=y ), SELinux on permissive mode and manually installing basic required packages like puppet, mariadb-galeria server and whatever it complained .. Now stuck on the nova install stage ..with an error message indicating nova-compute.service cannot start.. Any ideas ?

-- packstack error log --

-- 192.168.0.20_api_nova.pp: [ DONE ]
Applying 192.168.0.20_nova.pp 192.168.0.20_nova.pp: [ ERROR ]
Applying Puppet manifests [ ERROR ]

] ERROR : Error appeared during Puppet run: 192.168.0.20_nova.pp Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.

details.

--- tail nova-consoleauth.log -------------

2014-09-24 18:23:44.526 1662 ERROR oslo.messaging._drivers.impl_rabbit [req-17f065b9-a532-4c8e-8322-3ca776bb9238 ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

closed

---- tail nova-cert.log -------------

 2014-09-24 18:24:52.828 1665 ERROR oslo.messaging._drivers.impl_rabbit [req-81a513b8-6501-4e08-bfc2-314a4a9ab98a ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

closed

Other nova logs are all INFO msg..some issue with the RabbitMQ service login api credentials..not able to figure out..

I rechecked the nova-compute logs and they have the same error message :

2014-09-24 18:23:32.060 9594 ERROR oslo.messaging._drivers.impl_rabbit [req-1b152ce0-6298-487a-b6cc-149024692b34 ] AMQP server 192.168.0.20:5672 closed the connection. Check login

openstack juno OpenStack Juno using RDO -- stuck on error during nova install stepfails installation: AMQP server closed the connection

Ventured trying out Openstack Juno install using the info on http://docs.openstack.org/trunk/install-guide/install/yum/content/basics-packages.html

Used Centos x64 v7.0 minimal server , EPEL repo installed and set in packstack answer file ( CONFIG_USE_EPEL=y ), SELinux on permissive mode and manually installing basic required packages like puppet, mariadb-galeria server and whatever it complained .. Now stuck on the nova install stage ..with an error message indicating nova-compute.service cannot start.. Any ideas ?

-- packstack error log --

192.168.0.20_api_nova.pp:                            [ DONE ]       
Applying 192.168.0.20_nova.pp
192.168.0.20_nova.pp:                             [ ERROR ]     
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.0.20_nova.pp
Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.

--- tail nova-consoleauth.log -------------

2014-09-24 18:23:44.526 1662 ERROR oslo.messaging._drivers.impl_rabbit [req-17f065b9-a532-4c8e-8322-3ca776bb9238 ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

---- tail nova-cert.log -------------

 2014-09-24 18:24:52.828 1665 ERROR oslo.messaging._drivers.impl_rabbit [req-81a513b8-6501-4e08-bfc2-314a4a9ab98a ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

Other nova logs are all INFO msg..some issue with the RabbitMQ service login api credentials..not able to figure out..

I rechecked the nova-compute logs and they have the same error message :

2014-09-24 18:23:32.060 9594 ERROR oslo.messaging._drivers.impl_rabbit [req-1b152ce0-6298-487a-b6cc-149024692b34 ] AMQP server 192.168.0.20:5672 closed the connection. Check login