Revision history [back]

click to hide/show revision 1
initial version

Devstack Single Machine Guide: IOError: [Errno 13] Permission denied: './worlddump-2014-09-15-081311.txt'

Hello, I am trying to install "Devstack for single machine" or "all-in-one" on Ubuntu 14.04 (Trusty) PC. After editing/creating file local.conf as per the guide described in http://devstack.org/guides/single-machine.html, I'm getting an error as attached bellow.

Any help will be appreciated, thanks in advance.

Building dependency tree       
Reading state information... Done
Note, selecting 'python' instead of 'python-wsgiref'
Note, selecting 'python-msgpack' instead of 'msgpack-python'
bc is already the newest version.
bridge-utils is already the newest version.
curl is already the newest version.
dnsmasq-base is already the newest version.
dnsmasq-utils is already the newest version.
ebtables is already the newest version.
euca2ools is already the newest version.
gawk is already the newest version.
gcc is already the newest version.
genisoimage is already the newest version.
git is already the newest version.
iptables is already the newest version.
kpartx is already the newest version.
libffi-dev is already the newest version.
libjs-jquery-tablesorter is already the newest version.
libldap2-dev is already the newest version.
libsasl2-dev is already the newest version.
libxslt1-dev is already the newest version.
libyaml-dev is already the newest version.
lsof is already the newest version.
lvm2 is already the newest version.
open-iscsi is already the newest version.
parted is already the newest version.
psmisc is already the newest version.
pylint is already the newest version.
python is already the newest version.
python-anyjson is already the newest version.
python-cheetah is already the newest version.
python-cherrypy3 is already the newest version.
python-coverage is already the newest version.
python-dateutil is already the newest version.
python-dev is already the newest version.
python-eventlet is already the newest version.
python-feedparser is already the newest version.
python-greenlet is already the newest version.
python-iso8601 is already the newest version.
python-kombu is already the newest version.
python-lockfile is already the newest version.
python-m2crypto is already the newest version.
python-migrate is already the newest version.
python-mox is already the newest version.
python-msgpack is already the newest version.
python-mysqldb is already the newest version.
python-nose is already the newest version.
python-numpy is already the newest version.
python-paste is already the newest version.
python-pastedeploy is already the newest version.
python-pastescript is already the newest version.
python-routes is already the newest version.
python-setuptools is already the newest version.
python-sqlalchemy is already the newest version.
python-tempita is already the newest version.
python-unittest2 is already the newest version.
python-webob is already the newest version.
python-xattr is already the newest version.
python2.7 is already the newest version.
screen is already the newest version.
sg3-utils is already the newest version.
sqlite3 is already the newest version.
sudo is already the newest version.
tar is already the newest version.
tcpdump is already the newest version.
tgt is already the newest version.
unzip is already the newest version.
vlan is already the newest version.
wget is already the newest version.
conntrack is already the newest version.
fping is already the newest version.
python-beautifulsoup is already the newest version.
python-mysql.connector is already the newest version.
python-pysqlite2 is already the newest version.
python-virtualenv is already the newest version.
socat is already the newest version.
sysfsutils is already the newest version.
iputils-arping is already the newest version.
iputils-ping is already the newest version.
libkrb5-dev is already the newest version.
libpq-dev is already the newest version.
libssl-dev is already the newest version.
libxml2-dev is already the newest version.
openssh-server is already the newest version.
openssl is already the newest version.
pm-utils is already the newest version.
python-libxml2 is already the newest version.
python-lxml is already the newest version.
python-sphinx is already the newest version.
python-suds is already the newest version.
qemu-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 112 not upgraded.
++ [[ -n False ]]
++ [[ False != \F\a\l\s\e ]]
++ date +%s
/home/onecloud/devstack/tools/install_prereqs.sh: line 80: /home/onecloud/devstack/.prereqs: Permission denied
+++ err_trap
+++ local r=1
+++ set +o xtrace
stack.sh failed
Error on exit
World dumping... see ./worlddump-2014-09-15-081311.txt for details
Traceback (most recent call last):
  File "/home/onecloud/devstack/tools/worlddump.py", line 86, in <module>
    sys.exit(main())
  File "/home/onecloud/devstack/tools/worlddump.py", line 78, in main
    with open(fname, 'w') as f:
IOError: [Errno 13] Permission denied: './worlddump-2014-09-15-081311.txt'